Bug 355091 - kyum isn't working after updating yum
kyum isn't working after updating yum
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-27 05:46 EDT by Thomas Wehrle
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 13:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Wehrle 2007-10-27 05:46:26 EDT
Description of problem:
kyum cannot process the ouput of yum. 

Version-Release number of selected component (if applicable):
kyum 0.7.5pre-001 (Using KDE 3.5.7-22.fc7 Fedora)

How reproducible:
Start kyum and click on "List Updates" or "List Installed" or "List 
available".

  
Actual results:

Process 11457 (yum) has been started.
Please be patient, this may be a lengthy operation...

(Command being executed: yum -y info installed).

Installed Packages
*** Traceback (most recent call last):
***   File "/usr/bin/yum", line 29, in <module>
***     yummain.main(sys.argv[1:])
***   File "/usr/share/yum-cli/yummain.py", line 105, in main
***     result, resultmsgs = base.doCommands()
***   File "/usr/share/yum-cli/cli.py", line 282, in doCommands
***     return self.yum_cli_commands[self.basecmd].doCommand(self, 
self.basecmd, self.extcmds)
***   File "/usr/share/yum-cli/yumcommands.py", line 168, in doCommand
***     rip = base.listPkgs(ypl.installed, 'Installed Packages', basecmd)
***   File "/usr/share/yum-cli/output.py", line 129, in listPkgs
***     self.infoOutput(pkg)
***   File "/usr/share/yum-cli/output.py", line 99, in infoOutput
***     print _("Summary: %s") % enc(pkg.summary)
***   File "/usr/share/yum-cli/output.py", line 86, in enc
***     t = gettext.dgettext(d, s)
***   File "/usr/lib/python2.5/gettext.py", line 530, in dgettext
***     codeset=_localecodesets.get(domain))
***   File "/usr/lib/python2.5/gettext.py", line 478, in translation
***     t = _translations.setdefault(key, class_(open(mofile, 'rb')))
***   File "/usr/lib/python2.5/gettext.py", line 180, in __init__
***     self._parse(fp)
***   File "/usr/lib/python2.5/gettext.py", line 313, in _parse
***     v = v.split(';')
*** AttributeError: 'list' object has no attribute 'split'
Process exited normally with code 1.


Expected results:


Additional info:
Comment 1 Thomas Wehrle 2007-10-27 16:48:25 EDT
sorry, it's not a problem of Kyum. It's a problem of yum. 
If I try  "yum -y info kdeutils", I get the same result:

yum -y info kdeutils
Installed Packages
Name   : kdeutils
Arch   : i386
Epoch  : 6
Version: 3.5.7
Release: 1.fc7.1
Size   : 10 M
Repo   : installed
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 105, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 282, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, 
sel                       f.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 168, in doCommand
    rip = base.listPkgs(ypl.installed, 'Installed Packages', basecmd)
  File "/usr/share/yum-cli/output.py", line 129, in listPkgs
    self.infoOutput(pkg)
  File "/usr/share/yum-cli/output.py", line 99, in infoOutput
    print _("Summary: %s") % enc(pkg.summary)
  File "/usr/share/yum-cli/output.py", line 86, in enc
    t = gettext.dgettext(d, s)
  File "/usr/lib/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'
Comment 2 Thomas Wehrle 2007-11-01 11:19:56 EDT
yum list installed is working. 
Only    "yum info" is not working.

rpm-python Verison 4.4.2.2-2.fc7 is installed
python-libs Version 2.5-14.fc7 is installed.

Comment 3 Mumrel 2007-11-01 12:15:25 EDT
I have this problem too.
If you need any additional info just ask.


Greetings
Comment 4 Jeremy Katz 2007-11-01 13:55:32 EDT

*** This bug has been marked as a duplicate of 252136 ***

Note You need to log in before you can comment on or make changes to this bug.