Bug 355161 - we need a way to configure channel mappin gin the UI (was: Creative Technology SB Live! 24-bit External plays 5.1 wrong)
we need a way to configure channel mappin gin the UI (was: Creative Technolog...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Patch
: 471864 (view as bug list)
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2007-10-27 08:15 EDT by David Nielsen
Modified: 2009-02-24 20:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 20:31:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2007-10-27 08:15:04 EDT
Description of problem:
I recently brought a nice set of Logitech Z-5450 Speakers which support 5.1,
however I've noticed when looking at the PulseAudio Volume App that despite a
5.1 movie with AC3 sound going in and being correctly detected the output to the
IEC958 port (Digital Coaxial) only shows 2 channels going out.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.16.svn20071017.fc8

How reproducible:
100%

Steps to Reproduce:
1. Buy expensive nice speakers, hook up to cheap integrate sound card
2. Fight PulseAudio to get output on non-default hw=0,2
  
Actual results:
Notice how you input 5.1 and get 2 channels out

Expected results:
Glorious 5.1 output

Additional info:
Comment 1 David Nielsen 2007-10-29 06:19:24 EDT
The gnome volume control keeps resetting the channel mode setting to 2ch instead
of 6ch as asked to. This doesn't smell like Pulseaudio is at fault, reassigning
to the kernel, thinking this is the ALSA driver but I'm unaware how to get more
information.

Comment 2 Chuck Ebbert 2007-10-29 18:11:26 EDT
Which kernel version?

And did you try completely disabling pulseaudio to rule it out? Uninstalling
pulseaudio and pulseaudio-plugins-alsa should be enough.
Comment 3 David Nielsen 2007-10-30 01:46:17 EDT
kernel-2.6.23.1-37.fc8

Removing all of PulseAudio still only yeilds stereo output
Comment 4 David Nielsen 2007-11-08 08:33:33 EST
interestingly, the same thing happens when I plug in this newly bought Sound
Blaster Surround 5.1 USB card when connected to the speakers using a TOSLINK
cable. I tested the speaker arrangement by plugging it directly into my DVD
player using the TOSLINK and that played back DTS 5.1 beautifully.
Comment 5 Lennart Poettering 2007-11-11 12:38:57 EST
Currently, PulseAudio opens audio devices in Stereo only by default. You need
some manual configuration to actviate surround support.

The reason for this is PA can hardly guess how many boxes you actually connected
to your PC and how they are positioned in your room.

I am working to make this a bit easier to configure, i.e. by right clicking on a
device in pavucontrol, and selecting from a small popup menu your setup from a
couple possible setups. (i.e. "Analog Stereo", "Analog 4.0", "Analog 4.1",
"Analog 2.1", "Analog 5.1", "Digital" and so on).

Stay tuned.
Comment 6 Lennart Poettering 2007-11-11 12:41:40 EST
Oh, and this in fact is a limitation of PA and probably has nothing to do with
the kernel.

And also, please not that PA only very unlikely will ever do AC-3 encoding for
you, due to patents.
Comment 7 David Nielsen 2007-11-11 13:03:21 EST
So long as I can do AC3 passthrough I believe the hardware I have will do the
actual decoding for me.
Comment 8 David Nielsen 2008-01-26 22:37:47 EST
Lennart, is there any progress in providing some UI to set this. One problem
that occures from this is that video files contain AC3 sound is that the audio
gets directed to the wrong channels using Totem I only have what sounds like the
center channel directed out the left speaker.. entirely unusable in other words.
Playing the same file with mplayer the audio gets down sampled to 2 channels
correctly (though the volume is very low).
Comment 9 Mike Gahagan 2008-04-17 15:27:04 EDT
I have a SB-Live 24-bit usb external card as well. I have only tried stereo
output through the coax-digital output, but it only works when I connect the usb
device before booting the system.

If I connect it after the system boots the only thing I get through the digital
coax out is the little start-up sound and then nothing. aplay will not even show
the iec958 device, but using the surround71 device will result in 2-channel
audio played out through the coax port. 

Something else is going on here and I don't think this is only pulseaudio's fault :)

I'm still looking into the various problems I am seeing. I also find that the
analog line outputs do not work at all, but the headphone jack does.
Comment 10 Bug Zapper 2008-05-13 23:45:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 David Nielsen 2008-06-02 08:32:23 EDT
OpenSUSE 11 now has the UI for doing this:

http://dev.compiz-fusion.org/~cyberorg/2008/06/02/opensuse-touch-to-pulseaudio/
Comment 12 David Nielsen 2008-10-12 06:00:45 EDT
Reassigning to rawhide as there still isn't UI to change this. Lennart can you comment on the openSUSE patch?
Comment 13 John Poelstra 2008-10-15 17:22:20 EDT
This bug has been triaged
Comment 14 Lennart Poettering 2008-10-20 07:25:51 EDT
TheOpenSUSE patch is a too limited and makes a per-device setting global. I don't think it is a good idea to merge that.
Comment 15 Bug Zapper 2008-11-25 21:02:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Lennart Poettering 2008-12-18 09:09:29 EST
*** Bug 471864 has been marked as a duplicate of this bug. ***
Comment 17 Lennart Poettering 2009-02-24 20:31:29 EST
There's now an upstream bug for this for g-v-c.

http://bugzilla.gnome.org/show_bug.cgi?id=572217

Note You need to log in before you can comment on or make changes to this bug.