Bug 471864 - Pulseaudio only uses 2 channels on a multichannel sound device
Pulseaudio only uses 2 channels on a multichannel sound device
Status: CLOSED DUPLICATE of bug 355161
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-11-17 05:28 EST by Steve Hill
Modified: 2008-12-18 09:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-18 09:09:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2008-11-17 05:28:33 EST
Description of problem:
Pulseaudio only uses the front 2 speakers on a SB Live (EMU10K1) sound card which supports 4 speakers.  This is not only the default setting, but there is no way to fix it without manually hacking the config files.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Rawhide on machine with multichannel sound card
2. Try playing sound through rear speakers
3. Observe silence
Actual results:
Pulseaudio only sees 2 channels on the hardware, even though "aplay -L" clearly lists a "surround40" subdevice with 4 channels.

Expected results:
Pulseaudio should detect the existence of a multichannel device and enable the extra channels, or at the very least allow the user to select the appropriate subdevice.

Additional info:
The work-around is to add "default-sample-channels = 4" to /etc/pulse/daemon.conf, but this changes the number of channels seen on all the other sound cards in the machine too, which may not be what you want.
Comment 1 Bug Zapper 2008-11-26 00:30:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 2 Lennart Poettering 2008-12-08 13:26:10 EST
Unfortunately there is now way to magically detect what kind of speakers you have actually connected to your sound cards. We can't know if it is 2.0, 3.1, 4.0, 5.0, 5.1, 7.0, 7.1 or any other weird setup. That means you will always have to configure something manually. Right now this is done via editing configuration files. In the future we will allow that via a simple UI.
Comment 3 Steve Hill 2008-12-08 13:42:21 EST
This quite clearly is a bug - "upgrading" caused my system went from all my speakers working to only 2 of them working, with no indication as to how to fix it.

Additionally, as I mentioned, the workaround affects *all* the sound cards in the system, which is probably not what you want.
Comment 4 Lennart Poettering 2008-12-18 09:09:29 EST

*** This bug has been marked as a duplicate of bug 355161 ***

Note You need to log in before you can comment on or make changes to this bug.