Bug 356371 - nash ignores root mount options with nfsroot
nash ignores root mount options with nfsroot
Status: CLOSED DUPLICATE of bug 240745
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 08:23 EDT by Jens Osterkamp
Modified: 2008-04-30 11:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 11:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
probable fix (436 bytes, patch)
2007-10-29 08:23 EDT, Jens Osterkamp
no flags Details | Diff
probable fix, 2nd try (432 bytes, patch)
2007-10-29 08:44 EDT, Jens Osterkamp
no flags Details | Diff

  None (edit)
Description Jens Osterkamp 2007-10-29 08:23:24 EDT
Description of problem:
When generating an initrd for mkzimage the specified rootopts put into the init
script in the initrd as mount options for nfsroot.
But when the image is booted and the init script is executed, the mount options
are ignored and are always set to kernel defaults.

Version-Release number of selected component (if applicable):
6.0.19-3

How reproducible:
Every time by building zImage with mkinitrd and mkzimage. 

Steps to Reproduce:
1. Create initrd with e.g.
mkinitrd --with=tg3 --rootopts=tcp,nolock,rsize=4096,wsize=4096 --net-dev=eth0
--rootfs=nfs /boot/initrd-2.6.22-5.20070920bsc.img 2.6.22-5.20070920bsc
2. create zImage with
mkzimage /boot/vmlinuz-2.6.22-5.20070920bsc no no
/boot/initrd-2.6.22-5.20070920bsc.img /usr/share/ppc64-utils/zImage.stub
/boot/zImage-2.6.22-5.20070920bsc
3.boot the image and take a look at /proc/mounts.
  
Actual results:

rootfs is still mounted with udp even though tcp was specified.

Expected results:

rootfs should be mounted with tcp, rsize=4096, wsize=4096

Additional info:

I created a patch which fixes the problem for me. Will attach to this bug.
Comment 1 Jens Osterkamp 2007-10-29 08:23:24 EDT
Created attachment 241741 [details]
probable fix
Comment 2 Jens Osterkamp 2007-10-29 08:44:45 EDT
Created attachment 241771 [details]
probable fix, 2nd try
Comment 3 Hanns-Joachim Uhl 2008-01-28 13:01:01 EST
Hello Peter,
do you have any news on this bugzilla with regards to Fedora 8 or 9 ..?
Will it be fixed with an update for Fedora 8 ..? 
Or only with Fedora 9 ..?
Please advise.
Thanks in advance for your support.
Comment 4 Ian Dall 2008-04-30 09:09:55 EDT
This looks like a duplicate of 240745
Comment 5 Jens Osterkamp 2008-04-30 09:25:53 EDT
Yes, looks very similar. AFAICT it is not yet fixed in Fedora.
Comment 6 Jochen Roth 2008-04-30 11:19:33 EDT
I suggest to close this bug as a duplicate of yours.
Your bug is 5 months! older. We can celebrate his first birthday in 3 weeks.

*** This bug has been marked as a duplicate of 240745 ***

Note You need to log in before you can comment on or make changes to this bug.