Bug 240745 - nash nfsmount doesn't respect mount options + proposed patch
nash nfsmount doesn't respect mount options + proposed patch
Status: CLOSED DUPLICATE of bug 444973
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
: 356371 (view as bug list)
Depends On:
Blocks: 444973
  Show dependency treegraph
Reported: 2007-05-21 08:39 EDT by Pavol Šimo
Modified: 2009-02-17 14:40 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-17 14:40:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix processing of nfs mount options (421 bytes, patch)
2008-04-30 08:56 EDT, Ian Dall
no flags Details | Diff

  None (edit)
Description Pavol Šimo 2007-05-21 08:39:04 EDT
From the current nash code:
char * foo = NULL;
if (nfsmount(device, mntPoint, &flags, &foo, &options, 0)) {
so the actual options are the 5th argument to nfsmount.
That is argument declared char **mount_opts.
But the options parsing loop operates on the variable old_opts (as is in the
original nfsmount.c from nfs-utils, but that's inside the parse_options
routine), which is constructed from extra_opts.
Hence the patch corrects the behaviour using mount_opts.

--- nfsmount.c.orig     2006-10-04 20:28:35.000000000 +0200
+++ nfsmount.c  2007-05-21 14:36:03.000000000 +0200
@@ -323,7 +323,7 @@
        /* add IP address to mtab options for use when unmounting */
        s = inet_ntoa(server_addr.sin_addr);
-       old_opts = *extra_opts;
+       old_opts = *mount_opts;
        if (!old_opts)
                old_opts = "";
        if (strlen(old_opts) + strlen(s) + 10 >= sizeof(new_opts)) {
Comment 1 Bug Zapper 2008-04-03 20:49:15 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 Ian Dall 2008-04-30 08:56:58 EDT
Created attachment 304221 [details]
Patch to fix processing of nfs mount options
Comment 3 Ian Dall 2008-04-30 09:01:22 EDT
The bug still appears in Fedora 8 and development. That is mkinitrd-6.0.19-4.fc8
and mkinitrd-6.0.52-1.fc9. See the above patch. I can't change status or version.
Comment 4 Jochen Roth 2008-04-30 11:19:34 EDT
*** Bug 356371 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-05-13 22:55:29 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 7 Andrew McNabb 2008-12-02 15:39:20 EST
Has this bug been fixed yet?  I've run into similar symptoms in Fedora 10, so I'm curious if it's the same cause.

I noticed that there's a patch attached.  Is there any particular reason that it wouldn't be applied?  Thanks.
Comment 8 Peter Jones 2009-02-17 14:40:41 EST

*** This bug has been marked as a duplicate of bug 444973 ***

Note You need to log in before you can comment on or make changes to this bug.