Bug 357841 - xscreensaver demo's crash gnome session
xscreensaver demo's crash gnome session
Status: CLOSED DUPLICATE of bug 336331
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
: 361741 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 05:20 EDT by J.Jansen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 05:19:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (3.51 KB, application/octet-stream)
2007-10-30 11:27 EDT, J.Jansen
no flags Details
/var/log/Xorg.0.log (32.19 KB, text/plain)
2007-10-30 11:28 EDT, J.Jansen
no flags Details
output of "rpm -qa | sort" (38.03 KB, text/plain)
2007-10-30 11:29 EDT, J.Jansen
no flags Details

  None (edit)
Description J.Jansen 2007-10-30 05:20:00 EDT
Description of problem: After upgrading to the current version of xscreenaver
and rebooting the machine most xscreensaver demo's crash the gnome session on my
Acer1700.


Version-Release number of selected component (if applicable):
5.03-12.fc7

How reproducible:
do not know, since I did this on one machine only.

Steps to Reproduce:
1.upgrade xscreensaver packages to 5.03-12.fc7
2.reboot
3.run xscreensaver either as screensaver or demo's in "preview" mode
  
Actual results:
crash of gnome session

Expected results:
nice annimation on the screen

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2007-10-30 05:25:38 EDT
What video driver, and which screensavers?
Comment 2 J.Jansen 2007-10-30 07:10:04 EDT
It is a SIS M650 video card, using a "standard" driver from F8.

Most demo's crash i.e : I just let it crash with Voronoi
But the same holds for many others

       
Comment 3 J.Jansen 2007-10-30 07:13:51 EDT
Sorry I'm not running F8 but F7.
Comment 4 J.Jansen 2007-10-30 07:17:03 EDT
I'm not sure, but I think all GL-modes give the problem
Comment 5 Mamoru TASAKA 2007-10-30 08:36:03 EDT
Would you "attach" the following?
- /etc/X11/xorg.conf
- /var/log/Xorg.0.log
- the result of "rpm -qa | sort"

Please don't write directly on this bug report but attach the log.
Comment 6 J.Jansen 2007-10-30 11:27:04 EDT
Created attachment 243561 [details]
/etc/X11/xorg.conf
Comment 7 J.Jansen 2007-10-30 11:28:38 EDT
Created attachment 243571 [details]
/var/log/Xorg.0.log
Comment 8 J.Jansen 2007-10-30 11:29:26 EDT
Created attachment 243581 [details]
output of "rpm -qa | sort"
Comment 9 Mamoru TASAKA 2007-10-30 12:11:27 EDT
(In reply to comment #8)
> Created an attachment (id=243581) [edit]
> output of "rpm -qa | sort"
> 

xscreensaver-5.03-12.fc7
xscreensaver-base-5.03-12.fc7
xscreensaver-debuginfo-5.03-12.fc7
xscreensaver-extras-5.03-12.fc7
xscreensaver-gl-extras-5.03-12.fc7

Well, this should not be.
Did you upgrade xscreensaver by yum? Now xscreensaver-gl-extras
5.03-12.fc7 requires xscreensaver-gl-base
$ rpm -qp --requires xscreensaver-gl-extras-5.03-12.fc7.i386.rpm | grep xscreensaver
xscreensaver-gl-base = 1:5.03-12.fc7
Comment 10 J.Jansen 2007-10-31 04:09:17 EDT
thanks that helped.

I sed yumex to update. As far as I know this is a graphical shell around yum. It
should have picked up the dependencies.

              Jouk
Comment 11 Mamoru TASAKA 2007-10-31 04:36:02 EDT
So would you check if your problem still appears if you install
xscreensaver-gl-base?
Comment 12 J.Jansen 2007-10-31 04:50:28 EDT
As I said: it helped. The problem is gone after installation of xscreensaver-gl-base

Comment 13 Mamoru TASAKA 2007-10-31 05:19:06 EDT
Oh.. I missed it...

(In reply to comment #10)
> thanks that helped.

Thank you for verifing this.

*** This bug has been marked as a duplicate of 336331 ***
Comment 14 Mamoru TASAKA 2007-11-01 13:01:24 EDT
*** Bug 361741 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.