Bug 361741 - Voronoi screensaver crashes Xscreensaver
Voronoi screensaver crashes Xscreensaver
Status: CLOSED DUPLICATE of bug 357841
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-01 09:34 EDT by Michael Cronenworth
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-01 13:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2007-11-01 09:34:32 EDT
Description of problem: The screensaver named "Voronoi" is selected to be the
screensaver and the screensaver activates. Then you move your mouse or press
keys to bring up the password box. Upon input the password box will appear for a
split second before disappearing -- giving full access to the logged in user
without prompting/checking the password. In other words, Xscreensaver has
crashed (missing from ps -ef list) and has to be restarted. This only started to
happen after the last Xscreensaver package upgrade. If I select any other
screensaver, it will not crash and works properly.

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. Select Voronoi
2. Lock screen
3. Move mouse or press keys to attempt password authentication
Actual results: Xscreensaver crashes

Expected results: Password box appears to authenticate user.

Additional info: 32-bit Pentium 4 3.0ghz with HT and all the latest package updates.
Comment 1 Mamoru TASAKA 2007-11-01 09:46:25 EDT
What does "rpm -qa | grep xscreensaver | sort" say?
Comment 2 Michael Cronenworth 2007-11-01 12:47:08 EDT
I apologize, I should have originally included that for completeness.

$ rpm -qa | grep xscreensaver | sort
Comment 3 Michael Cronenworth 2007-11-01 12:55:37 EDT
Ah ha... your question got me to thinking.

I checked your changelog and it says you split up the gl packages. I installed
xscreensaver-gl-base package and the voronoi screensaver no longer crashes.

Is there no dependency on xscreensaver-gl-extras requiring xscreensaver-gl-base?
If not, there should be. Feel free to close this bug, if appropriate.
Comment 4 Mamoru TASAKA 2007-11-01 13:01:23 EDT
Well, xscreensaver-gl-extras-1:5.03-12.fc7 actually requires

[tasaka1@localhost i386]$ rpm -qp --requires
xscreensaver-gl-extras-5.03-12.fc7.i386.rpm | grep xscreensaver
xscreensaver-gl-base = 1:5.03-12.fc7

So the correct behavior is that xscreensaver-gl-base should already be
installed in your system... Anyway thank you for reporting.

*** This bug has been marked as a duplicate of 357841 ***

Note You need to log in before you can comment on or make changes to this bug.