Bug 35804 - Exception during install
Exception during install
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-12 09:47 EDT by Hemant Gandre
Modified: 2007-03-26 23:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 00:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hemant Gandre 2001-04-12 09:47:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT)


Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: xloadimage

Local variables in innermost frame:
self: <comps.HeaderList instance at 823ba78>
item: xloadimage

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Reproducible: Always
Steps to Reproduce:
1.Start installation
2.It will occur while server install
3.
	

Expected Results:  Continue with normal installation
Comment 1 Brent Fox 2001-04-12 12:54:53 EDT
I think something is wrong with your cd or something got corrupted during your
download.

*** This bug has been marked as a duplicate of 18019 ***
Comment 2 Hemant Gandre 2001-04-12 13:04:49 EDT
No, I downloaded anaconda* files again just to cross-check. Same result again, 
hence I posted this bug.
Comment 3 Brent Fox 2001-04-12 15:12:52 EDT
No, I think at least some of the packages themselves are corrupt.  Anaconda is
doing the right thing...trying to install the packages, but it blows up when it
can't find (or uncompress) the package it is looking for.

What kind of install are you trying to do?
Comment 4 Hemant Gandre 2001-04-13 05:30:48 EDT
I am trying to install Linux Server. How do I check which packages are corrupt. 
I have checked file sizes they do match perfectly.
Comment 5 Brent Fox 2001-04-15 17:53:18 EDT
No, I mean what kind of installation type (CDROM, hard drive, nfs, ftp, http)?
It sounds like you are trying to do a hard drive install.  If so, please try
downloading the iso images for the first and second discs, store them on a
partition on your hard drive, and boot with the boot.img disk.  If you still see
the problem, run the md5sum program on the iso images and compare them to the
md5sums that you see on the ftp site.
Comment 6 Brent Fox 2001-04-20 00:40:03 EDT

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.