Bug 358591 - Missing TLB flush with SVM ASIDs
Missing TLB flush with SVM ASIDs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
http://lists.xensource.com/archives/h...
:
Depends On: 318891
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 13:06 EDT by Markus Armbruster
Modified: 2008-05-21 10:59 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2007-10-30 13:06:17 EDT
Found on xen-devel (see URL), not sure whether we need it, see URL field for
patch.  Quote from there:

But, with SVM ASIDs, it is possible to:
(1) Update CR3 update,
(2) vmenter the guest, and
(3) and vmexit due to a page fault
all without an intervening host TLB flush.

Then the page fault code could use the linear pagetable
to read a top-level shadow page table entry.

But, without this change, it would fetch the wrong value
due to a stale TLB.
Comment 1 Markus Armbruster 2007-10-31 03:55:03 EDT
Fixed in xen-3.1-testing.hg cset 15491:3ce0fb37cf59
Comment 2 Bill Burns 2008-01-03 09:11:11 EST
This issue was fixed by the rebase to the Xen 3.1.2 Hypervisor and is thus
fixed for RHEL 5.2. Setting flags and state.
Comment 3 Don Zickus 2008-01-24 11:34:47 EST
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 6 errata-xmlrpc 2008-05-21 10:59:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.