Bug 35861 - Installation crashed at X configuration
Installation crashed at X configuration
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-13 03:28 EDT by Arnold Goth
Modified: 2007-03-26 23:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 10:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug # 35861 (758 bytes, text/plain)
2001-04-13 03:30 EDT, Arnold Goth
no flags Details

  None (edit)
Description Arnold Goth 2001-04-13 03:28:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; CS 2000; Windows 98)


Installation detected an error at one of my partitions (?)

Reproducible: Didn't try
Steps to Reproduce:
1.Created free hard drive space on both C: and D: of 10G drive; /boot 
below cylinder 1024, everything else at top of drive.  Used Partition 
Commander.
2.Re-set BIOS to boot at CD-ROM, inserted Red Hat 7.
3.Used Druid to assign Linux to free spaces created on my Win98 machine by 
Partition Commander.  Installation progressed to X configuration when 
error message appeared.  Dialog box had me save .txt file to A: and sent 
me to Bugzilla.
	

Actual Results:  Don't have time tonight to try again.

Expected Results:  Will be covering this in class tomorrow at 10am Pacific 
time; can you e-mail me by then?

File from floppy:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 1542208
fsystem: ext2
self: <fstab.GuiFstab instance at 84baee8>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda6
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Arnold Goth 2001-04-13 03:30:09 EDT
Created attachment 15284 [details]
Bug # 35861
Comment 2 Brent Fox 2001-04-13 10:22:32 EDT
This bug is a duplicate of bug #16686.  It looks like you didn't format the /
partition.  Right after the Disk Druid screen, there is a screen asking you what
partitions you want to format.  Formatting / is absolutely necessary, so if you
don't do it, the installer with crash later when it tries to copy data to an
unformatted partition.

We have added a lot more error handling code since 7.0 was released, so this
problem should not occur in future versions.

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.