This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 358621 - rpcbind-0.1.4-8.fc7 breaks NFS
rpcbind-0.1.4-8.fc7 breaks NFS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
: 363811 (view as bug list)
Depends On:
Blocks: 418441
  Show dependency treegraph
 
Reported: 2007-10-30 13:08 EDT by H.J. Lu
Modified: 2008-01-11 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.1.4-12.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2007-10-30 13:08:11 EDT
With rpcbind-0.1.4-8.fc7, kernel reported

Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: starting 90-second grace period
call_verify: server localhost requires stronger authentication.
RPC: failed to contact local rpcbind server (errno 13).
call_verify: server localhost requires stronger authentication.
RPC: failed to contact local rpcbind server (errno 13).
call_verify: server localhost requires stronger authentication.
RPC: failed to contact local rpcbind server (errno 13).
lockd_up: makesock failed, error=-13
call_verify: server localhost requires stronger authentication.
RPC: failed to contact local rpcbind server (errno 13).

when starting nfs. Revert to rpcbind-0.1.4-6.fc7 fixes nfs.
Comment 1 H.J. Lu 2007-10-30 13:12:26 EDT
Adding

ALL: localhost

to /etc/hosts.allow fixes the problem.
Comment 2 Mike Cohler 2007-10-30 13:59:04 EDT
I have also had problems today - reported at
http://marc.info/?t=119374079500001&r=1&w=2

I tried H.J. Lu's suggestion from #1 above and it fixes the problem for me also.
Comment 3 H.J. Lu 2007-10-30 14:12:14 EDT
Depending on /etc/hosts, I also need

ALL: 127.0.0.1

in /etc/hosts.allow.
Comment 4 Mike Cohler 2007-10-30 15:28:42 EDT
I have also now done the yum update to the same version of rpcbind on the nfs
client machine, running F7 with a fully updated system, and it would not see the
nfs share until the same workaround as in comment #1 was made. Then after
restarting it all works fine again - but I do not know if there are now security
implications as a result?

So this is a problem on both nfs server and nfs client.
Comment 5 Mike Cohler 2007-10-30 15:47:12 EDT
I notice that nfs-utils was also updated today - is it possible that the
breakage was not due to rpcbind update but nfs-utils update?
Comment 6 Joe Orton 2007-11-01 05:13:01 EDT
This seems to have regressed due to the fix for bug 248284.
Comment 7 Steve Dickson 2007-11-01 07:18:02 EDT
I agree, this is a regression due to bug 248284, but I'm
not sure what the answer is either. Should there be some type
of configuration knob to tell rpcbind when to used the
libwrap files?
Comment 8 Joe Orton 2007-11-02 07:21:49 EDT
If you can't work out what the right thing to do is then just revert the change
and fix the regression.  This is breaking NFS for *everybody who updates*.  At
least withdraw the update.
Comment 9 H.J. Lu 2007-11-02 09:34:35 EDT
I think rpcbind.spec should add

ALL: 127.0.0.1
ALL: localhost

to /etc/hosts.allow during install if they aren't there and /etc/hosts.deny
isn't empty.
Comment 10 Joe Orton 2007-11-08 04:13:01 EST
*** Bug 363811 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2007-12-20 14:53:20 EST
rpcbind-0.1.4-12.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpcbind'
Comment 12 Fedora Update System 2008-01-11 17:00:22 EST
rpcbind-0.1.4-12.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.