Bug 363811 - the latest update to rpcbind causes multipel failures
the latest update to rpcbind causes multipel failures
Status: CLOSED DUPLICATE of bug 358621
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 09:57 EDT by gort
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 04:13:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gort 2007-11-02 09:57:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Description of problem:
the update to rpcbind-0.1.4-8.fc7 on our Fedora 7 systems resulted in several failures with rpc-related services.  NIS, amd were hard hit, and the affected systems could no longer perform automounting, remote logins no longer worked (due to NIS (ypbind) failures.  The work-around was to go to each host and revert to an earlier version of rpcbind (rpcbind-0.1.4-6.fc7) and reboot.   Restarting rpcbind, followed by restarts of ypbind, nfs and amd did not reliably correct the situation.

Systems worked correctly after the initial upgrade to rpcbind-0.1.4-8.fc7; however any system that rebooted after the update exhibited the failure immediately, and other systems began exhibiting problems even if they hadn't been rebooted.  We first noticed a problem when amq could not longer communicate with amd on the affected systems.

Version-Release number of selected component (if applicable):
rpcbind-0.1.4-8.fc7

How reproducible:
Always


Steps to Reproduce:
1.boot an i386/i686 system with rpcbind-0.1.4-8.fc7 installed
2.
3.

Actual Results:
rpcbind and ypbind and amd fail (rpcbind seems to continue to run).  ypbind is unable to communicate with the NIS server(s). amd is unable to mount file systems, users are unable to login, and trust among systems (maintained via NIS) fails.  I suspect any rpc-related service failed, not just the ones we noticed.

Expected Results:
the affected processes should have run normally, ypbind should communicate with the NIS servers, amd should be able to mount file systems, etc., non-root users should be able to login

Additional info:
most of the affected systems are running kernel-2.6.22.5-76.fc7

I indicated high severity because this bug renders our systems unusable.
Comment 1 Joe Orton 2007-11-08 04:13:00 EST

*** This bug has been marked as a duplicate of 358621 ***

Note You need to log in before you can comment on or make changes to this bug.