Bug 35959 - RFE: pcmciadd.img diskette not recognized by pcmcia.img diskette
RFE: pcmciadd.img diskette not recognized by pcmcia.img diskette
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2001-04-15 02:54 EDT by Peter H. Jones
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-21 17:31:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
pcmcia.img file I downloaded from rawhide, dated April 5, 2001 (1.41 MB, application/octet-stream)
2001-04-15 10:15 EDT, Peter H. Jones
no flags Details
Copy of pcmciadd.img file from rawhide, dated April 5, 2001 (1.41 MB, application/octet-stream)
2001-04-15 10:18 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2001-04-15 02:54:57 EDT
I am trying to to a linux rescue on an ftp connection using a PCMCIA card ethernet. The versions of the disk images were on Rawhide,
about April 14th, 2001.

I booted the pcmcia.img diskette. It loaded, and then asked for the PCMCIA Driver Diskette, which was pchiadd.img. The installer
complained the diskette was not the diskette it wanted, and thus failed to initialize the PCMCIA ethernet card I use. Further,
I didn't get a second chance to insert the PCMCIA diskette.

I would have expected to be able to do a linux rescue.

Steps to reproduce:
1 Make diskettes from pcmcia.img and pcmciadd.img in the Rawhide directory.
2 Boot from pcmcia.img
3 Type "linux rescue" and return
4 When asked for PCMCIA driver diskette, insert pcmciadd.img diskette.

Desired outcomes: continue to be able to linux rescue.

Actual outcome: PCMCIA driver diskette is not recognized, so FTP-based rescue is impossible.

The diskette was recognized under Beta/Wolverine

iPeter Jones
Comment 1 Brent Fox 2001-04-15 08:42:53 EDT
I have not seen this in our internal testing.  I will verify with the latest tree.
Comment 2 Peter H. Jones 2001-04-15 10:15:19 EDT
Created attachment 15384 [details]
pcmcia.img file I downloaded from rawhide, dated April 5, 2001
Comment 3 Peter H. Jones 2001-04-15 10:18:25 EDT
Created attachment 15385 [details]
Copy of pcmciadd.img file from rawhide, dated April 5, 2001
Comment 4 Peter H. Jones 2001-04-15 10:23:58 EDT
I tried my test again today, under stricter experimental conditions:
1) Another pair of diskettes
2) Full re-formatting, instead of using existing MSDOS diskettes
3) Power-down before reboot

When I boot the pcmcia.img diskette, I see the version number 7.0.91.
In response to the boot prompt, I type:
linux rescue

On c1 (the main console), the system enters VGA mode and appears to run
normally; the last message is the prompt:
"Please insert your PCMCIA driver disk into your floppy drive now
<OK> <Cancel>"

On c3 (reached by typing ALT-F3), the last messages are:
* going to insmod pcmcia_core.o (path is NULL)
* failed to load pcmcia_core - ask for pcmciadd

On c4 (reached by typing ALT-F4), the last message is:
<6> hub.c: 2 ports detected
<6> hub.c: registered new ??? (can't read my handwritten note, sorry)

I return to c1 with ALT-F1, swap the diskette for pcmciadd.img, and

c1 shows: "Initializing PC card devices", then
"That floppy does not look like a Red Hat PCMCIA driver disk <OK>

c3 had the following additional messages:
* read rhpcmcia
<blank line>
* going to insmod pcmcia_core.o - path is (NULL)

c4 shows no change

I click OK. I continue through the dialogues:
Choose a Language, I choose English.
Keyboard: US

Then I get "What type of media contains the rescue image", and the
only choices are CDROM and Hard Drive. I was hoping for an FTP choice here.

1) When downloading diskette images, I found the prompt "Please insert
your PCMCIA driver disk" confusing, for I didn't know which image
I would need. Fortunately, the answer is given in c3, but most
beginners would not be aware of this. It would be simple to change
the message to "Please insert your PCMCIADD diskette".

2) The message
"That floppy does not look like a Red Hat PCMCIA driver disk"
should give the user another opportunity to insert the correct diskette.

3) I wish there were a verification tool running on Windows 98 et al.
that would checksum validate a downloaded image, and another that
would compare a diskette with that downloaded image. This would detect
possible user errors in creating diskettes.

For reference, I have posted the images I have downloaded, as
pcmciar.img, and pcmciaddr.img. Because of the size of these files,
I suggest RedHat delete these from this bug report after verification.

Thank you for your prompt response to my first report.
Comment 5 Peter H. Jones 2001-04-15 10:27:37 EDT
For details of the machine this bug was detected on, please see bug# 25966
Comment 6 Brent Fox 2001-04-16 00:54:09 EDT
Some responses:
1)  It's too late to change this at this time because of translations.

2)  I agree, that would be nice.  I'll look into it.

3)  I have heard that there are md5sum freeware utilities for Windows, but I
have not used any of these personally.

For items 1 and 2, it's too late for these to be put into the current tree, but
we will consider these for a future release.  I'll change the severity tag to
Comment 7 Peter H. Jones 2001-04-17 03:32:28 EDT
I tried the disk images under version 7.1. The pcmciadd.img disk is accepted, 
solving the problem stated in the Short Summary. That would account for 
RedHat not seeing the problem in internal testing.
Comment 8 Peter H. Jones 2001-04-17 06:26:15 EDT
I have successfully run RedHat linux rescue on ftp with a PCMCIA card under 7.1. 
I believe this problem can be marked as resolved.

As a further documentation enhancement, it would be useful to note that the 
frustration of not being able to log onto a busy public ftp server can be 
relieved by using a copy of the essential files, on a nearby private ftp server, 

some directory, can use non-anonymous login
       7.1 (optional)

These files require about 5 megabytes.

Note You need to log in before you can comment on or make changes to this bug.