Bug 359781 - s-c-bind mangles named.conf
Summary: s-c-bind mangles named.conf
Status: CLOSED DUPLICATE of bug 449046
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
(Show other bugs)
Version: 8
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-31 08:43 UTC by Bowe Strickland
Modified: 2008-07-18 10:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 10:57:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bowe Strickland 2007-10-31 08:43:16 UTC
[root@localhost ~]# rpm -q system-config-bind
system-config-bind-4.0.2-8.fc8
[root@localhost ~]# cat /etc/redhat-release 
Fedora release 8 (Werewolf)

after attempting to edit the default IPV4 binding ACL in "DNS Server"
properties, s-c-bind generally loses it, and all further actions generate
exceptions:

Traceback (most recent call last):
  File "/usr/share/system-config-bind/RRGUI.py", line 1572, in aclDialogResponse
    s.aclWidget.save()
  File "/usr/share/system-config-bind/RRGUI.py", line 1567, in save
    s.attr.nmdc[ s.attr.key  ] = s.attr.key[-1] + ' ' + s.attr.out() + '\n'
  File "/usr/share/system-config-bind/NamedConf.py", line 793, in __setitem__
    raise IndexError
IndexError
Traceback (most recent call last):
  File "/usr/share/system-config-bind/ZoneTree.py", line 817, in on_row_activated
    s.Edit(r)
  File "/usr/share/system-config-bind/ZoneTree.py", line 763, in Edit
    EditDialog(s.bind,r,read_only=readOnly)
  File "/usr/share/system-config-bind/EditDialog.py", line 217, in __init__
    s.options = Options(bind.nmdc, s.name, obj)
  File "/usr/share/system-config-bind/Options.py", line 157, in __init__
    s.parse()
  File "/usr/share/system-config-bind/Options.py", line 68, in parse
    s.opts[key]={ 'obj': s.obj[k], 'key':k, 'opt':key, 'option': O[key],
'value':O[key]['type'](s.obj[k]) }
TypeError: int() argument must be a string or a number, not 'dict'
Traceback (most recent call last):
  File "/usr/share/system-config-bind/ZoneTree.py", line 768, in EditClicked
    s.Edit( s.selection() )        
  File "/usr/share/system-config-bind/ZoneTree.py", line 763, in Edit
    EditDialog(s.bind,r,read_only=readOnly)
  File "/usr/share/system-config-bind/EditDialog.py", line 217, in __init__
    s.options = Options(bind.nmdc, s.name, obj)
  File "/usr/share/system-config-bind/Options.py", line 157, in __init__
    s.parse()
  File "/usr/share/system-config-bind/Options.py", line 68, in parse
    s.opts[key]={ 'obj': s.obj[k], 'key':k, 'opt':key, 'option': O[key],
'value':O[key]['type'](s.obj[k]) }
TypeError: int() argument must be a string or a number, not 'dict'

Comment 1 Jesse Keating 2007-11-15 19:46:19 UTC
Still looking for an owner for system-config-bind.

Comment 3 Jaroslav Reznik 2008-07-18 10:57:15 UTC

*** This bug has been marked as a duplicate of 449046 ***


Note You need to log in before you can comment on or make changes to this bug.