Bug 360481 - Traceback in package selection
Traceback in package selection
Status: CLOSED DUPLICATE of bug 336791
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 12:01 EDT by Joe Orton
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 13:14:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2007-10-31 12:01:01 EDT
pirut-1.3.25-2.fc8

Traceback as below; reproducible by doing:

1) run pirut
2) select a package group
3) click "optional packages"
2) double-click any package name

Component: pirut
Summary: TB91835f44 GroupSelector.py:211:_pkgToggled:TypeError: GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 208, in _rowToggle
    self._pkgToggled(None, path)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 211, in _pkgToggled
    i = self.pkgstore.get_iter_from_string(path)
TypeError: GtkTreeModel.get_iter_from_string() argument 1 must be string, not tuple

Local variables in innermost frame:
path: (0,)
widget: None
self: <pirut.GroupSelector.OptionalPackageSelector instance at 0xc1d3f2c>
Comment 1 Jeremy Katz 2007-10-31 13:14:49 EDT

*** This bug has been marked as a duplicate of 336791 ***

Note You need to log in before you can comment on or make changes to this bug.