Bug 360811 - jomolhari-fonts is installed if Tibetan language is excluded
jomolhari-fonts is installed if Tibetan language is excluded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 15:43 EDT by John Reiser
Modified: 2008-01-10 00:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 00:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-31 15:43:37 EDT
Description of problem: jomolhari-fonts is composed onto install media and
instaslled by default despite commenting out "## @ tibetan-support" in 
/usr/share/pungi/f8-fedora.ks.

Version-Release number of selected component (if applicable):
jomolhari-fonts-0.003-4.fc8


How reproducible: always


Steps to Reproduce:
1. comment-out "@ tibetan-support" in /usr/share/pungi/f8-fedora.ks by inserting
a hash '#' at the beginning of the line
2. compuse install media using pungi; install with defaults
3. rpm -qa | grep jomolhari-fonts
  
Actual results:
jomolhari-fonts-0.003-4.fc8

Expected results:
No jolmolhari-fonts because Tibetan language support was excluded explicitly.

Additional info:
Comment 1 Marcin Garski 2007-10-31 16:22:52 EDT
You have excluded tibetan-support but there is still "@bhutanese-support".
jomolhari-fonts is shared between those two groups.
Try to comment out bhutanese-support too.
Comment 2 John Reiser 2007-10-31 16:59:38 EDT
Actually, I commented out every "@<language>-support" line, so I intended to
cover all those bases.  But Katz says that "base-x" demands some exotic fonts. 
Is this true?  (If so, then there really isn't much flexibility in the
"optional" @<language>-support lines.)
Comment 3 Nicolas Mailhot 2007-10-31 17:20:05 EDT
Exotic is in the eye of the beholder. If you want to remove every font but a
specific set, you need both to comment out language groups and explicitely
blacklist individual packages which are provided by generic groups.

Language groups do not tag everything associated with a particular language,
just everything to add for a particular language in addition to distro defaults.
Otherwise removing every group would leave you with no fonts or localizations at
all.

Generaly speaking fine-tuning package sets requires reading the comps files
fedora uses. They reflect policy, not technical defaults and policy is very
subjective. 

BTW none of your bugs are related to the packages themselves, so please close
them or reassign them to the component responsible for comps (I guess it's
distribution)
Comment 4 Jens Petersen 2007-10-31 21:33:53 EDT
I think this is also a duplicate of bug 360861.
Though I am not sure how many Fedora users really need
a Tibetan font by default, so I concede that jomolhari-fonts may be
considered a more exotic than most of the other Asian fonts
we install now by default.

On the other hand some people might misinterpret such a change
as political, and so until we have some better guidelines
or criteria for fonts defaults I would rather keep things
as they are.
Comment 5 Jens Petersen 2008-01-10 00:45:16 EST
I am going to close this for now, since our current policy is basically
to install font coverage by default for as many languages as we can.

Note You need to log in before you can comment on or make changes to this bug.