Bug 360861 - fonts for languages installed when not selecting language support
fonts for languages installed when not selecting language support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
: 360781 360801 360831 360871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 15:54 EDT by John Reiser
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 20:50:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-31 15:54:13 EDT
Description of problem: sazanami-fonts-gothic is composed onto install media and
installed by default despite commenting out "## @japanese-support" in 
/usr/share/pungi/f8-fedora.ks.

Version-Release number of selected component (if applicable):
sazanami-fonts-gothic-0.20040629-4.20061016.fc8


How reproducible: always


Steps to Reproduce:
1. comment out "@japanese-support" in /usr/share/pungi/f8-fedora.ks by inserting
a hash '#' at the beginning of the line.
2. compose install media using pungi; install with defaults
3. rpm -qa | grep sazanami
  
Actual results:
sazanami-fonts-gothic-0.20040629-4.20061016.fc8


Expected results:
No sazanami-fonts because support for Japanese was excluded explicitly.

Additional info:
Comment 1 Jens Petersen 2007-10-31 20:50:40 EDT
Yes, this is intentional, we now install fonts for most languages by
default in F8 to have good language coverage.

If you really don't want Asian fonts installed from your kickstart file
you can explicitly omit them with lines like:

-sazanami-fonts-gothic
-cjkunifonts-uming
-baekmuk-ttf-fonts-gulim

etc.  Those are the large ones anyway.
Comment 2 Jens Petersen 2007-10-31 21:18:11 EDT
*** Bug 360781 has been marked as a duplicate of this bug. ***
Comment 3 Jens Petersen 2007-10-31 21:18:36 EDT
*** Bug 360801 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2007-10-31 21:19:23 EDT
*** Bug 360831 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2007-10-31 21:20:19 EDT
*** Bug 360871 has been marked as a duplicate of this bug. ***
Comment 6 Behdad Esfahbod 2007-11-06 20:21:14 EST
Huh, shouldn't all font packages be named something-fonts or fonts-something? 
What are these names then:

-sazanami-fonts-gothic
-cjkunifonts-uming
-baekmuk-ttf-fonts-gulim
Comment 7 Jens Petersen 2007-11-07 00:15:54 EST
(In reply to comment #6)
> Huh, shouldn't all font packages be named something-fonts or fonts-something? 

> -sazanami-fonts-gothic
> -cjkunifonts-uming
> -baekmuk-ttf-fonts-gulim

They are subpackage of sazanami-fonts, cjkunifonts, and baekmuk-ttf-fonts.

There are plenty of other older examples of subpackages in the distro:
bitmap-fonts-cjk
dejavu-fonts-experimental
tetex-fonts-hebrew
xorg-x11-fonts-*

Note You need to log in before you can comment on or make changes to this bug.