Bug 361271 - Can not input two Chinese characters in kedit with smart-pinyin IM of scim
Can not input two Chinese characters in kedit with smart-pinyin IM of scim
Status: CLOSED DUPLICATE of bug 205357
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 22:34 EDT by HaiYan Shao
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 00:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the screenshot of hua(1) (10.24 KB, image/png)
2007-10-31 22:34 EDT, HaiYan Shao
no flags Details
the screenshot of hua(2) (11.01 KB, image/png)
2007-10-31 22:35 EDT, HaiYan Shao
no flags Details

  None (edit)
Description HaiYan Shao 2007-10-31 22:34:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Can not input two hanzi in kedit with smart-pinyin of scim. They can not display
correctly.

How reproducible:


Steps to Reproduce:
1. Launch kedit in zh_CN locale.
2. Activate smart-pinyin IM of scim.
3. Input "hua"
  
Actual results:
A dot is displayed instead of Chinese character '华' and '话'.

Expected results:


Additional info:
Comment 1 HaiYan Shao 2007-10-31 22:34:24 EDT
Created attachment 245071 [details]
the screenshot of hua(1)
Comment 2 HaiYan Shao 2007-10-31 22:35:52 EDT
Created attachment 245081 [details]
the screenshot of hua(2)
Comment 3 Jens Petersen 2007-11-01 00:03:45 EDT
I think this is a qt issue with fonts.

Which fonts do you have installed?
("rpm -qa fonts-\* | sort")

*** This bug has been marked as a duplicate of 205357 ***
Comment 4 Liang Zhang 2007-11-01 01:20:02 EDT
The Chinese font which I install is fonts-chinese-3.03-4.fc7 
Comment 5 Jens Petersen 2007-11-01 01:28:11 EDT
I was referring to https://bugzilla.redhat.com/show_bug.cgi?id=205357#c7
Comment 6 Liang Zhang 2007-11-01 01:36:28 EDT
I tested this bug, and this bug is existing in f7.
The Chinese font which I install is fonts-chinese-3.03-4.fc7.
The relevant bug is 219451.
https://bugzilla.redhat.com/show_bug.cgi?id=219451


Note You need to log in before you can comment on or make changes to this bug.