Bug 205357 - Qt doesn't use correct font to render glyphs
Qt doesn't use correct font to render glyphs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Rahul Bhalerao
Ben Levenson
: i18n
: 213210 361271 (view as bug list)
Depends On:
Blocks: 209971 211973 219451
  Show dependency treegraph
 
Reported: 2006-09-06 06:37 EDT by Nicole Dai
Modified: 2008-09-14 10:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 15:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for gedit and kedit (1.30 MB, image/png)
2006-09-06 06:37 EDT, Nicole Dai
no flags Details
Screenshot for firefox in KDE (134.21 KB, image/png)
2006-09-22 02:24 EDT, Nicole Dai
no flags Details
Screenshot got from Konqueror and firefox (218.80 KB, image/png)
2006-09-26 03:39 EDT, Nicole Dai
no flags Details

  None (edit)
Description Nicole Dai 2006-09-06 06:37:56 EDT
Description of problem:
Some Chinese words cannot be showed normally in kedit.Compared that, these words
can be showed normally in gedit. Pls refer to attached screenshot for details.

Version-Release number of selected component (if applicable):
kdeutils-3.5.4-2.fc6

How reproducible:
Always
Comment 1 Nicole Dai 2006-09-06 06:37:57 EDT
Created attachment 135643 [details]
Screenshot for gedit and kedit
Comment 2 Ngo Than 2006-09-06 07:20:20 EDT
which packages should be installed to reproduce this problem and which LANG is 
using here (echo $LANG)?

how can i type the words in the screenshots?

Thanks
Comment 3 Nicole Dai 2006-09-06 09:19:01 EDT
[root@dhcp-0-179 ~]# echo $LANG
zh_CN.UTF-8

The problem was found in kdeutils-3.5.4-2.fc6

I used Smart Pinyin IM to type the words in gedit and kedit respectively.

Thanks
Comment 4 Nicole Dai 2006-09-06 09:21:40 EDT
The test case is as below:
Actions:
1. In Chinese (P.R. of China) environment, launch gedit and kedit.  
2. Launch Smart Pinyin IM. 
3. Type the following key in gedit and kedit respectively: yi di zai yao gong+2
shang shi zhong guo tong he de you ren wo zhu chan bu wei zhe min jing le fa yi	

Result:
Verify the following Chinese words are showed in gedit and kedit: 一地在要工上是
中国同和的有人我主产不为这民经了发以
Comment 5 Nicole Dai 2006-09-22 02:24:45 EDT
Created attachment 136932 [details]
Screenshot for firefox in KDE

The problem was also found in other applications in KDE, such as the title of
websites, the name of .odt file, etc.
Comment 6 Nicole Dai 2006-09-26 03:39:39 EDT
Created attachment 137111 [details]
Screenshot got from Konqueror and firefox
Comment 7 Akira TAGOH 2006-10-04 08:30:01 EDT
It seems that Qt doesn't use Chinese fonts. when I just removed fonts-japanese
package, it looks good then.
Comment 8 Akira TAGOH 2006-10-30 08:25:32 EST
This also happens on Assamese.
Comment 9 Jens Petersen 2007-11-01 00:03:46 EDT
*** Bug 361271 has been marked as a duplicate of this bug. ***
Comment 10 Liang Zhang 2007-11-06 02:11:46 EST
I tested this bug with qt-3.3.6, I found this bug has already been fixed.
So we can close it.
Comment 11 A S Alam 2007-11-14 01:50:30 EST
(In reply to comment #8)
> This also happens on Assamese.
TAGOH,
have you any specific example to test this for as_IN?
Comment 12 Rahul Bhalerao 2008-03-03 06:22:11 EST
(In reply to comment #11)
> (In reply to comment #8)
> > This also happens on Assamese.
> TAGOH,
> have you any specific example to test this for as_IN?
> 

Alam, see bug #228267.
Comment 13 Jens Petersen 2008-05-01 00:49:55 EDT
Any improvement with qt4 and kde4?
Comment 14 Jens Petersen 2008-05-01 01:48:08 EDT
*** Bug 213210 has been marked as a duplicate of this bug. ***
Comment 15 Bug Zapper 2008-05-13 22:19:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.