Bug 36178 - rhn_register aborts with message AttributeError: setValue
rhn_register aborts with message AttributeError: setValue
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Jay Turner
:
: 47654 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 03:36 EDT by Bill McCarty
Modified: 2015-01-07 18:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment out 2 lines of code to work-around error (662 bytes, patch)
2001-04-25 19:17 EDT, Need Real Name
no flags Details | Diff

  None (edit)
Description Bill McCarty 2001-04-17 03:36:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


When running rhn_register via SSH, rhn_register terminates when I click 
the Enter button on the first contact information screen. The related rhn 
account exists, but has no associated hardware profile for the only 
associated PC; so, I was attempting to re-register the system in order to 
obtain a hardware profile.

Reproducible: Always
Steps to Reproduce:
1. login as root, via SSH.
2. Issue command "rhn_register --nox:.
3. Ok -> Next -> Next.
4. Fill in User name, password (2x), and email address. Click Next.
	

Actual Results:  Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 422, in __init__
    self.emailContactButton.setValue("*")
AttributeError: setValue
Comment 1 Jay Turner 2001-04-17 08:29:37 EDT
You need to upgrade to the latest version of python-xmlrpc.  In total, I would
recommend that you grab the latest version of up2date as well, so grab:
up2date[-gnome]-2.5.3-1 (for 7.0)
up2date[-gnome]-2.5.3-0.6.x (for 6.2)
python-xmlrpc-1.4.1 (for 7.0)
python-xmlrpc-1.4.0-0.6.x (for 6.2)
Comment 2 Bill McCarty 2001-04-17 13:57:21 EDT
Hmm, I already have these versions, as I followed the instructions for 
installing rhn under 6.2. See rpm output, following:

# rpm -q up2date
up2date-2.5.3-0.6.x
# rpm -q python-xmlrpc
python-xmlrpc-1.4-0.6.x

Off topic: Wouldn't/shouldn't up2date have updated itself and python-xmlrpc 
without manual intervention?
Comment 3 Bennett Feitell 2001-04-20 17:20:49 EDT
I am having the same problem, it seems to have something to do with the email
address checkbox on the page after the sign in page. Could it be that the
setValue("*") thing is expecting a different type of variable than is set
earlier in the tui.py file?  I know nothing about python, I just spent a few
hours poking around and trying to figure out why it was bombing out...
Comment 4 Need Real Name 2001-04-25 19:17:13 EDT
Created attachment 16465 [details]
Comment out 2 lines of code to work-around error
Comment 5 Need Real Name 2001-04-25 19:42:26 EDT
I can also recreate the problem with the non-gnome rhn_register on a Red Hat
v6.2 box that needs to be re-registered with RHN.  The machine is already up to
date such that "up2date -l" only shows kernel packages which are behind.   The
package versions are:
  rpm-4.0.2-6x 
  python-1.5.2-27.6.x
  rpm-python-4.0.2-6x
  python-xmlrpc-1.4-0.6.x
  up2date-2.5.4-0.6.x
  rhn_register-1.3.2-0.6.x

The error message is identical to the one bmccarty@apu.edu has already posted.

The attachment provided above appears to "correct" the issue by commenting out
the offending lines of code.  The resulting rhn_register complettes as expected
without any sign of ill effect.  And since rhn_register, including tui.py, is
covered by the General Public License, this patch and the resulting derived work
by applying it is of course covered under the GPL.  However, I do not recommend
wide-spread redistribution and modification of the derived work since this patch
is best described as a "work-around" rather than a well thought out fix. 
Standard GPL disclaimers/no warrenty statement also applies.  :-)  Keep this in
mind if all the bits on the machine and RHN account associated with running the
derived work happen to implode.
Comment 6 Milan Kerslager 2001-04-30 04:49:14 EDT
I had the same problem. I manually updated system to latest up2date,
rhn_register, rpm and then it was impossible to register machine to RHN.
Patch above solves the problem. This shoulb be fixed ASAP as official update
from RH's updates are broken and do not allow to register machine into RHN (bad
news for customers).
Comment 7 Curtis Doty 2001-05-06 21:16:37 EDT
This bug is due to a missing dependency in rhn_register. Here's a cleaner 
workaround than above:

# rpm -U newt-0.50.22-2.i386.rpm

I guess the fix would be for redhat to add the dependency in a future 
rhn_register package:

Requires: newt >= 0.50.22
(Or maybe it's fixed in 0.50.17 but I dunno since I didn't bother to check.)

FYI, I reproduced this bug with newt-0.50.14-2.
Comment 8 Curtis Doty 2001-05-08 13:59:47 EDT
On another legacy upgrade installation, I found the presence of glint causes 
rhn_register to core dump. I'm only guessing it cores on the attempt to load 
the old rpm.so.

# rhn_register --help
Segmentation fault (core dumped)

# rpm -e glint

# rhn_register --help
Usage: rhn_register [options]
Comment 9 petr 2001-07-06 07:10:03 EDT
I can confirm that new version of newt solves this problem. But new version of newt is not available for RedHat Linux 6.2. I found following in changelog of 
newt:

* Thu Aug  3 2000 Matt Wilson <msw@redhat.com>
- added setValue method for checkboxes in snack

But it was after release of RHL6.2.

Comment 10 Elliot Lee 2001-12-28 14:25:30 EST
*** Bug 47654 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2006-08-07 13:12:30 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 12 Bill Nottingham 2006-10-18 10:14:54 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.