Bug 36358 - [aic7xxx] System hangs with Adaptec 7890 on-board SCSI controller and add-in QLogic QLA2200
[aic7xxx] System hangs with Adaptec 7890 on-board SCSI controller and add-in ...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-17 16:44 EDT by Jonathan Arehart
Modified: 2007-04-18 12:32 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 10:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Arehart 2001-04-17 16:44:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3 i686)

At boot time, as the aic7xxx driver loads it hangs the machine.  It only
does this if the QLA2200 card is present in the system.  If the no_probe
option is passed to the aic7xxx module or if the QLA2200 is absent,
everything works correctly.

Reproducible: Always
Steps to Reproduce:
1.  Attempt to install Red Hat Linux 7.1 on a machine with on-board Adaptec
7890 SCSI controllers and a QLogic QLA2200.  The system will lock when the
installer loads the aic7xxx driver.  This can be avoided by using the
"expert noprobe" install mode.
2.  Reboot the machine.  :-)

Actual Results:  System lockup requiring a system reset.

Expected Results:  The drivers should co-exist wihout causing system
lockups.

This is using the 2.4.2-2boot and 2.4.2-2smp kernels from Red Hat 7.1
retail CDs.  The machine is a Dell PowerEdge 6350 with 2 500MHz Pentium III
Xeon processors and 1GB of RAM.  The install target is an 18GB hard disk on
the first on-board Adaptec 7890 SCSI controller.  This has also been seen
on a quad-400MHz machine with 1GB of RAM.
Comment 1 Dana Canfield 2001-04-18 11:35:08 EDT
FYI, I think this is probably related to, or a duplicate of bug 29572.
Comment 2 John P Rogate 2001-04-24 14:47:14 EDT
I just received red hat 7.1 ... having the same problem ... cannot install the 
product successfully...  it is really annoying since i am going to teach a 
class, and planned on using 7.1 ...

need a fix asap!
Comment 3 John P Rogate 2001-04-24 16:46:08 EDT
just tried many ways to get the product installed.  it doesn't work!  several 
other bug ID's exist that sort of identify the same problem in one or more 
ways.  i spent the whole afternoon trying to get it loaded.  yup, there may be 
workarounds (please let me know exactly if one works using the distribution).  
i think this bug should be raised to a higher priority ... the product (Deluxe 
Workstation) does not install out of the box!  I do not think this is a good 
situation.  i have installed 6.1, 6.2 and 7.0 hundreds of times in class, and 
there have been no major issues.  I do not think 7.1 should have been released 
in this state.  Would like to have some idea on when this will be resolved and 
if new distribution will be made available.
Comment 4 Need Real Name 2001-07-23 10:31:57 EDT
I just bought 8 VALinux "fire sale" systems.. I have to use 6.2 on them, b/c 
7.1 hangs on this exact problem...

:(~~

Any clues on a fix?
Comment 5 Tesfamariam Michael 2001-07-23 10:52:09 EDT
When installing, at the boot prompt, enter "expert noprobe" to install in 
expert mode. When you choose the "aic7xxx" driver, pass "aic7xxx=no_probe" 
parameter option.
Comment 6 Doug Ledford 2001-08-02 13:25:22 EDT
You can also avoid the problem by loading the QLogic driver before the aic7xxx
driver.  However, there isn't really a fix to be made here except to use the
aic7xxx=no_probe option because the problem really is that the PCI BIOS is
assigning an address to the QLogic card that overlaps with the addresses that
EISA or VLB based aic7xxx cards *could* be at and as the driver is probing for
those addresses, it is causing a system lock.  Simply moving the QLogic card to
a different slot on a different peer PCI bus could be sufficient to make the
problem go away entirely.

I'm marking this as WONTFIX because A) the aic7xxx driver is not deprecated in
favor of the new aic7xxx driver from Adaptec and any fixes should be there, not
in the old driver and B) the only way to fix this would be to force the aic7xxx
driver to try and interpret the address registers on *all* PCI devices looking
for conflicts between them and the built in EISA/VLB bus probe addresses it
uses, and since those address registers on different PCI devices are used
differently depending on the PCI device in question, this would likely be a
doomed attempt at sorting them all out.
Comment 7 Need Real Name 2001-08-02 13:42:35 EDT
I have the same problem on a Intel L440GX+ Serverboard with Adaptec 7896 on-
board SCSI .
The Installer hang with "aic7xxx driver loading".

I tried to do the expert install with the "aic7xxx=no_probe" as parameter for 
the adaptec controller.
It didn't work.

The Installation of red Hat 7.0 worked fine.

Comment 8 John P Rogate 2001-08-02 14:04:46 EDT
just wondering why everyone is going around in circles on this still when the 
install issue has been resolved in bug 29555.

my question:  is this problem fixed in the regular "store" distribution, or is 
it expected to be fixed in the next release (7.2?).

Note You need to log in before you can comment on or make changes to this bug.