Bug 363781 - Search by subject function broken in slrn (with fix)
Summary: Search by subject function broken in slrn (with fix)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: slrn (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-02 13:51 UTC by Jan Andres
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.9.8.1pl1-5.20070716cvs.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 16:14:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Andres 2007-11-02 13:51:31 UTC
In slrn-0.9.8.1pl1-4.20070716cvs.fc8, the "subject search" function ('s' key
in header display) searches only through the article authors, not their subjects.

This is caused by the fix for a bug in this functionality, contained in
slrn-0.9.8.1pl1-asearch.patch. The same fix is already contained in
slrn-0.9.8.1pl1-20070716cvs.patch.bz2. The patch command succeeds to apply the
patch twice, but on the second attempt it gets applied in the wrong place so the
search function breaks.

Omitting slrn-0.9.8.1pl1-asearch.patch fixes the issue for me.

Comment 1 Miroslav Lichvar 2007-11-02 14:40:22 UTC
Fixed in slrn-0.9.8.1pl1-5.20070716cvs.fc8. 

Thanks for the report!


Comment 2 Fedora Update System 2007-11-06 16:14:44 UTC
slrn-0.9.8.1pl1-5.20070716cvs.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.