This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 363831 - diff -b option (ignore whitespace) does not work
diff -b option (ignore whitespace) does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: diffutils (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 420791 (view as bug list)
Depends On:
Blocks: F8Target 252117
  Show dependency treegraph
 
Reported: 2007-11-02 10:00 EDT by Ian
Modified: 2007-12-13 05:28 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.8.1-19.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 19:13:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian 2007-11-02 10:00:36 EDT
Description of problem:
-b option (ignore whitespace) on diff does not work

Version-Release number of selected component (if applicable):
diffutils-2.8.1-17.fc8

How reproducible:
Always

Steps to Reproduce:
1. echo "abc" > f1
2. echo "abc " > f2
3. diff -b f1 f2
  
Actual results:
1c1
< abc
---
> abc


Expected results:
No output.

Additional info:
Comment 1 Tim Waugh 2007-11-06 07:13:14 EST
Fixed in 2.8.1-18.fc8.
Comment 2 Fedora Update System 2007-11-08 01:00:59 EST
diffutils-2.8.1-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update diffutils'
Comment 3 Marc Schwartz 2007-11-09 17:25:58 EST
Just a quick heads up, that the -19 version seems to have resolved a problem
with running 'make check-all' on R (http://www.r-project.org/).

It's is not on a mirror yet, so I got it directly from Koji at:

http://koji.fedoraproject.org/koji/buildinfo?buildID=23465


I posted on this issue earlier today on the r-devel list:

https://stat.ethz.ch/pipermail/r-devel/2007-November/047397.html

Thanks to Tom Callaway for referencing this bug.
Comment 4 Fedora Update System 2007-11-12 19:13:48 EST
diffutils-2.8.1-19.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Tim Waugh 2007-12-13 05:28:49 EST
*** Bug 420791 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.