Bug 420791 - Probable gcc bug on 64-bit - diff -b or -t report differences on line with spaces
Summary: Probable gcc bug on 64-bit - diff -b or -t report differences on line with sp...
Status: CLOSED DUPLICATE of bug 363831
Alias: None
Product: Fedora
Classification: Fedora
Component: diffutils   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-12 00:38 UTC by Jim Thomas
Modified: 2007-12-13 10:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 10:28:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file showing tests on "lapuwale" the 64-bit system and "aa" a 32-bit system (3.18 KB, text/plain)
2007-12-12 00:38 UTC, Jim Thomas
no flags Details

Description Jim Thomas 2007-12-12 00:38:49 UTC
Description of problem:
diff -b and diff -w report differences on lines with only blanks on 64-bit processor

Version-Release number of selected component (if applicable):
diff 2.8.1
gcc (GCC) 4.1.2 20070925 (Red Hat 4.1.2-33)

How reproducible:
100%

Steps to Reproduce:
1. echo "     " > blanks
2. echo "" > empty
3. diff -b
4. diff -w
  
Actual results:
differences

Expected results:
no differences

Additional info:
Presumably a bug in gcc, actually :)
I recompiled diffutils 2.8.1 with the above gcc and that is better, but it still
shows differences for diff -t
NOTE - this is 2.6.23.1-42.fc8 on a 64-bit Q6700
see attachment

Comment 1 Jim Thomas 2007-12-12 00:38:49 UTC
Created attachment 284841 [details]
log file showing tests on "lapuwale" the 64-bit system and "aa" a 32-bit system

Comment 2 Tim Waugh 2007-12-12 12:47:11 UTC
This sounds suspiciously like bug #363831 which was fixed in an update.  Please
show me the output of 'rpm -q diffutils' so that I can rule that out.

Comment 3 Jim Thomas 2007-12-12 17:54:24 UTC
We were running diffutils-2.8.1-17.fc8 .  yuming diffutils-2.8.1-19.fc8 made it
work.  Thank you! Jim

Comment 4 Tim Waugh 2007-12-13 10:28:48 UTC

*** This bug has been marked as a duplicate of 363831 ***


Note You need to log in before you can comment on or make changes to this bug.