Bug 364571 - Desktop effects could not be enabled
Desktop effects could not be enabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 16:04 EDT by Per Bothner
Modified: 2009-01-09 02:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:22:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf, which prevents desktop effects from working (1.57 KB, text/plain)
2008-01-24 14:34 EST, Per Bothner
no flags Details
Xorg.0.log matching just-attached xorg.conf (211.73 KB, text/plain)
2008-01-24 14:36 EST, Per Bothner
no flags Details
Xorg.0.log when there is no xorf.conf - desktop effects works (136.85 KB, text/plain)
2008-01-24 14:36 EST, Per Bothner
no flags Details
xorg.conf based on log, plus Virtual (1.42 KB, text/plain)
2008-01-24 20:37 EST, Per Bothner
no flags Details

  None (edit)
Description Per Bothner 2007-11-02 16:04:08 EDT
I do System -> Preferences -> Look and Feel -> Desktop Effects and click on
Enable Desktop Effects.  The Gnome window manager goes away, and then after a
while it come back with an very uninformative error message "Desktop effects
could not be enabled".

This is on a Dell Inspiron E1405 laptop with Intel 945GM running the intel X
driver. I'm running rawhide (IIRC installed from test2 live CD), with current
updates as just now, and freshly rebooted.

This *used* to work, earlier in the F8 process.  (With one caveat: it wouldn't
work if I had NetBeans running.)  However, it hasn't worked for a while now. 

How reproducible:  Always.
Comment 1 Ralph Loader 2007-12-02 20:01:51 EST
I too find that compiz no longer works in FC8 with the Intel X driver; it used
to work just fine in FC7.  Lspci says:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)

Running compiz from the comand lines gives:

compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
Comment 2 Will Woods 2007-12-03 17:52:54 EST
Weird, works for me on fresh installs and upgrades.. things may have been fishy
during the F8 test cycle.

Does this work with F8 final? Have you tried it out on a LiveCD?
Comment 3 Ralph Loader 2007-12-03 21:54:24 EST
This is on FC8 final (with current updates), with the i810 driver, and a newly
generated X config (created with system-config-display).

[I also tried the intel driver; I couldn't get DRI to work that at all :-(]
Comment 4 Matěj Cepl 2008-01-23 19:38:25 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Per Bothner 2008-01-24 14:34:57 EST
Created attachment 292843 [details]
xorg.conf, which prevents desktop effects from working
Comment 6 Per Bothner 2008-01-24 14:36:02 EST
Created attachment 292844 [details]
Xorg.0.log matching just-attached xorg.conf
Comment 7 Per Bothner 2008-01-24 14:36:47 EST
Created attachment 292845 [details]
Xorg.0.log when there is no xorf.conf - desktop effects works
Comment 8 Per Bothner 2008-01-24 14:47:03 EST
I've uploaded the requested attachments.
Desktop effects *does* work when there is no xorg.conf.

There is one annoyance: When desktop effects is enabled, I can't drag windows
between workspaces in the workspace switcher.  Is this a known problem?

The other annoyance is that without the xorg.conf I cannot do "multi-screen"
(cinerama?) with the workspace across both my laptop screen and an external
(1920x1200) monitor:

$ xrandr --output  LVDS  --auto  --output VGA --auto --right-of LVDS
xrandr: screen cannot be larger than 1920x1920 (desired size 3360x1200)
Comment 9 Matěj Cepl 2008-01-24 19:45:33 EST
OK, to untangle your last comment:

a) moving between workspaces is a matter of huge discussion in bug 200292
b) problems with xrandr are most likely duplicate of bug 387691. See bug 387691
comment 8. Now it is getting complicated, because you need /etc/X11/xorg.conf to
add Virtual there. To create a xorg.conf corresponding to the current
configuration in X w/o any xorg.conf, browse through /var/log/Xorg.0.log and it
is there. Cut it out with a text editor and save it as /etc/X11/xorg.conf. Then
follow the steps in the above-mentioned bug.

Does it help?
Comment 10 Per Bothner 2008-01-24 20:37:22 EST
Created attachment 292899 [details]
xorg.conf based on log, plus Virtual

Thanks for the response.  As suggested, I created an xorg.conf based on the
default printed out in the Xorg.0.log. and then added a Virtual command.
See attachment "xorg.conf based on log, plus Virtual".
If the "Virtual" command is commented out (as shown in the attachment), then I
can enable Desktop Effects, but I can't do dualhead.
If I enable the Virtual command (by removing the comment character), I can do
dualhead, but I can't enable Desktop effects.
Maybe my 945GM chip is just too wimpy to support both desktop effects and the
large virtual screen at the same time?	No big deal (the desktop effects are
amusing, but terribly useful).	(For that matter I don't really care much about
 dualhead as long as I can cleanly switch between the external and internal
displays, which finally in F8 works reliably.)	However, it would be friendlier
if there were some more helpful message explaining *why* desktop effects
couldn't be enabled,
Comment 11 Bug Zapper 2008-11-26 03:10:56 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2009-01-09 02:22:17 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.