Bug 36504 - rpm2html needs to be rebuilt against new rpm
rpm2html needs to be rebuilt against new rpm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm2html (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 42752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-18 12:10 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 10:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-18 12:10:28 EDT
After upgrading to rpm-4.0.2 on 6.2, rpm2html now fails:

rpm2html: error in loading shared libraries: /usr/lib/librpm.so.0: undefined symbol: ufdio

rebuilding rpm2html against the new rpm fixies this.  This probably
falls into the same category as the recent gnorpm and ucd-snmp
errata.
Comment 1 Daniel Roesen 2001-04-19 06:37:31 EDT
Same goes for "kpackage" and "rpmfind" and "purp". I think that should be all
affected packages on main CD and powertools. I used:

for i in *; do
  rpm -qp --requires $i | fgrep -qs librpm.so.0 && echo $i
done

in the relevant directories to find out which packages link against librpm.
Comment 2 Daniel Veillard 2001-05-14 11:28:34 EDT
I added a specific entry in the rpm2html/rpmfind FAQ
http://rpmfind.net/linux/rpm2html/faq.html
#4

Daniel
Comment 3 Jeff Johnson 2001-05-30 08:46:47 EDT
*** Bug 42752 has been marked as a duplicate of this bug. ***
Comment 4 Hugo van der Kooij 2001-05-30 09:31:22 EDT
When will fixed binaries be shipped? Not everyone is able to recompile the packages. (Certainly with slow machines.) My tries on a slow SPARC system 
that is the intended platform to use it for will not succeed.
Comment 5 Need Real Name 2001-06-23 00:36:06 EDT
I'm having problems with fdio (symbol not found) with ucd-snmp 4.2.1 -- compiled
from sources, against rpm 4.0.2.

I've tried what I can to make it work, but it still doesn't.

Any other issues that need to be dealt with here?
(Looks like someone changed namespaces ... )
Comment 6 Daniel Veillard 2001-07-17 19:31:36 EDT
I just released a new version rpm2html-1.6, it built fine against
the RawHide rpm packages. Should propagate to RawHide in the next days.

Daniel

Note You need to log in before you can comment on or make changes to this bug.