Bug 36504 - rpm2html needs to be rebuilt against new rpm
Summary: rpm2html needs to be rebuilt against new rpm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm2html
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 42752 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-18 16:10 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-07-16 14:27:29 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-04-18 16:10:28 UTC
After upgrading to rpm-4.0.2 on 6.2, rpm2html now fails:

rpm2html: error in loading shared libraries: /usr/lib/librpm.so.0: undefined symbol: ufdio

rebuilding rpm2html against the new rpm fixies this.  This probably
falls into the same category as the recent gnorpm and ucd-snmp
errata.

Comment 1 Daniel Roesen 2001-04-19 10:37:31 UTC
Same goes for "kpackage" and "rpmfind" and "purp". I think that should be all
affected packages on main CD and powertools. I used:

for i in *; do
  rpm -qp --requires $i | fgrep -qs librpm.so.0 && echo $i
done

in the relevant directories to find out which packages link against librpm.

Comment 2 Daniel Veillard 2001-05-14 15:28:34 UTC
I added a specific entry in the rpm2html/rpmfind FAQ
http://rpmfind.net/linux/rpm2html/faq.html
#4

Daniel

Comment 3 Jeff Johnson 2001-05-30 12:46:47 UTC
*** Bug 42752 has been marked as a duplicate of this bug. ***

Comment 4 Hugo van der Kooij 2001-05-30 13:31:22 UTC
When will fixed binaries be shipped? Not everyone is able to recompile the packages. (Certainly with slow machines.) My tries on a slow SPARC system 
that is the intended platform to use it for will not succeed.

Comment 5 Need Real Name 2001-06-23 04:36:06 UTC
I'm having problems with fdio (symbol not found) with ucd-snmp 4.2.1 -- compiled
from sources, against rpm 4.0.2.

I've tried what I can to make it work, but it still doesn't.

Any other issues that need to be dealt with here?
(Looks like someone changed namespaces ... )

Comment 6 Daniel Veillard 2001-07-17 23:31:36 UTC
I just released a new version rpm2html-1.6, it built fine against
the RawHide rpm packages. Should propagate to RawHide in the next days.

Daniel


Note You need to log in before you can comment on or make changes to this bug.