Bug 365331 - SATA detection SIS964 Chipset
SATA detection SIS964 Chipset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 389721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-03 14:24 EDT by Michael Seney
Modified: 2007-12-06 19:13 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 19:13:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (17.87 KB, text/plain)
2007-11-03 14:24 EDT, Michael Seney
no flags Details

  None (edit)
Description Michael Seney 2007-11-03 14:24:59 EDT
Description of problem:
sata_sis 0000:00:05.0: Detected SiS 180/181/964 chipset in SATA mode
ata3: COMRESET failed (errno=768)
ata3: reset failed (errno=768), retrying in 10 secs
ata3: reset failed, giving up

Version-Release number of selected component (if applicable):
Linux 2.6.23.1-42.fc8 #1 SMP

How reproducible:
Very

Steps to Reproduce:
1. Boot Fedora 8 RC3 on a motherboard having the SIS964 chipset and SATA HDD
2.
3.
  
Actual results:
Slow boot and failed detection of the SATA Hard Disk

Expected results:
Normal boot and detection of the SATA Hard Disk

Additional info:
This also occured in OpenSUSE 10.3 upon its initial release
Comment 1 Michael Seney 2007-11-03 14:24:59 EDT
Created attachment 247361 [details]
dmesg
Comment 2 Chuck Ebbert 2007-11-05 14:14:59 EST
Try the workarounds:

https://fedoraproject.org/wiki/KernelCommonProblems

Comment 3 ryan roth 2007-11-08 12:10:05 EST
I have the same issue with Fedora 7 & 8, and none of the workarounds work.  My
only solutions have been to run either the XEN kernel, or compile my own vanilla
kernel.
Comment 4 Chuck Ebbert 2007-11-08 13:16:50 EST
Fixed by commit aaa092a114696f4425cd57c4d7fa05110007e247
This will be in the next kernel release, but will not help people who can't install.
Comment 5 Scott McMahan 2007-11-13 06:09:02 EST
"This will be in the next kernel release" - which release will fix this problem?
I have kernel 2.6.23.1.-49.fc8 and the messages are the same as in the posted
log. Can't even see the SATA drive. This Asus SiS motherboard worked fine with
FC6 and 7, so this is something new in 8 that broke it.
Comment 6 Scott McMahan 2007-11-13 06:12:13 EST
Please change priority from "low" and severity "medium" to show-stopper -- this
bug cripples any Asus motherboard using an SATA drive! This is a critical
problem. Why doesn't Fedora 8 say something as a warning during the upgrade
process that it is not compatible with the hardware? Is there some way to undo
the upgrade to Fedora 8?
Comment 7 Scott McMahan 2007-11-13 09:15:09 EST
Several related COMRESET bugs suggest adding "pci=nomsi pci=nommconf" to the
kernel boot parameters - I tried adding them to the grub boot parameters, but
this doesn't affect the COMRESET failed (errno=768) bug.

sata_sis 0000:00:05.0: Detected SiS 180/181/964 chipset in SATA mode
Nov 13 09:02:10 therru kernel: scsi2 : sata_sis
Nov 13 09:02:10 therru kernel: scsi3 : sata_sis
Nov 13 09:02:10 therru kernel: ata3: SATA max UDMA/133 cmd 0x0001eff0 ctl
0x0001efe6 bmdma 0x0001ef90 irq 21
Nov 13 09:02:10 therru kernel: ata4: SATA max UDMA/133 cmd 0x0001efa8 ctl
0x0001efe2 bmdma 0x0001ef98 irq 21
Nov 13 09:02:10 therru kernel: ata3: COMRESET failed (errno=768)
Nov 13 09:02:10 therru kernel: ata3: reset failed (errno=768), retrying in 10 secs
Nov 13 09:02:10 therru kernel: ata3: COMRESET failed (errno=768)
Nov 13 09:02:10 therru kernel: ata3: reset failed (errno=768), retrying in 10 secs
Nov 13 09:02:10 therru kernel: ata3: COMRESET failed (errno=768)
Nov 13 09:02:10 therru kernel: ata3: reset failed (errno=768), retrying in 35 secs
Nov 13 09:02:10 therru kernel: ata3: limiting SATA link speed to 1.5 Gbps
Nov 13 09:02:10 therru kernel: ata3: COMRESET failed (errno=768)
Nov 13 09:02:10 therru kernel: ata3: reset failed, giving up

Same messages for ata4.

I only have one SATA drive attached, not two.

Comment 8 Chuck Ebbert 2007-11-13 14:16:06 EST
(In reply to comment #6)
> Please change priority from "low" and severity "medium" to show-stopper -- this
> bug cripples any Asus motherboard using an SATA drive!

It is specific to SiS chipsets, not Asus motherboards.

> This is a critical
> problem. Why doesn't Fedora 8 say something as a warning during the upgrade
> process that it is not compatible with the hardware?

Nobody reported any problems from Fedora 8 test1, test2 or test3.

Comment 9 Scott McMahan 2007-11-13 14:44:37 EST
If any additional information is needed, let me know - I can reproduce this
easily and can send logs or run commands or anything else.
Comment 10 Chuck Ebbert 2007-11-13 16:08:55 EST
Patch in CVS
Comment 11 Masaki MIWA 2007-11-15 11:01:07 EST
*report

sorry, i'm not good at English

i had same sata-hdd-problem too.
kernel 2.6.22 worked fine with F7 but 2.6.23 doesn't.
since i installed kernel 2.6.23.1-26.fc7, F7 become to be fine again.
and kernel 2.6.23.1-28-fc7 is fine too.

i did upgrade from F7 to F8.
F8 didn't work fine with kernel 2.6.23.1-49.fc8 on my pc, but worked fine with 
kernel 2.6.23.1-28.fc7.

**my pc**
M/B ASUS P4R800V
RAID CONTROLER SiS 180
one SATA HDD

thank you(In reply to comment #0)
> Description of problem:
> sata_sis 0000:00:05.0: Detected SiS 180/181/964 chipset in SATA mode
> ata3: COMRESET failed (errno=768)
> ata3: reset failed (errno=768), retrying in 10 secs
> ata3: reset failed, giving up
> 
> Version-Release number of selected component (if applicable):
> Linux 2.6.23.1-42.fc8 #1 SMP
> 
> How reproducible:
> Very
> 
> Steps to Reproduce:
> 1. Boot Fedora 8 RC3 on a motherboard having the SIS964 chipset and SATA HDD
> 2.
> 3.
>   
> Actual results:
> Slow boot and failed detection of the SATA Hard Disk
> 
> Expected results:
> Normal boot and detection of the SATA Hard Disk
> 
> Additional info:
> This also occured in OpenSUSE 10.3 upon its initial release

(In reply to comment #10)
> Patch in CVS

Comment 12 Masaki MIWA 2007-11-15 11:01:20 EST
*report

sorry, i'm not good at English

i had same sata-hdd-problem too.
kernel 2.6.22 worked fine with F7 but 2.6.23 doesn't.
since i installed kernel 2.6.23.1-26.fc7, F7 become to be fine again.
and kernel 2.6.23.1-28-fc7 is fine too.

i did upgrade from F7 to F8.
F8 didn't work fine with kernel 2.6.23.1-49.fc8 on my pc, but worked fine with 
kernel 2.6.23.1-28.fc7.

**my pc**
M/B ASUS P4R800V
RAID CONTROLER SiS 180
one SATA HDD

thank you(In reply to comment #0)
> Description of problem:
> sata_sis 0000:00:05.0: Detected SiS 180/181/964 chipset in SATA mode
> ata3: COMRESET failed (errno=768)
> ata3: reset failed (errno=768), retrying in 10 secs
> ata3: reset failed, giving up
> 
> Version-Release number of selected component (if applicable):
> Linux 2.6.23.1-42.fc8 #1 SMP
> 
> How reproducible:
> Very
> 
> Steps to Reproduce:
> 1. Boot Fedora 8 RC3 on a motherboard having the SIS964 chipset and SATA HDD
> 2.
> 3.
>   
> Actual results:
> Slow boot and failed detection of the SATA Hard Disk
> 
> Expected results:
> Normal boot and detection of the SATA Hard Disk
> 
> Additional info:
> This also occured in OpenSUSE 10.3 upon its initial release

(In reply to comment #10)
> Patch in CVS

Comment 13 Masaki MIWA 2007-11-17 21:43:44 EST
i downloaded "linux 2.6.23.1-58.fc8" from koji.fedoraproject.org and 
it works fine with sis 180 raid controler and single sata hdd (not raid).
thank you.
Comment 14 Scott McMahan 2007-11-19 10:28:09 EST
With:

ID	24568
Package Name	kernel
Version	2.6.23.1
Release	58.fc8

SATA seems to be working fine with the SiS 964 chipset. I am able to mount and
use my SATA drive as usual. No "COMRESET failed (errno=768)" messages appear
during the boot process.
Comment 15 Chuck Ebbert 2007-11-21 14:33:17 EST
in 2.6.23.8-62
Comment 16 Chuck Ebbert 2007-11-21 14:33:40 EST
*** Bug 389721 has been marked as a duplicate of this bug. ***
Comment 17 Domingo Becker 2007-11-23 07:27:05 EST
(In reply to comment #4)
> Fixed by commit aaa092a114696f4425cd57c4d7fa05110007e247
> This will be in the next kernel release, but will not help people who can't
install.
> 

As Chuck says, the problem seems to be resolved for SiS chipset, but for people
who can't install, we need a new respin.
I tested doing my own live cd with revisor, from the rawhide template. It
installed the kernel 2.6.24-0.39.rc3.git1.fc9 in the live cd.
But unfortunately, the boot stops when it can't find /sbin/init. It seems the
revisor's livecd from rawhide template is incomplete or broken.
I will continue testing with the rawhide kernel, creating my boot cd with
revisor, and I'll let you know when I succeed installing Fedora in my computer
with Sis964 chipset.

regards
Comment 18 Mitchell 2007-12-06 18:23:16 EST
Add me to the list of 'Me Too'.

I was going to do a clean install of my FC6 server to F8 but this bug stopped me
dead in my tracks.  F7 worked fine bug i dont want to go through all the hasles
of upgraded to only get 6 months of updates out of the ordeal.

Please create a fix!

Thanks,
mitchell

Note You need to log in before you can comment on or make changes to this bug.