Bug 365611 - TAHI--DHCPv6--The recieved Reply message do not include valid NoBinding Status code
TAHI--DHCPv6--The recieved Reply message do not include valid NoBinding Statu...
Status: CLOSED DUPLICATE of bug 365661
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-04 02:39 EST by Zhiyong Wu
Modified: 2008-01-15 23:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 23:13:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-04 02:39:52 EST
Description of problem:

  When having dhcpv6 tests about "Reception of Release message with invalid 

IA_NA Identifier" in the server mode,we found that The recieved Reply message 

do not include valid NoBinding Status code in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   The Reply message do not include valid NoBinding Status code.

Expected results:

   The Reply message should include valid NoBinding Status code. 

Additional info:
  
   please refer to
 
http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_
1_0_7_server/rfc3315/index.html

   (1) 59 Part C : Reception of Release message with invalid IA_NA Identifier 

   (2) 62 Part C : Reception of Decline message with invalid IA_NA Identifier
Comment 1 RHEL Product and Program Management 2007-11-07 05:24:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Zhiyong Wu 2007-12-27 23:56:06 EST
the bug has been tested FAIL with dhcpv6-1.0.4-1.el5.i386.rpm 
dhcpv6-client-1.0.4-1.el5.i386.rpm  libdhcp6client-1.0.4-1.el5.i386.rpm.

But the new question occurs as shown below:

please refer to
 
http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071225/DHCPv6_Self_Test_P2_1_0_8_server/rfc3315/index.html

   (1) 59 Part C : Reception of Release message with invalid IA_NA Identifier 

   (2) 62 Part C : Reception of Decline message with invalid IA_NA Identifier




Comment 3 David Cantrell 2008-01-15 23:13:31 EST

*** This bug has been marked as a duplicate of 365661 ***

Note You need to log in before you can comment on or make changes to this bug.