Bug 365661 - TAHI--DHCPv6--The returned status code of the recieved DHCPv6 Advertise Message is not NoAddrsAvail
TAHI--DHCPv6--The returned status code of the recieved DHCPv6 Advertise Messa...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
urgent Severity medium
: rc
: ---
Assigned To: David Cantrell
: ZStream
: 365611 (view as bug list)
Depends On:
Blocks: 253764 455723
  Show dependency treegraph
 
Reported: 2007-11-04 03:05 EST by Zhiyong Wu
Modified: 2009-01-20 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:38:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-04 03:05:15 EST
Description of problem:

  When having dhcpv6 tests about "Advertise message transmission with Status 

Code Option, NoAddrAvail" in the server mode,we found that the returned status 

code of the recieved DHCPv6 Advertise Message is not NoAddrsAvail.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   The returned status code of the recieved DHCPv6 Advertise Message is not 

NoAddrsAvail.

Expected results:

   The returned status code of the recieved DHCPv6 Advertise Message should be 

NoAddrsAvail.

Additional info:
  
   please refer to
 
http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_
1_0_7_server/rfc3315/index.html

   (1) 29 Part D : Advertise message transmission with Status Code Option, 
NoAddrAvail
Comment 1 RHEL Product and Program Management 2007-11-07 05:24:31 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Zhiyong Wu 2007-12-28 01:44:35 EST
also about status code,

Additional info:
  
   please refer to

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071225/DHCPv6_Self_Test_P2_1_0_8_server/rfc3315/index.html

   (1) 59	Part C : Reception of Release message with invalid IA_NA Identifier

   (2) 62	Part C : Reception of Decline message with invalid IA_NA Identifier
Comment 3 David Cantrell 2008-01-15 23:08:39 EST
Fixed upstream and will be in dhcpv6-1.0.5.
Comment 4 David Cantrell 2008-01-15 23:13:32 EST
*** Bug 365611 has been marked as a duplicate of this bug. ***
Comment 11 Denise Dumas 2008-06-06 09:42:01 EDT
This works when there is only one IA_NA but fails for multiple IA_NA options.
Known issue, OK for DoD cert.
Comment 12 Red Hat Bugzilla 2008-07-07 21:24:24 EDT
Adding yshao@redhat.com to the cc list as the manager of the disabled user zwu@redhat.com who reported this bug
Comment 13 David Cantrell 2008-07-15 19:13:17 EDT

*** This bug has been marked as a duplicate of 439526 ***
Comment 14 David Cantrell 2008-07-15 19:29:30 EDT
A fix for this issue should be in dhcpv6-1.0.10-6.el5 and later builds.
Comment 22 errata-xmlrpc 2009-01-20 16:38:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0165.html

Note You need to log in before you can comment on or make changes to this bug.