This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 366051 - gdesklets fails to start
gdesklets fails to start
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdesklets (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
:
: 383451 (view as bug list)
Depends On:
Blocks: 383451
  Show dependency treegraph
 
Reported: 2007-11-04 14:46 EST by Eric Harney
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 05:28:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2007-11-04 14:46:47 EST
Description of problem:
Tried to run gdesklets for the first time on this machine, fails with a python
assertion message

Version-Release number of selected component (if applicable):
gdesklets-0.35.4-9.fc8
python-2.5.1-15.fc8

How reproducible:
Every time

Steps to Reproduce:
1. $ gdesklets
  
Actual results:

$ gdesklets 
Starting gdesklets-daemon...
Connecting to daemon [  ###        ]python: Modules/gcmodule.c:261: update_refs:
Assertion `gc->gc.gc_refs != 0' failed.
Connected to daemon in 204 milliseconds.

==========================================================[11/04/07-14:42:25]===
=== Unhandled error! Something bad and unexpected happened. ===

[EXC]
in /usr/bin/gdesklets: line 399 <module>
in /usr/bin/gdesklets: line 273 parse_command
in /usr/bin/gdesklets: line 177 __open_profile
in /usr/bin/gdesklets: line 167 __client_daemon
in /usr/lib64/gdesklets/main/client.py: line 208 set_remove_command
in /usr/lib64/gdesklets/main/client.py: line 38 __send
in /usr/lib64/gdesklets/utils/xdr.py: line 75 recv
[EXC]/usr/lib64/gdesklets/utils/xdr.py

[---]   70     chunk = ""
[---]   71     while (True):
[---]   72         try:
[---]   73             length = ord(s.recv(1))
[---]   74         except:
[ERR]>  75             raise XDRError
[---]   76 
[---]   77         if (length): chunk += s.recv(length)
[---]   78 
[---]   79         flag = s.recv(1)
[---]   80         if (flag == _CONT): continue
[---]   81
Comment 1 Luya Tshimbalanga 2007-11-09 01:04:07 EST
After installing Fedora 8 from scratch, I attempted to reproduce the bug.
gdesklets has been succesfully installed without problem and perfectly executes.
Seeing the traceback, it appears the issue is related to gc, not gdesklets. Try
to update the gc package and see if gdesklets works.
Comment 2 Luya Tshimbalanga 2007-11-14 02:38:50 EST
Running gdeskets for a while. I have seen no problem with the starting. It seems
you have used Fedora 8 RC3. Could you confirm if gdesklets is working on your
system?
Comment 3 Eric Harney 2007-11-14 17:41:24 EST
I'm still seeing the same problem -- running all the latest F8 packages.

gc-7.0-6.fc8
gdesklets-0.35.4-9.fc8
python-2.5.1-15.fc8

What can I try from here to troubleshoot?
Comment 4 Tyler Owen 2007-11-14 21:00:20 EST
I am not having any issues running gdesklets either on my two Fedora 8 machines.
 However my machines are not 64bit.  

Luya, are you machines 64bit?

Could you check to see if there is anything useful in
~/.gdesklets/logs/gdesklets%3A0.0.log
Comment 5 Eric Harney 2007-11-14 21:10:39 EST
The log file is just one line:
Log messages of /home/emh/.gdesklets/logs/gdesklets%3A0.0.log

Comment 6 Luya Tshimbalanga 2007-11-15 04:24:15 EST
(In reply to comment #4)
> I am not having any issues running gdesklets either on my two Fedora 8 machines.
>  However my machines are not 64bit.  
> 
> Luya, are you machines 64bit?

Yes, the system is 64bit. I failed to reproduce the problem because gdesklets
started without issue.
It seems gc module inside python failed to start thus causing gdesklets to
traceback. 

Eric, could start gdesketls from terminal with all traceback?
Comment 7 Eric Harney 2007-11-19 08:55:48 EST
(In reply to comment #6)
> Eric, could start gdesketls from terminal with all traceback?

How do I do this?
Comment 8 Luya Tshimbalanga 2007-11-20 02:28:43 EST
Retry to run gdesklets from the terminal. I suspect the problem is related to
python module with this"
"python: Modules/gcmodule.c:261: update_refs:
Assertion `gc->gc.gc_refs != 0' failed."

It seems gc value is 0 hence the failure. Not sure what caused the issue.
Comment 9 Luya Tshimbalanga 2007-11-20 03:04:37 EST
Please test
http://luya.fedorapeople.org/packages/RPMS/gdesklets-0.36-0.1.beta.fc8.x86_64.rpm
to see if the issue goes away.
Comment 10 Eric Harney 2007-11-20 07:44:34 EST
(In reply to comment #9)
> Please test
> http://luya.fedorapeople.org/packages/RPMS/gdesklets-0.36-0.1.beta.fc8.x86_64.rpm
> to see if the issue goes away.

This seems to work -- it starts up and I don't see this error.

(Running the older 0.35.4 still gives the same error.)
Comment 11 Fedora Update System 2007-11-20 12:55:49 EST
gdesklets-0.36-0.1.1.beta.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdesklets'
Comment 12 Luya Tshimbalanga 2007-11-29 02:57:33 EST
*** Bug 383451 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.