Bug 366401 - PulseAudio can not started as systemwide.
PulseAudio can not started as systemwide.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: padevchooser (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 00:55 EST by Adrin Jalali
Modified: 2008-03-27 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 11:46:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2007-11-05 00:55:01 EST
Description of problem:
There is no default daemon to manage pulseaudio, and it has problems when is
started as systemwide as root, so I could not use an init script for that,
because it must be started as the user. I sould start it everytime I login to X.

Version-Release number of selected component (if applicable):
akode-pulseaudio-2.0.1-9.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-zeroconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
kde-settings-pulseaudio-3.5-34.fc8
pulseaudio-module-zeroconf-0.9.7-0.17.svn20071017.fc8


How reproducible:
Just install the OS.

Actual results:
No daemon present.

Expected results:
A daemon starting pulseaudio.
Comment 1 Mike Cohler 2007-11-10 17:18:04 EST
Is this related to my report at:
https://bugzilla.redhat.com/show_bug.cgi?id=373881

I see problems in KDE with audio - and in /var/log/messages I get a line:
Nov  9 17:41:21 lapmike2 pulseaudio[2914]: main.c: This program is not intended
to be run as root (unless --system is specified).
Comment 2 Adrin Jalali 2007-11-10 23:04:53 EST
Yes, you or that program or script running pulseaudio is running that as root
and must send --system switch to pulseaudio. But the problem is that even if you
send that switch to pulseaudio it does not start and in some experiments it was
seen that even if it starts, clients from users can not connect to that, and so
the user must start it manually as user.
Comment 3 Lennart Poettering 2007-11-11 11:46:58 EST
In Fedora PulseAudio is started as a session daemon.

If you want to start PulseAudio as system wide daemon than you have to manually
create an init script and set up a few things like an access group 'pulse-access'.

Please note that it is not recommended to start PA as system daemon. If you do
it, than you are expected to know pretty well what you are doing. In most cases
running PA as system daemon is *not* what you want. The only use case where this
might make sense is on thin clients where no local user exists.

I will close this bug now, since PA is run as a session daemon on Fedora.
Comment 4 Habig, Alec 2008-03-27 12:45:24 EDT
Note that as a consequence running all sound through PA, a session daemon, sound
for a Fedora system is now broken by default unless a user is using a X session
which is already set up to start PA (ie, gnome, kde).  Someone running a
different window manager, or heaven forbid, trying to work in a text console, is
toast unless they go learn how to run PA themselves (something I'm just now
starting on).  

Rather than being tied to a high-level Xwindows session manager, shouldn't PA be
started by default at login along with the other local, userspace device
wrangling which happens when someone logs in on console rather than remotely? 
Which is a process that appears to have changed a great deal since I last looked
at it, so I've no useful specific suggestions right now, but I could open a new
bugzilla entry to work on it.

"No sound for you" (unless you're using gnome or kde) seems a rather draconian
default.  Sound is something which, having no graphical component, should work
in runlevel 3, but currently does not.

Note You need to log in before you can comment on or make changes to this bug.