Bug 36674 - 2.4.3-2.9.2: duplicate aic7xxx.o module.
2.4.3-2.9.2: duplicate aic7xxx.o module.
Status: CLOSED DUPLICATE of bug 36602
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 13:57 EDT by Sam Varshavchik
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 13:57:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-04-19 13:57:48 EDT
Installed by 2.4.3-2.9.2:

/lib/modules/2.4.3-2.9.2/kernel/drivers/scsi/aic7xxx/aic7xxx.o
/lib/modules/2.4.3-2.9.2/kernel/drivers/scsi/aic7xxx.o

This results in an error in the mkinitrd script:


    fmPath=`(cd /lib/modules/$kernel; find -type f -name $modName.o)`

    if [ ! -f /lib/modules/$kernel/$fmPath ]; then
        if [ -n "$skiperrors" ]; then
            return
        fi


Find will print the paths to both aic7xxx.o modules, so fmPath will contain
two words, and the if statement will fail.



Same thing in the smp package.
Comment 1 Arjan van de Ven 2001-04-19 14:01:03 EDT
Thanks for the report!
(but it appears to be a dupe of 36602)

*** This bug has been marked as a duplicate of 36602 ***

Note You need to log in before you can comment on or make changes to this bug.