Bug 368031 - yum info for LANG=it_IT => crash
yum info for LANG=it_IT => crash
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 04:26 EST by marco bernardi
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 09:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marco bernardi 2007-11-06 04:26:42 EST
Description of problem:
After general update of november 6 (Kernel 2.6.23.1-21.fc7) 

for LANG=it_IT 

yum info <something> => crash




Version-Release number of selected component (if applicable):
Yum Version: 3.2.7

How reproducible:
export LANG=it_IT or export LANG=it_IT.UTF-8
yum info samba

Installed Packages
Name   : samba
Arch   : i386
Version: 3.0.26a
Release: 6.fc7
Size   : 7.1 M
Repo   : installed
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 105, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 282, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 168, in doCommand
    rip = base.listPkgs(ypl.installed, 'Installed Packages', basecmd)
  File "/usr/share/yum-cli/output.py", line 129, in listPkgs
    self.infoOutput(pkg)
  File "/usr/share/yum-cli/output.py", line 99, in infoOutput
    print _("Summary: %s") % enc(pkg.summary)
  File "/usr/share/yum-cli/output.py", line 86, in enc
    t = gettext.dgettext(d, s)
  File "/usr/lib/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2007-11-06 09:01:39 EST
   

*** This bug has been marked as a duplicate of 252136 ***
Comment 2 marco bernardi 2007-11-06 10:20:25 EST
(In reply to comment #1)
>    
> 
> *** This bug has been marked as a duplicate of 252136 ***

OK... but why such bug has status "CLOSED" ?

Note You need to log in before you can comment on or make changes to this bug.