Bug 3696 - tftp install on headless Sparcstation 1+ fails
tftp install on headless Sparcstation 1+ fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
: 8761 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-24 01:01 EDT by Jeremy Katz
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 18:23:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 1999-06-24 01:01:44 EDT
Hi.  I've been trying to install RedHat 6 on a SparcStation
1+ without success this evening.  First, I attempted to boot
with the updated tftp32.img from updates.redhat.com.  This
transfer mysteriously stops partially through the install
process with no message on the Sparc or the tftp server
(rh6, SMP intel).

So, instead, I attempted to go the method of NFS root using
vmlinux32 as the boot kernel.  This actually boots the
kernel and gets to the mounting of the root fs and gives a
kernel panic because it can't mount the root fs 00:00.

Ideas?

------- Additional Comments From   06/24/99 16:54 -------
Actually, to clarify where the hang with tftp32.img occurs; it occurs while downloading this image to the SS.  I just did this twice and both times it stopped at 1c6a00.
Comment 1 Jay Turner 1999-06-28 10:09:59 EDT
There are some known issues with using tftp boot on slower sparcs or
on networks that are a little dirty.  Frequestly you will get these
timeouts when attempting to retrieve the boot file.  I would recommend
1 of 2 things: download the tftp image to make sure that you have a
good copy, and if failure does occur, try again a couple of times.  We
have machines in the lab that from time to time need 3 or 4 attempts
at the tftp boot.  We are able to load the new images on sparc
machines, so the image on the site is known good.  Reopen the bug if
you are still having problems.
Comment 2 Jeremy Katz 1999-07-11 22:39:59 EDT
I've downloaded the image again and I also checked the md5sum this
time and it came up fine.  So, the image itself that I downloaded is
fine.  I have also tried booting it 5-10 times in a row on a couple of
occasions without success.  I don't think that a dirty network is the
cause as it is only a local network with very low traffic and
congestion.  Also, I received an email from someone else with the
exact same problem on a SS2 while I was gone on vacation, so it sounds
like it could be a more serious problem.
Comment 3 slickgardner 1999-07-22 18:24:59 EDT
I've had the same problem with tftp32 image, on a Sparc1 w/64megs.
the 5.2 image works fine, all the time.  the 5.9 fails.  I just
downloaded all of 6.0 and will try tonight.  The network is only 2
machines, no traffic.
Comment 4 slickgardner 1999-07-26 14:06:59 EDT
I've had no problems at all with the tftp32.img I downloaded from the
update dir.  All net boot's have gone just fine, with the install
then working fine (mostly!).
The only thing that i've noticed is that things are SLOW.  If I
install packages totalling more than 200 megs, It looks a lot like
the machine hangs in several places, notably while it is checking for
dependencies (no progress dialogs or anything!) and just before,
during, and after the "Finding overlapping Files" part of the
install.  Some progress dialogs there would be nice for the slow
machines that take 30+ minutes to chug through the rpm database...
Now if someone could tell me why the "installing bootloader" part
never succeeds, i'll be a happy camper!
Comment 5 Jeremy Katz 1999-07-26 18:18:59 EDT
I expect it will be slow, once it gets beyond the point loading the
image.  I have yet to get it beyond the 1c6a00 mark of tftp'ing the
image.  And not only does it stop downloading the image, the machine
just completely stops responding; requiring the power switch to abort
it
Comment 6 Jay Turner 1999-08-02 14:15:59 EDT
OK, about the only other thing that I can offer is how much RAM is in
the machine??  There may be a conflict that the system is not able to
load all of the boot image.   The only other thing that I can imagine
is that we are looking at a hardware problem.  Either the boot image
does not work with 1+ machines (we do not have one in the lab,
therefore cannot test) or your machine is hitting problems with the
image.  I am tending to think that it is either memory or a conflict
with hardware.  I will pass this on to a developer for further action.
Comment 7 csnell 1999-08-25 18:23:59 EDT
I'm curious as to the answer to this issue before I try the updated
images.  I've been using a CD, but it just hangs after choosing the
packages.  If the folks at RedHat want, my machine is an IPC with
32Megs; I work right around the corner from you, and I'd be more than
willing to loan you the machine if it will help get a fix for this
problem.  E-mail me if you're interested.

------- Additional Comments From   08/25/99 19:04 -------
If it hangs right after selecting packages, that's another bug (don't
know the bug number offhand).  There is something in bugzilla related
to that though, they were able to solve it by waiting for a while, and
I mean a _long_ while.

Unfortunately, as to my install problem, I don't think that RedHat is
even watching this bug anymore for the most part, as the Assigned to
doesn't have an email address for the bug.  My other bug in the
database at least has an email address for the person it's assigned
to, though as of yet, they haven't emailed me which is annoying.

Anyway, best of luck.  Like I said, the word on sparc-list about your
hang was to just to let it try for a while.

------- Additional Comments From   10/05/99 15:21 -------
I've had the same probs on my SS1+, it just dies while downloading the
image, always at 1c6a00. I've got boot PROM version 1.3 and the box
has 16 MB of RAM. Tried both the origial 6.0 and the updated image.
5.2 works fine...
Comment 8 David Harris 1999-11-24 14:27:59 EST
RH:

I've had similar problems booting my Tektronix X-Terminal.  I used to boot it
just fine from RH5.2 using TFTP protocol.  I upgraded to RH6.1 and now I observe
the following symptoms:

1. The TFTP host (RH6.1) serves about half of the OS file, then mysteriously
stops - no errors just stops.
2. If I ping the host from the terminal's boot monitor, I get 119 good replies
and then, no more replies - just failed pings

I believe these two are related, because I never had either of these issues with
RH5.2. I have tried 3 different versions of the 3c59x device driver including
the one from RH5.2 to no avail.  I even tried a clean install of 6.1.  SOMETHING
HAS CHANGED IN 6.1!!!

Please offer suggestions on how I can debug this problem for myself, or let me
know what other information is needed.  I can tell that I'm not alone here with
TFTP problems under 6.1.

--David H.
jazztunes@yahoo.com
Comment 9 Jeremy Katz 2000-07-14 01:01:37 EDT
*** Bug 8761 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.