Bug 8761 - TFTP install boot on SPARCstation 1+ fails
TFTP install boot on SPARCstation 1+ fails
Status: CLOSED DUPLICATE of bug 3696
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
: 9939 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-23 03:24 EST by Bitt Faulk
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 13:33:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bitt Faulk 2000-01-23 03:24:21 EST
I have a SPARCstation 1+ that I am trying to install RedHat 6.1 on.  The
machine is "headless", meaning without a framebuffer or keyboard.  I am
booting and trying to install it via the serial port ttya.  I downloaded
ftp://ftp.redhat.com/pub/redhat/redhat-6.1/sparc/images/tftp32.img and
tried to tftp boot off of it.  The machine loads the image, to offset
130600, according to the Boot PROM, and then hangs there indefinitely, and
it seems to lock up hard.  Even a break sent to the serial port will not
pop it back out to the PROM monitor.

Here's the log of the boot:

<--- Capture --->
SPARCstation 1+, No keyboard.
ROM Rev. 1.3, 28 MB memory installed, Serial #12648430.
Ethernet address 8:0:20:c0:ff:ee, Host ID: 53c0ffee.


Testing

Type b (boot), c (continue), or n (new command mode)
>n
Type  help  for more information
ok boot net
Booting from: le(0,0,0)
130600
<--- Capture --->

The cursor is left on the same line as the block count, with a single space
after the count (underneath the space between "Booting" and "from:".

A tcpdump shows:

03:13:50.174129 rarp who-is 8:0:20:c0:ff:ee tell 8:0:20:c0:ff:ee
03:13:50.174160 rarp reply 8:0:20:c0:ff:ee at sparky.beaglebros.com
03:13:50.199004 sparky.beaglebros.com.38393 >
                count-zero.totalsports.net.tftp:
                23 RRQ "AC1000FE.SUN4C" (ttl 123, id 1234)
03:13:50.392473 count-zero.totalsports.net.1127 >
                sparky.beaglebros.com.38393: udp 516 (ttl 64, id 10461)
03:13:50.410964 sparky.beaglebros.com.38393 >
                count-zero.totalsports.net.1127: udp 4 (ttl 123, id 1234)
03:13:50.411564 count-zero.totalsports.net.1127 >
                sparky.beaglebros.com.38393: udp 516 (ttl 64, id 10462)

and then the tftp d/l continues for quite a while with no changes in the
pattern until the end:

03:14:47.648571 sparky.beaglebros.com.38393 >
                count-zero.totalsports.net.1127: udp 4 (ttl 123, id 1234)
03:14:47.648638 count-zero.totalsports.net.1127 >
                sparky.beaglebros.com.38393: udp 516 (ttl 64, id 12865)
03:14:47.672857 sparky.beaglebros.com.38393 >
                count-zero.totalsports.net.1127: udp 4 (ttl 123, id 1234)
03:14:47.672920 count-zero.totalsports.net.1127 >
                sparky.beaglebros.com.38393: udp 4 (ttl 64, id 12866)
03:14:47.687980 sparky.beaglebros.com.38393 >
                count-zero.totalsports.net.1127: udp 4 (ttl 123, id 1234)

and then it stops dead.

Again, I cannot break out to the 'ok' prompt; I have to power-cycle the
machine.  I have not been able to test it from a framebuffer, as I don't
have a 13W3 monitor or adapter available.  I have tried it with and without
a framebuffer installed.

Also, Debian slink seems to install fine, and the Solaris boot image boots,
but I don't have a Solaris machine on this subnet to perform an install
with.
Comment 1 Bitt Faulk 2000-01-24 23:06:59 EST
Also, I found a SCSI cdrom and attached that.  It now seems to be installing
fine off of the CD.  So there must be some sort of problem with the tftp boot
image specifically.
Comment 2 Bill Nottingham 2000-03-04 16:23:59 EST
*** Bug 9939 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2000-07-14 01:01:39 EDT

*** This bug has been marked as a duplicate of 3696 ***

Note You need to log in before you can comment on or make changes to this bug.