Bug 369801 - Tablet broken (upgrade from 2.6.23.1-10 to 2.6.23.1-21)
Tablet broken (upgrade from 2.6.23.1-10 to 2.6.23.1-21)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 10:48 EST by Sander Klous
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 11:02:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/bus/input/devices (2.27 KB, text/plain)
2007-11-08 17:05 EST, Sander Klous
no flags Details
/etc/X11/xorg.conf (1.16 KB, text/plain)
2007-11-08 17:07 EST, Sander Klous
no flags Details
/var/log/Xorg.0.log (75.28 KB, text/plain)
2007-11-08 17:08 EST, Sander Klous
no flags Details
ls -l /dev/input/* (1.94 KB, text/plain)
2007-11-08 17:09 EST, Sander Klous
no flags Details
/proc/bus/input/devices 2.6.23.1-21 (2.12 KB, text/plain)
2007-11-09 04:19 EST, Sander Klous
no flags Details
ls -l /dev/input/* 2.6.23.1-21 (1.65 KB, text/plain)
2007-11-09 04:20 EST, Sander Klous
no flags Details
/var/log/Xorg.0.log 2.6.23.1-21 (41.35 KB, text/plain)
2007-11-09 04:21 EST, Sander Klous
no flags Details
/var/log/dmesg 2.6.23.1-10 (25.43 KB, text/plain)
2007-11-09 16:38 EST, Sander Klous
no flags Details
/var/log/dmesg 2.6.23.1-21 (25.52 KB, text/plain)
2007-11-09 16:51 EST, Sander Klous
no flags Details

  None (edit)
Description Sander Klous 2007-11-07 10:48:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
The tablet of the Thinkpad X61 Tablet (ID=WACF008) doesn't work with the newest kernel version. It broke after an upgrade from kernel-2.6.23.1-10.fc7 to kernel-2.6.23.1-21.fc7. I've checked the kernel src rpm, but it still contains the patch to include WACF008 in the serial kernel driver. So, something else must be broken...

Thanks,
Sander Klous

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-21.fc7

How reproducible:
Always


Steps to Reproduce:
1. Boot kernel-2.6.23.1-21.fc7.
2. Try to start gdm with wacom enabled.
3. X fails to start

Actual Results:
X tries to restart n times and gives up.

Expected Results:
X should start normally

Additional info:
Comment 1 Chuck Ebbert 2007-11-07 16:52:24 EST
Does going back to the previous kernel fix the problem?
Comment 2 Sander Klous 2007-11-07 17:02:14 EST
(In reply to comment #1)
> Does going back to the previous kernel fix the problem?
> 

I removed 2.6.23.1-10, but I still have 2.6.22.9-91 installed. The tablet works
fine when I boot into that version. Do you want me to explicitly test on
2.6.23.1-10 again or is it sufficient to know that my tablet at the moment still
works when I boot into 2.6.22.9-91 and fails when I boot into 2.6.23.1-21?
Comment 3 Chuck Ebbert 2007-11-07 18:24:46 EST
2.6.22.9-91 did not have kernel support for those devices. It looks like maybe
adding support made them stop working??
Comment 4 Sander Klous 2007-11-08 02:20:55 EST
(In reply to comment #3)
> 2.6.22.9-91 did not have kernel support for those devices. It looks like maybe
> adding support made them stop working??
> 

I just reinstalled 2.6.23.1-10 to check your hypothesis.
In 2.6.23.1-10 the tablet is working fine.
Comment 5 Chuck Ebbert 2007-11-08 14:59:06 EST
Could you possibly try some of these other kernels to see where the problem
starts?

-17
http://koji.fedoraproject.org/koji/buildinfo?buildID=22895

-19
http://koji.fedoraproject.org/koji/buildinfo?buildID=22976

-20
http://koji.fedoraproject.org/koji/buildinfo?buildID=23094


Comment 6 Aristeu Rozanski 2007-11-08 16:17:36 EST
Sander, do you have to touch the tablet with the pen to work in 2.6.23-1-10?
The question is because that's how a tablet will behave in X if there's no proper
kernel and X tablet drivers loaded.
Comment 7 Chuck Ebbert 2007-11-08 16:18:42 EST
Also, what is in the file /etc/X11/xorg.conf ?
Comment 8 Aristeu Rozanski 2007-11-08 16:19:30 EST
Also, please attach here:
    /proc/bus/input/devices
    /etc/X11/xorg.conf
    /var/log/Xorg.0.log
    ls -l /dev/input/*
Comment 9 Sander Klous 2007-11-08 16:59:37 EST
(In reply to comment #6)
> Sander, do you have to touch the tablet with the pen to work in 2.6.23-1-10?
> The question is because that's how a tablet will behave in X if there's no
> proper kernel and X tablet drivers loaded.

Sorry, I don't understand the question. Do you mean that I have to test if the
tablet works when the pen is close to the screen instead of touching it? Or do
you mean that I should try to move the cursor by touching the screen with my
finger instead of the pen? Or do you mean something else?
Comment 10 Sander Klous 2007-11-08 17:05:57 EST
Created attachment 252201 [details]
/proc/bus/input/devices
Comment 11 Sander Klous 2007-11-08 17:07:01 EST
Created attachment 252211 [details]
/etc/X11/xorg.conf
Comment 12 Sander Klous 2007-11-08 17:08:42 EST
Created attachment 252221 [details]
/var/log/Xorg.0.log
Comment 13 Sander Klous 2007-11-08 17:09:35 EST
Created attachment 252231 [details]
ls -l /dev/input/*
Comment 14 Sander Klous 2007-11-08 17:11:03 EST
(In reply to comment #8)
> Also, please attach here:
>     /proc/bus/input/devices
>     /etc/X11/xorg.conf
>     /var/log/Xorg.0.log
>     ls -l /dev/input/*
> 

I've done this for 2.6.23.1-10, do you want it for 2.6.23.1-21 as well?
Comment 15 Chuck Ebbert 2007-11-08 17:16:35 EST
(In reply to comment #14)
> I've done this for 2.6.23.1-10, do you want it for 2.6.23.1-21 as well?
> 

Yes, that would be helpful too.

Comment 16 Aristeu Rozanski 2007-11-08 17:18:32 EST
> Sorry, I don't understand the question. Do you mean that I have to test if the
> tablet works when the pen is close to the screen instead of touching it? Or do
> you mean that I should try to move the cursor by touching the screen with my
> finger instead of the pen? Or do you mean something else?
tablets usually have proximity information, so you don't need to touch the
tablet with the pen to make the pointer move. Can you move the pointer using the
pen without touching the screen with the pen?


Comment 17 Aristeu Rozanski 2007-11-08 17:21:55 EST
hm. it's a serial based tablet and it will use only userlevel, Xorg, driver.
Unless the serial port support is broken, the kernel shouldn't be the culprit.
Also, forget about the proximity question: it happens only for USB tablets.
Chuck, any relevant serial/tty changes between those versions?
Comment 18 Sander Klous 2007-11-08 17:30:34 EST
> tablets usually have proximity information, so you don't need to touch the
> tablet with the pen to make the pointer move. Can you move the pointer using the
> pen without touching the screen with the pen?

Yes, I can. If the pen comes closer to the screen than about 1 cm, the pointer
starts moving.
Comment 19 Sander Klous 2007-11-09 04:17:58 EST
(In reply to comment #5)
> Could you possibly try some of these other kernels to see where the problem
> starts?
> 
> -17
> http://koji.fedoraproject.org/koji/buildinfo?buildID=22895
> 
> -19
> http://koji.fedoraproject.org/koji/buildinfo?buildID=22976
> 
> -20
> http://koji.fedoraproject.org/koji/buildinfo?buildID=23094
> 

None of these work :(

Comment 20 Sander Klous 2007-11-09 04:19:34 EST
Created attachment 252481 [details]
/proc/bus/input/devices 2.6.23.1-21
Comment 21 Sander Klous 2007-11-09 04:20:33 EST
Created attachment 252491 [details]
ls -l /dev/input/* 2.6.23.1-21
Comment 22 Sander Klous 2007-11-09 04:21:28 EST
Created attachment 252501 [details]
/var/log/Xorg.0.log 2.6.23.1-21
Comment 23 Sander Klous 2007-11-09 04:34:29 EST
(In reply to comment #17)
> hm. it's a serial based tablet and it will use only userlevel, Xorg, driver.
> Unless the serial port support is broken, the kernel shouldn't be the culprit.
> Also, forget about the proximity question: it happens only for USB tablets.
> Chuck, any relevant serial/tty changes between those versions?
> 

I just realized I never explicitly tested if it is the wacom that actually makes
X fail. So, I commented out the wacom related parts of xorg.conf to make sure.
Now, 2.6.23.1-21 boots fine (but without tablet functionality of course). So,
indeed the wacom breaks X as I assumed before.
Comment 24 Chuck Ebbert 2007-11-09 11:56:35 EST
Can you upload /var/log/dmesg after booting each kernel?
Comment 25 Sander Klous 2007-11-09 16:38:19 EST
Created attachment 253601 [details]
/var/log/dmesg 2.6.23.1-10
Comment 26 Sander Klous 2007-11-09 16:51:24 EST
Created attachment 253611 [details]
/var/log/dmesg 2.6.23.1-21

Do you want dmesg from the intermediate kernel versions as well?
Comment 28 Chuck Ebbert 2007-11-12 16:08:12 EST
Can you try changing xorg.conf to use /dev/ttyS1 fot the tablet?
Comment 29 Sander Klous 2007-11-13 01:43:21 EST
(In reply to comment #28)
> Can you try changing xorg.conf to use /dev/ttyS1 fot the tablet?

Yes, this did the trick. I now have a working tablet in 2.6.23.1-21.
Thanks!
Comment 30 Chuck Ebbert 2007-11-13 11:02:08 EST
Closing as "notabug."
Comment 32 Sander Klous 2007-11-16 01:57:41 EST
There is still a problem here. Booting my laptop from the docking station
results in /dev/ttyS1 being assigned to my tablet. Booting it standalone results
in /dev/ttyS0 being assigned to my tablet. This is not very convenient, since
/etc/X11/xorg.conf configuration must be changed to accommodate for this. Can
the assignment of /dev/ttyS# be made consistent? Should I put in a separate
feature request for this?
Comment 33 Aristeu Rozanski 2007-11-16 10:23:40 EST
does the ttyS1 appears when you boot without the docking?
Comment 34 Sander Klous 2007-11-16 11:28:43 EST
(In reply to comment #33)
> does the ttyS1 appears when you boot without the docking?

Do you mean in /dev? In that case yes:

[localhost ~]# ls -l /dev/ttyS*
crw-rw---- 1 root uucp 4, 64 2007-11-16 17:07 /dev/ttyS0
crw-rw---- 1 root uucp 4, 65 2007-11-16 18:06 /dev/ttyS1
crw-rw---- 1 root uucp 4, 66 2007-11-16 18:06 /dev/ttyS2
crw-rw---- 1 root uucp 4, 67 2007-11-16 18:06 /dev/ttyS3
[localhost ~]# 
Comment 35 Aristeu Rozanski 2007-11-16 11:35:52 EST
No, check doing:
   dmesg | grep ttyS

and will output something like:
   00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
   00:0c: ttyS1 at I/O 0x200 (irq = 5) is a NS16550A

I want to know if the ttyS1 line appears
Comment 36 Sander Klous 2007-11-16 11:43:37 EST
(In reply to comment #35)
> No, check doing:
>    dmesg | grep ttyS
> 
> and will output something like:
>    00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
>    00:0c: ttyS1 at I/O 0x200 (irq = 5) is a NS16550A
> 
> I want to know if the ttyS1 line appears

This is the output:

[localhost ~]# dmesg|grep ttyS
00:0a: ttyS0 at I/O 0x200 (irq = 5) is a NS16550A
[localhost ~]# 

So no ttyS1...
Comment 37 Aristeu Rozanski 2007-11-16 12:06:43 EST
OK, so what happened was: the kernel didn't supported the dock until the newer
version. And once the dock was identified, it detects another serial port that
is actually the old one.
I have another question: with and without the docking do you use the same
connector for the serial port?
Comment 38 Sander Klous 2007-11-16 12:37:38 EST
> I have another question: with and without the docking do you use the same
> connector for the serial port?

What do you mean with connector? It is a tablet notebook, so the tablet is
integrated into the screen.
Comment 39 Aristeu Rozanski 2007-11-16 13:34:11 EST
duh, forgot about this.
OK, fill another BZ# describing that a different serial port appears when you're
using the dock and the former doesn't works.
Comment 40 Sander Klous 2007-11-16 15:00:09 EST
(In reply to comment #39)
> duh, forgot about this.
> OK, fill another BZ# describing that a different serial port appears when you're
> using the dock and the former doesn't works.
> 

Done, see:
https://bugzilla.redhat.com/show_bug.cgi?id=387551

Note You need to log in before you can comment on or make changes to this bug.