Bug 36985 - upgrade installer fails on raid device
upgrade installer fails on raid device
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 40043 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2001-04-21 11:11 EDT by daryl herzmann
Modified: 2007-03-26 23:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 11:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from installer (sorry about multiple post) (23.90 KB, text/plain)
2001-12-14 14:02 EST, daryl herzmann
no flags Details

  None (edit)
Description daryl herzmann 2001-04-21 11:11:13 EDT
Here you go.  I am doing an upgrade and this happens.  Maybe something
wrong with my raidtab file?  I am trying to upgrade from 6.2

# cat /etc/raditab
raiddev /dev/md0
        raid-level      linear 
        nr-raid-disks   2
        persistent-superblock 1
        chunk-size    32 
        device          /dev/hdb1
        raid-disk       0
        device          /dev/hda5
        raid-disk       1

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 392, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 880, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 501, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 611, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/examine_gui.py", line
40, in getScreen
    self.parts = self.todo.upgradeFindRoot ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1179, in
upgradeFindRoot
    return upgrade.findExistingRoots(self.intf, self.fstab)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/upgrade.py", line 42, in
findExistingRoots
    raid.stopAllRaid(mdList)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/raid.py", line 78, in
stopAllRaid
    isys.raidstop(dev)
  File "/usr/lib/anaconda/isys.py", line 37, in raidstop
    _isys.raidstop(fd)
SystemError: (19, 'No such device')

Local variables in innermost frame:
mdDevice: md0
fd: 15

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
NsS'setupFilesystems'
p5
I1
sS'monitorVsync'
p6
S''
sS'videoCardStateNode'
p7
S''
sS'serial'
p8
I0
sS'ddruidReadOnly'
p9
I0
sS'bootdisk'
p10
I0
sS'videoRamState'
p11
S''
sS'monitorOriginalName'
p12
S''
sS'language'
p13
(itodo
Language
(dp14
S'langInfoByName'
p15
(dp16
S'Arabic (Yemen)'
p17
(S'ar_YE'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Argentina)'
p18
(S'es_AR'
S'iso01'
S'lat0-sun16'
tsS'Italian (Italy)'
p19
(S'it_IT@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Lebanon)'
p20
(S'ar_LB'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Guatemala)'
p21
(S'es_GT'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Libyan Arab Jamahiriya)'
p22
(S'ar_LY'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Oman)'
p23
(S'ar_OM'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Iraq)'
p24
(S'ar_IQ'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Chile)'
p25
(S'es_CL'
S'iso01'
S'lat0-sun16'
tsS'English (South Africa)'
p26
(S'en_ZA'
S'iso01'
S'lat0-sun16'
tsS'French (Switzerland)'
p27
(S'fr_CH'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Bahrein)'
p28
(S'ar_BH'
S'iso06'
S'LatArCyrHeb-16'
tsS'Croatian'
p29
(S'hr_HR'
S'iso02'
S'lat2-sun16'
tsS'French (France)'
p30
(S'fr_FR@euro'
S'iso15'
S'lat0-sun16'
tsS'Greenlandic (Greenland)'
p31
(S'kl_GL'
S'iso01'
S'lat0-sun16'
tsS'Korean (Republic of Korea)'
p32
(S'ko_KR.euckr'
S'iso01'
S'lat0-16'
tsS'Ukrainian'
p33
(S'uk_UA'
S'koi8-u'
S'cyr-sun16'
tsS'Spanish (Mexico)'
p34
(S'es_MX'
S'iso01'
S'lat0-sun16'
tsS'Greek'
p35
(S'el_GR'
S'iso07'
S'gr.f16'
tsS'Spanish (El Salvador)'
p36
(S'es_SV'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Honduras)'
p37
(S'es_HN'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Costa Rica)'
p38
(S'es_CR'
S'iso01'
S'lat0-sun16'
tsS'Dutch (Netherlands)'
p39
(S'nl_NL@euro'
S'iso15'
S'lat0-sun16'
tsS'Serbian (Yugoslavia)'
p40
(S'sr_YU@cyrillic'
S'iso05'
S'cyr-sun16'
tsS'Russian (Ukraine)'
p41
(S'ru_UA'
S'koi8-u'
S'cyr-sun16'
tsS'Afrikaans (South Africa)'
p42
(S'af_ZA'
S'iso01'
S'lat0-sun16'
tsS'Norwegian'
p43
(S'no_NO'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Morocco)'
p44
(S'ar_MA'
S'iso06'
S'LatArCyrHeb-16'
tsS'Portuguese (Portugal)'
p45
(S'pt_PT@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Algeria)'
p46
(S'ar_DZ'
S'iso06'
S'LatArCyrHeb-16'
tsS'French (Belgium)'
p47
(S'fr_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'Indonesian'
p48
(S'id_ID'
S'iso01'
S'lat0-sun16'
tsS'Danish'
p49
(S'da_DK'
S'iso01'
S'lat0-sun16'
tsS'English (Denmark)'
p50
(S'en_DK'
S'iso01'
S'lat0-sun16'
tsS'Faroese (Faroe Islands)'
p51
(S'fo_FO'
S'iso01'
S'lat0-sun16'
tsS'Galician (Spain)'
p52
(S'gl_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'English (New Zealand)'
p53
(S'en_NZ'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Bolivia)'
p54
(S'es_BO'
S'iso01'
S'lat0-sun16'
tsS'Cornish (Britain)'
p55
(S'kw_GB'
S'iso01'
S'lat0-sun16'
tsS'Arabic (United Arab Emirates)'
p56
(S'ar_AE'
S'iso06'
S'LatArCyrHeb-16'
tsS'German (Austria)'
p57
(S'de_AT@euro'
S'iso15'
S'lat0-sun16'
tsS'Romanian'
p58
(S'ro_RO'
S'iso02'
S'lat2-sun16'
tsS'Spanish (Paraguay)'
p59
(S'es_PY'
S'iso01'
S'lat0-sun16'
tsS'Hebrew (Israel)'
p60
(S'he_IL'
S'iso08'
S'LatArCyrHeb-16'
tsS'German (Luxemburg)'
p61
(S'de_LU@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (USA)'
p62
(S'es_US'
S'iso01'
S'lat0-sun16'
tsS'Portuguese (Brasil)'
p63
(S'pt_BR'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Equador)'
p64
(S'es_EC'
S'iso01'
S'lat0-sun16'
tsS'Polish'
p65
(S'pl_PL'
S'iso02'
S'lat2-sun16'
tsS'Slovak'
p66
(S'sk_SK'
S'iso02'
S'lat2-sun16'
tsS'Macedonian'
p67
(S'mk_MK'
S'iso05'
S'cyr-sun16'
tsS'Spanish (Spain)'
p68
(S'es_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Syrian Arab Republic)'
p69
(S'ar_SY'
S'iso06'
S'LatArCyrHeb-16'
tsS'Czech'
p70
(S'cs_CZ'
S'iso02'
S'lat2-sun16'
tsS'Irish'
p71
(S'ga_IE@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Jordan)'
p72
(S'ar_JO'
S'iso06'
S'LatArCyrHeb-16'
tsS'Italian (Switzerland)'
p73
(S'it_CH'
S'iso01'
S'lat0-sun16'
tsS'German (Belgium)'
p74
(S'de_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'Albanian'
p75
(S'sq_AL'
S'iso01'
S'lat0-sun16'
tsS'Finnish'
p76
(S'fi_FI@euro'
S'iso15'
S'lat0-sun16'
tsS'Swedish (Sweden)'
p77
(S'sv_SE'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Peru)'
p78
(S'es_PE'
S'iso01'
S'lat0-sun16'
tsS'Dutch (Belgium)'
p79
(S'nl_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Panama)'
p80
(S'es_PA'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Venezuela)'
p81
(S'es_VE'
S'iso01'
S'lat0-sun16'
tsS'English (Great Britain)'
p82
(S'en_GB'
S'iso01'
S'lat0-sun16'
tsS'Russian'
p83
(S'ru_RU.koi8r'
S'koi8-u'
S'cyr-sun16'
tsS'Norwegian, Nynorsk (Norway)'
p84
(S'nn_NO'
S'iso01'
S'lat0-sun16'
tsS'English (Zimbabwe)'
p85
(S'en_ZW'
S'iso01'
S'lat0-sun16'
tsS'English (USA)'
p86
(S'en_US'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Nicaragua)'
p87
(S'es_NI'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Kuwait)'
p88
(S'ar_KW'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Colombia)'
p89
(S'es_CO'
S'iso01'
S'lat0-sun16'
tsS'Basque (Spain)'
p90
(S'eu_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Qatar)'
p91
(S'ar_QA'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Egypt)'
p92
(S'ar_EG'
S'iso06'
S'LatArCyrHeb-16'
tsS'English (Ireland)'
p93
(S'en_IE@euro'
S'iso15'
S'lat0-sun16'
tsS'Hungarian'
p94
(S'hu_HU'
S'iso02'
S'lat2-sun16'
tsS'Arabic (Tunisia)'
p95
(S'ar_TN'
S'iso06'
S'LatArCyrHeb-16'
tsS'French (Luxemburg)'
p96
(S'fr_LU@euro'
S'iso15'
S'lat0-sun16'
tsS'Japanese'
p97
(S'ja_JP.eucJP'
S'iso01'
S'lat0-16'
tsS'Swedish (Finland)'
p98
(S'sv_FI@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Saudi Arabia)'
p99
(S'ar_SA'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Dominican Republic)'
p100
(S'es_DO'
S'iso01'
S'lat0-sun16'
tsS'French (Canada)'
p101
(S'fr_CA'
S'iso01'
S'lat0-sun16'
tsS'English (Canada)'
p102
(S'en_CA'
S'iso01'
S'lat0-sun16'
tsS'German (Germany)'
p103
(S'de_DE@euro'
S'iso15'
S'lat0-sun16'
tsS'Slovenian (Slovenia)'
p104
(S'sl_SI'
S'iso02'
S'lat2-sun16'
tsS'Spanish (Uruguay)'
p105
(S'es_UY'
S'iso01'
S'lat0-sun16'
tsS'German (Switzerland)'
p106
(S'de_CH'
S'iso01'
S'lat0-sun16'
tsS'English (Australia)'
p107
(S'en_AU'
S'iso01'
S'lat0-sun16'
tsS'Catalan (Spain)'
p108
(S'ca_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Puerto Rico)'
p109
(S'es_PR'
S'iso01'
S'lat0-sun16'
tsS'Turkish'
p110
(S'tr_TR'
S'iso09'
S'lat5-sun16'
tsS'Estonian'
p111
(S'et_EE'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Sudan)'
p112
(S'ar_SD'
S'iso06'
S'LatArCyrHeb-16'
tsS'Icelandic'
p113
(S'is_IS'
S'iso01'
S'lat0-sun16'
tsS'English (Botswana)'
p114
(S'en_BW'
S'iso01'
S'lat0-sun16'
tsS'Manx Gaelic (Britain)'
p115
(S'gv_GB'
S'iso01'
S'lat0-sun16'
tssS'allSupportedLangs'
p116
(lp117
g42
ag75
ag46
ag28
ag92
ag24
ag72
ag88
ag20
ag22
ag44
ag23
ag91
ag99
ag112
ag69
ag95
ag56
ag17
ag90
ag108
ag55
ag29
ag70
ag49
ag79
ag39
ag107
ag114
ag102
ag50
ag82
ag93
ag53
ag26
ag86
ag85
ag111
ag51
ag76
ag47
ag101
ag30
ag96
ag27
ag52
ag57
ag74
ag103
ag61
ag106
ag35
ag31
ag60
ag94
ag113
ag48
ag71
ag19
ag73
ag97
ag32
ag67
ag115
ag43
ag84
ag65
ag63
ag45
ag58
ag83
ag41
ag40
ag66
ag104
ag18
ag54
ag25
ag89
ag38
ag100
ag36
ag64
ag21
ag37
ag34
ag87
ag80
ag59
ag78
ag109
ag68
ag62
ag105
ag81
ag98
ag77
ag110
ag33
asS'info'
p118
(dp119
S'SUPPORTED'
p120
NssS'supported'
p121
(lsS'default'
p122
NsbsS'instClass'
p123
(iinstallclass
DefaultInstall
p124
(dp125
S'rootPasswordCrypted'
p126
I0
sS'raidList'
p127
(lsS'nameserver'
p128
S''
sS'x'
NsS'rootPassword'
p129
NsS'makeBootdisk'
p130
I0
sS'installType'
p131
NsS'postScript'
p132
NsS'earlySwapOn'
p133
I0
sS'networkDevice'
p134
NsS'fstab'
p135
(lsS'clearText'
p136
NsS'lilo'
p137
(S'mbr'
p138
I1
S''
tsg13
NsS'name'
p139
S''
sS'postInChroot'
p140
I0
sS'pixmap'
p141
S''
sS'partitions'
p142
(lsS'clearType'
p143
NsS'gateway'
p144
S''
sS'mouse'
p145
NsS'packages'
p146
NsS'timezone'
p147
NsS'zeroMbr'
p148
I0
sS'keyboard'
p149
NsS'groups'
p150
NsS'bootProto'
p151
NsS'netmask'
p152
S''
sS'langdefault'
p153
NsS'skipSteps'
p154
(dp155
S'indivpackage'
p156
I1
ssS'auth'
p157
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsS'hostname'
p158
NsS'langsupported'
p159
NsS'showgroups'
p160
NsS'ip'
p161
S''
sS'firewall'
p162
(I-1
I1
(lp163
S''
I0
I0
I0
I0
I0
I0
tsS'defaultRunlevel'
p164
NsS'desktop'
p165
S''
sS'clearPartText'
p166
NsS'clearParts'
p167
I0
sbsS'bdstate'
p168
S''
sS'extraModules'
p169
(lp170
sS'rootpassword'
p171
NsS'fdDevice'
p172
S'fd0'
p173
sS'installSystem'
p174
I1
sS'comps'
p175
NsS'verifiedState'
p176
Nsg157
(itodo
Authentication
(dp177
S'useNIS'
p178
I0
sS'nisServer'
p179
S''
sS'useLdap'
p180
I0
sS'krb5Kdc'
p181
S''
sS'ldapTLS'
p182
S''
sS'useHesiod'
p183
I0
sS'ldapServer'
p184
S''
sS'nisDomain'
p185
S''
sS'krb5Realm'
p186
S''
sS'useLdapauth'
p187
I0
sS'hesiodRhs'
p188
S''
sS'useShadow'
p189
I1
sS'nisuseBroadcast'
p190
I0
sS'useKrb5'
p191
I0
sS'useMD5'
p192
I1
sS'ldapBasedn'
p193
S''
sS'krb5Admin'
p194
S''
sS'hesiodLhs'
p195
S''
sS'hesiodDlhs'
p196
S''
sbsS'users'
p197
NsS'hdList'
p198
NsS'dhcpState'
p199
S''
sS'method'
p200
(iimage
CdromInstallMethod
p201
(dp202
g4

<failed>
Comment 1 Brent Fox 2001-04-21 12:45:18 EDT
We will look into this.
Comment 2 daryl herzmann 2001-05-29 16:47:33 EDT
Any luck with this bug?  I would really like to install RH 7.1 on my machines. 
Do you need more information?  The SGI XFS 1.0 installer fails the same way. 
The RH 7.0 installer fails the same way.  Both RH 7.1 beta installers fail the
same way.
Comment 3 Matt Wilson 2001-07-01 13:02:39 EDT
I'm still trying to figure out how this particular failure can happen.
Comment 4 daryl herzmann 2001-07-02 09:52:12 EDT
Hi Again,
This morning I tried an install with XFS 1.0.1 PR3, but the same error occurs. 
Here is what vt4 reports, when trying to do an upgrade from 6.2

autorun ...
considering hdb1 ...
   adding hdb1 ...
   adding hda5 ...
created md0
bind <hda5,1>
bind <hdb1,2>
running <hdb1><hda5>
hdb1's event counter: 00000025
hda5's event counter: 00000025
RAID level -1 does not need chunksize! Continuing anyway.
md.c: presonality 1 is not loaded
do_md_run() returned -22
md0 stopped.
unbind <hdb1,1>
export_rdev(hdb1)
unbind <hda5,0>
export_rdev(hda5)
... autorun DONE.
Comment 5 Matt Wilson 2001-07-10 16:01:32 EDT
can you try making an initrd with --with=raid1 ?
Comment 6 daryl herzmann 2001-07-10 16:10:03 EDT
I am sorry.  I am not sure if I follow what you want me to do.  Please
elaborate if you think it is worth the time.  

I got around this upgrade problem, by a hack.
1.  umounted raid device
2.  fdisk the partitions of the raid device to type Linux ext2
3.  Move raidtab file
4. Upgrade to Rh 7.1
5. fdisk partitions back to fd
6. move raidtab back.
7. Works!

I have one machine with RedHat 7.1 beta1 on it, with which I could try your
suggestion. If you
are interested in telling me how.

Thanks.
Comment 7 Matt Wilson 2001-07-13 02:28:46 EDT
OK, I'm going to try to make the raid starting code more rhobust, you don't need
to do anything further.
Comment 8 Matt Wilson 2001-07-20 16:24:21 EDT
*** Bug 40043 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2001-07-27 16:35:29 EDT
What is the status of your fix msw?
Comment 10 Matt Wilson 2001-08-09 23:16:39 EDT
the next release will handle this gracefully.
Comment 11 daryl herzmann 2001-12-14 13:48:42 EST
Hi!
	Sorry to report, but I just tried upgrading to 7.2 and I still get the same
errors that I reported before.  Any ideas??  Unfortunately, my floppy dump of
the error did not work, but I will try again in a couple of hours to get the
error and attach it here.

Daryl
Comment 12 daryl herzmann 2001-12-14 14:02:41 EST
Created attachment 40669 [details]
Dump from installer (sorry about multiple post)
Comment 13 Jeremy Katz 2002-04-08 18:48:28 EDT
msw committed a fix for this to CVS
Comment 14 Brent Fox 2002-04-09 11:21:40 EDT
Can we close this as Rawhide then?

Note You need to log in before you can comment on or make changes to this bug.