Bug 40043 - Installer fails to handle raid partition & thus stops
Summary: Installer fails to handle raid partition & thus stops
Status: CLOSED DUPLICATE of bug 36985
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-10 09:45 UTC by Nick Hoath
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 15:00:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fdisk -l /dev/hda (338 bytes, text/plain)
2001-05-11 07:36 UTC, Nick Hoath
no flags Details
fdisk -l /dev/hdg (342 bytes, text/plain)
2001-05-11 07:37 UTC, Nick Hoath
no flags Details
Dump of actual error message during upgrade failure. (10.29 KB, text/plain)
2001-05-29 07:22 UTC, Nick Hoath
no flags Details
Dump from installer (23.90 KB, text/plain)
2001-12-14 18:59 UTC, daryl herzmann
no flags Details

Description Nick Hoath 2001-05-10 09:45:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20010131
Netscape6/6.01

Description of problem:
During an upgrade from RedHat 6.1 -> 7.1, anaconda reports an error
(paraphrased) while trying to setup to read the old installation status:
Raid device md0 needs 1 disks, but found 2.
The raid device was created automagically by the original 6.1 installation.
My fstab and raidtab are as follows:
fstab:
/dev/md0                /                       ext2    defaults        1 1
/dev/hda1               /boot                   ext2    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/hdg1               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             ext2    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0

raidtab:
raiddev             /dev/md0
raid-level                  0
nr-raid-disks               2
chunk-size                  64k
persistent-superblock       1
device      /dev/hda5
raid-disk     0
device      /dev/hdc5
raid-disk     1


How reproducible:
Always

Steps to Reproduce:
1. Boot off RedHat 7.1 installation CD 1
2. Proceed with upgrade procedure

	

Actual Results:  anaconda reported an error and gave the option of
debugging or giving up.

Expected Results:  anaconda should have mounted the raid array & proceed to
scan the previous installation!

Additional info:

Comment 1 Brent Fox 2001-05-10 20:43:30 UTC
Can you boot into your 7.0 system and post the output of the 'fdisk -l /dev/hda'
and 'fdisk -l /dev/hdc' commands?

Comment 2 Nick Hoath 2001-05-11 07:36:27 UTC
Created attachment 18107 [details]
fdisk -l /dev/hda

Comment 3 Nick Hoath 2001-05-11 07:37:53 UTC
Created attachment 18108 [details]
fdisk -l /dev/hdg

Comment 4 Nick Hoath 2001-05-11 07:38:49 UTC
I guess my raidtab is wrong... But would this stop the installation?

Comment 5 Brent Fox 2001-05-14 22:04:48 UTC
Almost certainly.  I can't imagine how the system worked in the first place. 
Please try again with a corrected raidtab and reopen this bug if this doesn't
fix the problem.

Comment 6 Nick Hoath 2001-05-29 07:22:58 UTC
Created attachment 19851 [details]
Dump of actual error message during upgrade failure.

Comment 7 Matt Wilson 2001-07-20 20:24:27 UTC

*** This bug has been marked as a duplicate of 36985 ***

Comment 8 daryl herzmann 2001-12-14 18:59:19 UTC
Created attachment 40668 [details]
Dump from installer


Note You need to log in before you can comment on or make changes to this bug.