Bug 37025 - DPMS not enabled in /etc/X11/XF86Config-4
DPMS not enabled in /etc/X11/XF86Config-4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On: 17829
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 16:52 EDT by Dax Kelson
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-09 23:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the installer generated file (3.61 KB, text/plain)
2001-04-22 20:20 EDT, Need Real Name
no flags Details
This is the Xconfigurator generated file. (1.80 KB, text/plain)
2001-04-22 20:22 EDT, Need Real Name
no flags Details

  None (edit)
Description Dax Kelson 2001-04-21 16:52:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686; Nav)


After installing RedHat 7.1 on my box with a Matrox G400, I had to manually
go in and add

Option  "DPMS"

To the monitor section.

Reproducible: Always
Steps to Reproduce:
1. Install Red Hat 7.1
2. View /etc/X11/XF86Config-4
Comment 1 Brent Fox 2001-04-21 17:26:29 EDT
Does this happen if you use the text mode installer?
Comment 2 Dax Kelson 2001-04-21 18:03:52 EDT
No, I haven't tried text mode.  BTW, the G400 I have is a G400MAX.
Comment 3 Brent Fox 2001-04-21 19:57:41 EDT
Does the graphical installer even work?  If so, does X start after installation?
Comment 4 Dax Kelson 2001-04-21 20:12:58 EDT
Yes, installing graphical works fine.  Aftewards though, power management for 
my monitor doesn't work.  My monitor always stays on.

I have to add:

Option  "DPMS"

To the monitor section in /etc/X11/XF86Config-4

In Red Hat 6.2, the installer properly added the "DPMS" option.  Red Hat 7.0 
and 7.1 don't.
Comment 5 Need Real Name 2001-04-22 20:14:13 EDT
I've experienced the same problem with RedHat 7.1. I did not experience the
problem with RedHat 7.0
On two machines, one an upgrade, the other a fresh install, the monitor always
remains on. Both machines were installed or upgraded in graphical mode, and use
KDE for the desktop. In the KDE control panel, the DPMS function is enabled.
The output from the xset -q command is:
DPMS (Energy Star):
Standby: 600    Suspend: 1200    Off: 1800
DPMS is Enabled
Monitor is On
I ran /usr/X11R6/bin/Xconfigurator to see if the file generated was different
than the one created by anaconda during the install. I'll attach the two
different versions of the file. One of several differences is the missing
'option "DPMS" ' in the anaconda version of the file.
Using the Xconfigurator generated file appears to have solved the problem.
The xset -q output remains the same, but the monitor now powers down.
Comment 6 Need Real Name 2001-04-22 20:20:05 EDT
Created attachment 16065 [details]
This is the installer generated file
Comment 7 Need Real Name 2001-04-22 20:22:29 EDT
Created attachment 16066 [details]
This is the Xconfigurator generated file.
Comment 8 Dax Kelson 2001-04-22 22:18:42 EDT
The fact that the files are different is annoying.  I reported that bug on RH 
7.0 in Sept 2000.

I've added the dependency on bug 17829
Comment 9 Need Real Name 2001-04-22 22:45:52 EDT
Probably completely unrelated, but the output from the X server at start up
displays the incorrect kernel version. X says:

XFree86 Version 4.0.3 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 16 March 2001

Operating System: Linux 2.2.17-8smp i686 [ELF]

uname -r (correctly) says:  2.4.2-2
Comment 10 Mike A. Harris 2001-04-23 01:17:07 EDT
The "Operating System" is *not* your kernel, but rather the kernel of
the computer on which it was compiled.
Comment 11 Brent Fox 2001-04-26 15:39:45 EDT
Related to msf's work on X.
Comment 12 josip 2001-05-01 23:44:59 EDT
I see the same problem.  Editing /etc/X11/XF86Config-4 manually to add DPMS
related entries did not help.  Interestingly enough, run level 5 broke when
XF86Config-4 was present but XF86Config was removed.  It appears that RH7.1
needs /etc/X11/XF86Config (without the '-4') to run: adding the DPMS entries to
XF86Config made the monitor turn off when nobody was logged in.   Unfortunately,
this does not fix the problem when somebody IS logged in.  There is still a
problem related to the xscreensaver.
Comment 13 Bryce Nesbitt 2001-06-25 14:15:48 EDT
There are two bugs here -- the XF86Config generation and the operation of
the screensaver as configured in Gnome.  Both are broken.   I see the same
problems.
Very annoying on a laptop.
Comment 14 Brent Fox 2001-07-09 23:55:30 EDT
Anaconda wasn't writing "Option 'dpms'" to XF86Config-4, but Xconfigurator was.
I just committed a patch to anaconda that adds that line to the file. Thanks for
your report.

Note You need to log in before you can comment on or make changes to this bug.