Bug 37027 - DPMS will not enable.
DPMS will not enable.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 18:22 EDT by Kirk Morrow
Modified: 2007-04-18 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-09 23:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk Morrow 2001-04-21 18:22:24 EDT
DPMS will not work on RedHat 7.1.  I have 2 different machines, 1 a fresh
install and the other an upgrade from 7.0.  Same symptoms, both machines.

Option "DPMS" is in the Monitor section of the file /etc/X11/XF86Config-4
file.  However, when at the login screen for Gnome the monitor never shuts
down.  If I login and do an "xset q" I get:

...
DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Disabled
...

Of course I could have xset turn on DPMS each time a user logs in, but
that's not all that useful to me.  I need DPMS to blank when at the login
screen.
Comment 1 edwinh 2001-04-21 20:46:15 EDT
See the same thing.

I believe this is due to xscreensaver.  Even when you don't check the box for
"power management",
xscreeensaver resets X's DPMS settings.  and it never does seem to kick in when
enabled anyway..

If I don't fire up xscreensaver at all DPMS works as expected.
Comment 2 Need Real Name 2001-04-22 20:35:39 EDT
I had the same problem on two different machines. I generated a new
/etc/X11/XF86Config-4 file using Xconfigurator, and the problem appears to have
been solved. The monitor now powers down properly both with and without the
screensaver. I use KDE rather than gnome, which may have an effect on the
solution. See bug #37025 for details.
Comment 3 Kirk Morrow 2001-04-23 00:31:11 EDT
As edwinh@computer.org stated, turning off xscreensaver does enable DPMS when
logged in.  However, this has no effect when no one is logged in.  Also, as
site policy, the screen must automatically lock and required a password when
idle for too long if someone is logged in, so this option doesn't work for me.  

I guess this bug should be copied to the owner of the xscreensaver package?

As devon1@charter.net mentions running XConfigurator from a text screen does fix
the login screen DPMS issue.  Although this doesn't explain why it doesn't work
in the first place, especially when Option "DPMS" was in the original
XF86Config-4 file.  It's interesting to note that the XF86Config files that
where generated during the anaconda install are significantly different then
those generated by the manual run.  The manually run (newer) config file have
more accurate information about my hardware.

Also, a bug that should probably be copied to the owner of Xconfigurator. 
During the manual run from a text screen, the test always failed.  It never even
tries to test the selected resolution, it just reports "a problem occured". 
Yet, if I skip the test and start X, it works just fine.

Some clippings from my config files:

XF86Config:

1d0
< # File generated by XConfigurator.
2a2
> # File generated by anaconda.
...
< # Device configured by Xconfigurator:
347,351c411,412
<     Identifier  "Matrox|Marvel G450 eTV"
<     VendorName  "Unknown"
<     BoardName   "Unknown"
<     #VideoRam    32768
<     # Insert Clocks lines here if appropriate
---
>     Identifier         "Matrox Millennium G450"
>     VideoRam           32768
...

XF86Config-4

1c1,2
< # XFree86 4.0 configuration generated by Xconfigurator
---
> 
> # File generated by anaconda.
...
57,60d112
< Section "Device"
< 	Identifier "Matrox|Marvel G450 eTV"
< 	Driver "mga"
< 	BoardName "Unknown"
64,66c116,122
< 	Identifier "Linux Frame Buffer"
< 	Driver "fbdev"
< 	BoardName "Unknown"
---
> 	# no known options
> 	Identifier   "Matrox Millennium G450"
>         Driver       "mga"
>         VendorName   "Matrox Millennium G450"
>         BoardName     "Matrox Millennium G450"
>         
>         #BusID
70,73c126,130
< 	Identifier "Screen0"
< 	Device "Matrox|Marvel G450 eTV"
< 	Monitor "MAG DJ717"
< 	DefaultDepth 16
---
> 	Identifier   "Screen0"
>         Device       "Matrox Millennium G450"
>         Monitor      "Monitor0"
> 	DefaultDepth	16
...
Comment 4 Mike A. Harris 2001-04-24 03:11:29 EDT
DPMS works for me fine in both GNOME and KDE, and with KDM/GDM.  I'm not
using it from a default install however.  IMHO, anaconda might be setting
DPMS to off by default?  I dunno, but I don't see any bug with DPMS in
XFree86.  I'll let the installer team decide what to do with this one.
Comment 5 Need Real Name 2001-04-24 07:48:45 EDT
I'd agree that it seems to be installer related, at least in my case. The
installer did not add option "DPMS" to my config file. In bug #37025 (perhaps
this bug should be marked a duplicate of bug #37025?) I've attached copies of
both the installer and Xconfigurator generated files.
Comment 6 edwinh 2001-04-24 09:35:25 EDT
I really don't think it's the installer.   I've used my own XF86Config-4, and
it's had  Option "DPMS"
the whole time.  It's either something in XFree or something in xscreensaver.

Try this:
  - make sure DPMS is enabled in the XF86Config
  - turn off xscreensaver (tell control-center "no screensaver")
  - restart X
  - "xset q", examine the DPMS settings.  if you wait long enough ti will kick
in
  - xscreensaver &
  - "xset q", examine the DPMS settings.  They are all set to 10.  Wait
forever.  Monitor will not turn   off.

I've seen this on multiple machines with different X configs.  I'm going to go
scrub the settings again
and compare with Xconfigurator's output, but I know for sure I've had it turned
on in all cases. 


Comment 7 Kirk Morrow 2001-04-24 12:54:50 EDT
My origingal situation was NOT a duplicate of bug #37025, because Anaconda DID
add "DPMS" to XF86Config-4 but DPMS still did not work.  It did not work at all
until I run XConfigurator manually after the install.  I do however agree that
it is likely  to be an anaconda issue.

As for Gnome/KDE, this is an issue with xscreensaver.  Now that I've gotten DPMS
to work with after the XConfigurator runs, DPMS gets disabled when I enable
xscreensaver whether I've selected "Power Management" or not.

IMHO this should be split into 2 bugs, one for the anaconda folks and one for
the xscreensaver folks.
Comment 8 Bill Nottingham 2001-05-02 16:38:30 EDT
xscreensaver/control-center interaction problem should be fixed as of
xsreensaver-3.32-1, control-center-1.4.0.1-2.
Comment 9 rotten 2001-05-04 19:29:22 EDT
I'm now running xscreensaver-3.32-1, and control-center-1.4.0.1-2. Bug still
exists, though manifestation has changed slightly. Instead of changing dpms
settings to 10/10/10, it now does the following (no matter what is entered into
the "screensaver" section of gnome control-center):

DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled

This bug is is more than a cosmetic problem, since it results in many users
being required to physically turn off/on their monitors multiple times each day.
In addition to being an inconvenience, the repeated degaussing causes increased
wear on the monitor.
Comment 10 josip 2001-05-08 08:27:06 EDT
This bug is very annoying and needs to be fixed very soon.  On my system, the
following worked:

(1) Manually add DPMS entries to /etc/X11/XF86Config (without the "-4" at the
end).  This fixes DPMS when nobody is logged on.  Unfortunately, xscreensaver
disables DPMS when somebody IS logged on.

(2) For each user, run xscreensaver-demo and change "Screensaver Options".  This
generates the ~/.xscreensaver file, where DPMS parameters for the xscreensaver
are set.

BTW, this applies to xscreensaver-3.29-3 and XFree86-4.0.3-5, which are the
current versions.  Other related bugs are #37025 and #37721.
Comment 11 rotten 2001-05-08 10:25:43 EDT
Ok, as josip(at)icase.edu points out, this is a new "feature" of xscreensaver:

Changes since 3.30:   * Put in more sensible defaults for DPMS, and updated
                        the documentation to reflect the fact that all your
                        DPMS settings are now belong to xscreensaver.

Apparently, gnome control-center doesn't know about this. Fixing it should
simply being a matter of making gnome control-center add the line:
dpmsEnabled:	True
to the user's ~/.xscreensaver when he/she turns on power management.
Comment 12 Stephen Rasku 2001-06-12 01:20:49 EDT
I am seeing this as well.  I am running KDE and have the screensaver disabled. 
For good measure, I created a .xscreensaver file:

	dpmsEnabled:    True

and re-started X.  However, "xset q" still reports "DPMS is Disabled".
Comment 13 Brent Fox 2001-07-09 23:55:21 EDT
Anaconda wasn't writing "Option 'dpms'" to XF86Config-4, but Xconfigurator was.
 I just committed a patch to anaconda that adds that line to the file.  Thanks
for your report.

Note You need to log in before you can comment on or make changes to this bug.