Bug 370711 - xcb_xlib.c:50: xcb_xlib_unlock: Assertion 'c->xlib.lock' failed.
xcb_xlib.c:50: xcb_xlib_unlock: Assertion 'c->xlib.lock' failed.
Status: CLOSED DUPLICATE of bug 301691
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
i386 Linux
high Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
http://bugs.sun.com/bugdatabase/view_...
:
: 374701 377471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 21:41 EST by Mario Torre
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 13:17:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Torre 2007-11-07 21:41:08 EST
Description of problem:

Please note: The bug does *not* apply to IcedTea, Bugzilla complain to use a
component, and this is the most obvious. It's here for reference.

Every java application that uses swing or awt does not work with Sun Java 1.6.0.03.

See http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373 for details and
http://www.netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=98765 for a possible
workaround. The bug is marked as fixed on the Sun Database. IcedTea is not
affected by this bug.

Version-Release number of selected component (if applicable):

Sun JDK 1.6.0.03

How reproducible:

Always.

Steps to Reproduce:
1. Install Sun JDK 1.6.0.03
2. go to [jdk_home]/demo/jfc/Metalworks
3. java -jar Metalworks.jar
  
Actual results:

Java exists printing this message on the console:

xcb_xlib.c:50: xcb_xlib_unlock: Assertion 'c->xlib.lock' failed.

Expected results:

Normal execution of the application.

Additional info:

The proposed "sed" workaround works for me:

sed -i 's/XINERAMA/FAKEEXTN/g' \
/usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

I've not tested yet for possible problems deriving from that, though.
Comment 1 Eli Wapniarski 2007-11-13 00:09:15 EST
The problem exists when running arkeiasb on Fedora 8 as well. I get...

java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Comment 2 Eli Wapniarski 2007-11-13 00:10:17 EST
Oh... I forgot to mention that I'm using x96_64.
Comment 3 Eli Wapniarski 2007-11-13 00:10:47 EST
sorry x86_64.
Comment 4 Eli Wapniarski 2007-11-13 00:13:10 EST
Oh. One other thing to note, there is a big discussion about it at

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373
Comment 5 Andres Escallon 2007-11-13 10:19:58 EST
I have experienced the problem trying to run Netbeans, Xdevelop IDE and other
java applications with different versions of JDKs 1.5 and 1.6.
Comment 6 Laurence Vanek 2007-11-13 22:50:13 EST
this bug has also prevented a reinstall of x-plane flight simulator (retail
software).  I am guessing its the java on the install DVD.

how do we take care of those cases?  IcedTea or Sun w/"sed fix" produces no help
here.
Comment 7 Bill C. Riemers 2007-11-15 11:09:20 EST
According to the discussions I have found this happens with any version of Java
after updating Xinerima, when launching any program using awt.   The following
workaround does work:

updatedb; for i in $(locate libmawt.so);do sed -i "s/XINERAMA/FAKEEXTN/g" "$i";done

Obviously, all that can be done for the closed source versions of Java is the
workaround, but it would be nice to get an actual fix put in IcedTea.
Comment 8 Bill C. Riemers 2007-11-15 11:13:16 EST
BTW.  The original poster was wrong, IcedTea is affected by this bug!  I can
confirm this problem exists in java-1.7.0-icedtea-1.7.0.0-0.19.b21.  After
upgrading from Fedora 7 to Fedora 8, I was unable to run netbeans until applying
the workaround.




Comment 9 Bill C. Riemers 2007-11-15 11:19:41 EST
*** Bug 377471 has been marked as a duplicate of this bug. ***
Comment 10 Bill C. Riemers 2007-11-15 11:25:08 EST
*** Bug 374701 has been marked as a duplicate of this bug. ***
Comment 11 Mario Torre 2007-11-15 11:33:25 EST
Hi Bill, it works for me on icedtea b21 and netbeans 6.0 beta 1, not sure why
(I've *not* applied the sed fix there):

[neugens@nirvana ~]$ rpm -qa|grep icedtea
java-1.7.0-icedtea-devel-1.7.0.0-0.19.b21.snapshot.fc8
java-1.7.0-icedtea-javadoc-1.7.0.0-0.19.b21.snapshot.fc8
java-1.7.0-icedtea-demo-1.7.0.0-0.19.b21.snapshot.fc8
java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8
java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8

The last mg version of IcedTea also works.

As I understand, this is a bug due to statically linking to an old library. In
IcedTead this should be fixed.

As a reply to comment #6, I have a couple of ideas that you may try:

A. copy the content of the DVD on your local drive, so that you can have write
access, run the sed command, redo a DVD image and try to install the software.
B. Install the software with an old version of Fedora, you may try a live CD so
that once installed the application sits on the hard drive.
C. downgrade Xinerama, install the software, then upgrade again

Of of these tricks could work, or blow up your installation, so use with care.
Comment 12 Thomas Fitzsimmons 2007-11-15 13:17:46 EST
(In reply to comment #8)
> BTW.  The original poster was wrong, IcedTea is affected by this bug!  I can
> confirm this problem exists in java-1.7.0-icedtea-1.7.0.0-0.19.b21.  After
> upgrading from Fedora 7 to Fedora 8, I was unable to run netbeans until applying
> the workaround.

I can't reproduce this on java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8 using
the steps in the original report.  strace shows java dlopen'ing the
system-installed libXinerama:

[pid 14631] open("/usr/lib/libXinerama.so.1", O_RDONLY) = 7

(provided by libXinerama-1.0.2-3.fc8) which is how we fixed this problem in IcedTea.

What version of NetBeans were you using?  NetBeans 6.0 Beta 1 should work,
previous versions are known not to work.  (If you tried an earlier version,
please file a separate bug for "NetBeans X does not work on java-1.7.0-icedtea",
and include all reproducer details.)

Adam Jackson has provided a workaround in bug 301691, comment 19:

> Install the appropriate rpm from:
>
> http://ajax.fedorapeople.org/libxcb/
>
> And run the app with LIBXCB_ALLOW_SLOPPY_LOCK=1 in the environment.


*** This bug has been marked as a duplicate of 301691 ***

Note You need to log in before you can comment on or make changes to this bug.