Bug 37072 - Very bad: (SCSI) Magneto Optical disks can be ejected when mounted!!
Very bad: (SCSI) Magneto Optical disks can be ejected when mounted!!
Status: CLOSED DUPLICATE of bug 38871
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-04-22 12:32 EDT by Alfredo Ferrari
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-24 17:00:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alfredo Ferrari 2001-04-22 12:32:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-3smp i686)

With RH7.1 SeaWolf I can eject a MagnetoOptical disk (the drive is a
Fujitsu DynaMO640) even though it is mounted and i.e. I cd to it.
If I press the eject button the disk comes out with all possible
consequences (I trashed already two disks).
It did not occur on all previous versions of RH neither in
Wolverine as far as I know (I installed it only partially). I do not know
whether the problem is in mount or somewhere else, however it seems that
mounting does no longer tell the hardware to inhibit the eject. I met the
problem on a Latitude C800 with a APA1480A
SCSI card and the disk formatted as superfloppy (all drive
formatted as one single file system, "mke2fs /dev/sdb")

The same hardware combination (and the same disk) worked nicely with RH7.0,
a similar machine (Latitude Cpx500) with the same SCSI card and MO drive
worked nicely with RH6.1,6.2 and 7.0

Reproducible: Always
Steps to Reproduce:
1.format the MO disk ("mke2fs -b 2048/dev/sdb")
2.mount it ("mount -t ext2 /dev/sdb /diskmo") write some data, cd to it
3.press the eject button

Actual Results:  the disk is ejected (and the system sees it still mounted,
of course after a while the system heavily complains)

Expected Results:  the disk should not be ejected
Comment 1 Alfredo Ferrari 2001-04-24 15:45:44 EDT
Hi, I am surprised to see no reaction to such a serious bug (trashing disks is
not the best advertising for Linux). I can confirm that the bug is there with
both the new and the old pcmcia drivers. If it is a bug of the SCSI driver
(aic7xxx) it will affect a large amount of cards due to the diffusion of Adaptec
hardware, if it is a bug of mount it should affect all cards...

I had another bug for mount (less serious but still disturbing) which was
submitted february 26th (29542, it affects both RH7.0 and RH7.1). No reaction on
that side too, it is still NEW not even ASSIGNed, is the maintainer of mount in
indefinite vacation? When I posted the bug to the RedHat lists RH guys answered
in the usual way "put it into bugzilla" however they did not add it was a way to
forget it forever...

Comment 2 Bernhard Rosenkraenzer 2001-04-24 15:49:08 EDT
Reported against the wrong component, the kernel handles device locking.
Reassigning. This may well be a bug in your device's firmware, though.
Comment 3 Arjan van de Ven 2001-04-24 15:53:16 EDT
Is magicdev running ?
Comment 4 Alfredo Ferrari 2001-04-24 16:40:28 EDT
Hi, sorry for bothering you again.... after the APA1480 stuff. I'll tell you in
half a hour (I have to go back home to check) if magicdev is running or not. I
would  exclude the device firmware since it is the same exact device which
worked nicely (=> blocking the ejection) under RH6.0,6.1,6.2 and 7.0 (the last
till one week ago until I upgraded to 7.1).
Two other identical devices (same model same firmware revision) are regularly
blocking the ejection on two 6.2 systems as well.
Comment 5 Alfredo Ferrari 2001-04-24 17:00:17 EDT
No magicdev is not running. Let me know whether you nedd further infos.
Comment 6 Alan Cox 2001-05-28 13:59:33 EDT

*** This bug has been marked as a duplicate of 38871 ***

Note You need to log in before you can comment on or make changes to this bug.