This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 370861 - AttributeError 'split' -- yum info <package> -- german
AttributeError 'split' -- yum info <package> -- german
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 02:39 EST by shrek-m
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 09:14:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2007-11-08 02:39:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.8) Gecko/20071019 Fedora/2.0.0.8-1.fc7 Firefox/2.0.0.8

Description of problem:
`LANG=C yum info <package`  is ok

`yum info <package>`
no summary, no description
==> AttributeError: 'list' object has no attribute 'split'


Version-Release number of selected component (if applicable):
yum-3.2.7-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. yum info <package>

Actual Results:
# yum info kernel  (or other packages)
Installed Packages
Name   : kernel
Arch   : x86_64
Version: 2.6.23.1
Release: 10.fc7
Size   : 60 M
Repo   : installed
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 105, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 282, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 168, in doCommand
    rip = base.listPkgs(ypl.installed, 'Installed Packages', basecmd)
  File "/usr/share/yum-cli/output.py", line 129, in listPkgs
    self.infoOutput(pkg)
  File "/usr/share/yum-cli/output.py", line 99, in infoOutput
    print _("Summary: %s") % enc(pkg.summary)
  File "/usr/share/yum-cli/output.py", line 86, in enc
    t = gettext.dgettext(d, s)
  File "/usr/lib64/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib64/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib64/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'


Expected Results:


Additional info:
# cat /etc/sysconfig/i18n
LANG="de_DE.UTF-8"
SYSFONT="latarcyrheb-sun16"

was an dist-upgrade via yum fc6->f7
Comment 1 Till Maas 2007-11-08 16:58:30 EST
same problem here on i386
Comment 2 Jeremy Katz 2007-11-09 09:14:58 EST

*** This bug has been marked as a duplicate of 252136 ***

Note You need to log in before you can comment on or make changes to this bug.