Bug 37098 - pppd gets spawned multiple times with persistent/demand connections
pppd gets spawned multiple times with persistent/demand connections
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-22 18:15 EDT by Trever Adams
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:25:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2001-04-22 18:15:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3 i686; en-US; rv:0.8.1+)
Gecko/20010421


I have one box that acts as the gateway for my house network.  We only have
a dial up line.  I have been using pppd with 2.3.x and 2.4.x kernels for
some time with this setup.  I upgraded to 7.1 a day or so ago.   Now, the
demand and persistent connections make pppd or ppp-watch spawn multiple
pppd's.  For example:  Connection is terminated.  I should only have one
pppd running with an entry of ppp0 in ifconfig for it.  Now, with RedHat
7.1  I get two pppd's and ppp0,ppp1 in ifconfig.  This was an upgrade
install and not a clean install.  I believe though that all 7.1 things were
installed that had previous parts.   No dependency problems.

Reproducible: Always
Steps to Reproduce:
1.  Create a pppd connection
2.  Make it demand in options and make it persistant
3.  Get it to connect
4.  Drop connection
5.  ps xa, ifconfig
	

Actual Results:  I get too many ppp interfaces and pppd's running.

Expected Results:  One pppd running.  One interface.
Comment 1 Trever Adams 2001-04-24 01:40:22 EDT
I have found additional things.  I still do not know if ppp-watch or pppd is at
fault.  The above directions do not cause the problem.  It seems pppd is
unkillable, however, ppp-watch seems to see the signal to die and spawns a new
pppd.  Hence the multiple pppd's.

I had reasons for having if-down.local in /etc/ppp kill the pppd (I cannot
remember this late at night what they were, it seems it had to do with some
other program working right).  It is a bug for pppd to ignore the QUIT (I
believe that is the default for kill) signal.  It is also a bug for pppd to see
that signal and assume pppd is dead and restart it without verifying that pppd
went away.

Two bugs: pppd doesn't respond to the signal mentioned above, and ppp-watch
restarts pppd when it shouldn't.
Comment 2 Alex Kanavin 2001-05-09 10:02:08 EDT
I suspect this is a duplicate of bug #39231. 
There's a patch there, please tell if it fixes your problem.
Comment 3 Bruce Garlock 2001-05-22 11:44:15 EDT
I had a similar issue with ppp-watch.  It did not redial when the connection was broken, like it did in RH 6.2.  Until a new release of initscripts is released, I 
simply copied the ppp-watch program from my system backup tape, and replaced the rh 7.1 version.  Works like advertised, now.
Comment 4 Thomas Woerner 2004-08-13 05:25:00 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.