Bug 371111 - Cannot upgrade F7 -> F8 with DVD on x86_64
Cannot upgrade F7 -> F8 with DVD on x86_64
Status: CLOSED DUPLICATE of bug 372011
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 08:09 EST by Giacomo Succi
Modified: 2007-11-30 17:12 EST (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 14:53:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum loop (3.00 KB, text/plain)
2007-11-10 08:56 EST, Francis Kung
no flags Details
verbose yum output (1.56 MB, text/plain)
2007-11-11 04:20 EST, drago01
no flags Details

  None (edit)
Description Giacomo Succi 2007-11-08 08:09:24 EST
Description of problem:
During the upgrade phase of my existing Fedora installation the installer hang.
When the system check the dependencies of the packge the progress bar stop
progress after a while (the text install told me around the 25~26%) and the HDD
and DVD-Rom Driver leds stop blinking.

Version-Release number of selected component (if applicable):
Fedora 8 Final (x86_64 DVD)

How reproducible:
100%

Steps to Reproduce:
1. Insert DVD
2. Boot
3. Select "Install or upgrade an existing system" or "Install or upgrade an
existing system (text mode)"
4. Select "Upgrade an existing installation"
5. Choose the system to upgrade "Fedora 7 (/dev/VolGroup/LogVol00) in my case
6. Choose "Update boot loader configuration" or "Create new boot loader
configuration"
7. Choose "The GRUB boot loader will be installed on " (/dev/sda in my case)
8. Around the 25% of the "Checking dependencies in packages selected for
installation..." the installer stop working.
  
Actual results:
Apparent hang. Enter and switching VCs etc still works, but control-alt-delete
didn't. No progress.
On VC 3 I got 19 "14:00:02 WARNING : No package matched to remove".

Expected results:
The upgrade process continue happily.

Additional info:
Hardware is a Comex XP.521 (1,86GHz Intel Core 2 Duo, Intel 945 Express Chipset
Family, mouse wireless USB plugged). System currently boots F7 fine with the
standard setup.
Comment 1 Nils Philippsen 2007-11-08 08:29:39 EST
I had the same experience, not with the DVD but with an NFS install of the
(supposedly) same tree. After waiting for about 2 hours I gave up ;-).

As a workaround, I downloaded the Everything tree and copied over this
files/dirs from the Fedora to the Everything tree:

.treeinfo
images
isolinux
media.repo

Then I used the resulting combined tree as installation source.

From that I gather that anaconda has serious problems with upgrading systems
that have (lots of?) packages that aren't contained in the default media.
Perhaps anaconda should offer to add additional repos so the additional packages
can be upgraded as well and don't ruin the dependency solving step.
Comment 2 Vinu Moses 2007-11-08 12:20:28 EST
I experience the same problem when attempting to upgrade from FC7 -> FC8. The
only differences compared to the original poster is that I'm using 
1. an i386 DVD and not the x86_64 DVD
2. regular hard disk partitions and not LVM

The problem occurs regardless of whether I use the GUI or text mode option for
the upgrade and it freezes at about 25% of the "Checking dependencies in
packages selected for installation...".

I'd be glad if someone could suggest a fix for this problem (that is less
painful than #1) to help me get through with this upgrade.

(And, yes, as #1 mentioned, I do have quite a number of packages that are not on
the default media or the fedora everything repo).

My hardware:
Asus A8V-Deluxe motherboard (VIA KT800 chipset), Athlon X2 4200+ processor,
Sapphire Radeon X1950Pro graphics card, 2 GB Transcend DDR2 RAM, PS2 keyboard,
USB mouse, Seagate 160GB SATA hard disk connected to an inbuilt Promise PDC20378
(FastTrak 378/SATA 378) controller.
Comment 3 bwelling 2007-11-08 14:11:20 EST
I'm seeing the same problem when upgrading from F7 to F8, using the x86_64 DVD.
 I've tried installing twice, and both times it's hung at 26%.  An strace of the
anaconda process is pretty much the same as the one attached to bug #366641, and
it's using 100% of 1 CPU.

I definitely have some packages installed that aren't on the default install
DVD, but I don't think it's a huge number (and can't figure out how to list
installed RPMs by repository).
Comment 4 adriano 2007-11-08 17:46:17 EST
Same problem also for me.
FC8 i368 DVD:
- try to upgrade from fc7 on dell D620 (/dev/VolGroup/LogVol00) and anaconda
stops on 26% of "Checking dependencies..."
Comment 5 Ronald Kuetemeier 2007-11-08 23:56:29 EST
Got the same problem.  
Checked with yum list extras.  Seems it's only packages where the yum upgrade
failed during the year, I'm upgrading from FC6. I removed those packages and see
what happens. 
Comment 6 Bojan Smojver 2007-11-09 01:28:38 EST
Ditto DVD upgrade on i386. I did upgrade one box successfully, so the package
combo must be causing this.
Comment 7 Bojan Smojver 2007-11-09 05:25:46 EST
Indeed the problem was related to some packages for which the dependencies could
not be solved. Unfortunately, anaconda goes into an endless loop (yum does too
on attempt to yum update the OS) instead of just reporting that things won't
work out.
Comment 8 Nils Philippsen 2007-11-09 08:10:53 EST
(In reply to comment #7)
> Unfortunately, anaconda goes into an endless loop (yum does too
> on attempt to yum update the OS) instead of just reporting that things won't
> work out.

Anaconda shouldn't just report that things don't work out (if they don't work
out), it should also offer to add external repositories just like when
installing (ideally it would come with "fedora" and "fedora-updates"
pre-configured). That way most packages should already be up to date when
booting into the upgraded system.
Comment 9 adriano 2007-11-09 08:58:00 EST
I've updated my fedora 7 before upgrade to fedora 8, but nothing has changed.
Anaconda stops always at the same point...
Please fix it or suggest a workaround!!!!!!
Comment 10 Jeremy Katz 2007-11-09 09:10:21 EST
Can you try the update image at
http://katzj.fedorapeople.org/updates-f8-yumloop.img and see if it resolves the
problem?

The use of update images is described at
http://fedoraproject.org/wiki/Anaconda/Updates
Comment 11 Ronald Kuetemeier 2007-11-09 10:39:57 EST
I removed all packages reported by yum list extras. Same problem. Just hangs.
Comment 12 adriano 2007-11-09 11:20:09 EST
from http://fedoraproject.org/wiki/Anaconda/Updates I read:
...updates.img files provided by the Fedora project are gzip compressed cpio
archives"
But if I try to gunzip updates-f8-yumloop.img (renamed with extension .gz) I get
"not in gzip format".
So, putting it in a usb key, Anaconda stops just after dvd media test dialog.
Is file updates-f8-yumloop.img correct?
Comment 13 Bojan Smojver 2007-11-09 15:13:52 EST
Regarding comment #8 - sure - but if there is no salvaging, it should not be
stuck in the endless loop, is what I meant.

Back to figuring out why hibernate causes SATA/ext3 to go berserk...
Comment 14 adriano 2007-11-09 17:29:07 EST
(In reply to comment #10)
> Can you try the update image at
> http://katzj.fedorapeople.org/updates-f8-yumloop.img and see if it resolves the
> problem?
> 
> The use of update images is described at
> http://fedoraproject.org/wiki/Anaconda/Updates

Nothing changed with the update image.
I've repeated all the procedure (...and changed usb key from last try!) but the
behavior is always the same: anaconda loads updates from the pendrive but stops
at the same point of the "Checking dependencies in packages selected for
installation...".
Comment 15 Gustav Sverre Kampp 2007-11-10 05:58:49 EST
I have this problem too, exactly as described.
I have created a list of the packages I have installed and a sysreport, if this
can be helpfull to anyone.
Comment 16 Francis Kung 2007-11-10 08:56:02 EST
Created attachment 253921 [details]
yum loop

Pointing yum to the F8 DVD as a repository, disabling all other repositories,
and running "yum update" yields the attached loop.

I'll try uninstalling the third-party packages listed there to see if I can
pinpoint the culprit...
Comment 17 Levente Farkas 2007-11-10 09:08:18 EST
after searching different list i found the following solution works for me:
remove these packages:
java
jdk
libvirt
gtk-vnc
xen
duplicate openoffice packages (just no recoginzed after rpm -qa|grep openof|sort)
compiz
glib-devel
NetworkManager
dbus
expat
avahi
those pacakges which has not contains the above names don't need to remove it
remove these with 
rpm -e --nodeps
Comment 18 Thomas M Steenholdt 2007-11-10 10:42:04 EST
Having the same problem here...

For me it worked doing a "yum -y remove NetworkManager" prior to the upgrade. I
had previously tried to remove 3rd-party packages as much as possible, with no
luck. It seems, from the different things people have to remove to work around
this issue, to be largely dependent on the packages installed. Isn't there a way
to make anaconda more verbose so we can catch these loops etc. in anaconda
itself, rather than having to setup mediarepos and running yum from an installed
system? That might be useful for this, and future anaconda problems!?
Comment 19 Francis Kung 2007-11-10 14:13:11 EST
+1 on anaconda verbosity, though that only helps for people willing to do manual
package removals & re-installations.  In my case, after resolving the dependency
loop (which I'll blame a third-party package for), I ran into a long list of
failed dependencies.

I ended up forcibly removing a number of packages, both official Fedora ones and
3rd-party ones, to get rid of conflicts.  The biggest culprits seemed to be:

devel packages , as I suppose they aren't on the DVD but are tied to a
particular version of a package and thus hold back upgrades.

multi-lib problems: if you have both the i386 and x86_64 versions of a package
installed, sometimes the installed i386 will conflict with an update attempt on
the x86_64 version (I'm guessing when an updated x86_64 version is available
without a corresponding i386 update)
Comment 20 drago01 2007-11-10 14:46:29 EST
I saw this on two boxes had to delete wireless-tools-devel, avahi-compact-howl,
ImageMagick and  expat to get it working
Comment 21 Michal Schmidt 2007-11-10 16:04:36 EST
According to some, the problem occurs even when attempting to upgrade with yum 
(without anaconda). yum goes to an infinite loop resolving dependencies:
https://www.redhat.com/archives/fedora-devel-list/2007-November/msg00562.html
I saw very similar reports here (in Czech, sorry):
http://www.abclinuxu.cz/blog/publish/2007/11/9/199508

Should this bug be reassigned to yum?
Comment 22 drago01 2007-11-11 04:20:26 EST
Created attachment 254301 [details]
verbose yum output

Yes it is a yum bug. I have attached the output of yum using only the dvd as
repo.
I cannot do any other tests because after deleting the packages I mentioned
above, I was able to update. (also saw this issue on 2 F7 boxes, but FC6->F8
worked just fine)
Comment 23 Francis Kung 2007-11-11 16:46:21 EST
After resolving the yum loop, I tried another Anaconda upgrade, and it still
hung at 26%.  Running a yum update against the DVD, it listed a number of
missing dependencies (but no loop) - so at the very least, at that point
Anaconda should tell me there is a problem, rather than hanging.
Comment 24 Jeremy Katz 2007-11-12 14:53:23 EST

*** This bug has been marked as a duplicate of 372011 ***
Comment 25 zak 2007-11-29 23:22:09 EST
cd-record is one of the culprits, I think. It probably has something to do with
the package being dropped from distros due to the licensing issue. 

I think that if the anaconda installer just displayed the name of the package it
was looking for dependencies for, it would cut down the strife users are
experiencing greatly, as they could just remove the one troublesome package and
continue. I had to rpm -e over 600 packages before it worked :/

Note You need to log in before you can comment on or make changes to this bug.