Bug 366641 - can't upgrade F7 to F8rc3
can't upgrade F7 to F8rc3
Status: CLOSED DUPLICATE of bug 372011
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: 373891 374951 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-11-05 06:26 EST by Tomasz Torcz
Modified: 2007-11-30 17:12 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-12 14:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
install log from another run (22.75 KB, text/plain)
2007-11-05 07:01 EST, Tomasz Torcz
no flags Details
strace output (818.78 KB, text/plain)
2007-11-07 05:01 EST, Joe Orton
no flags Details
anaconda.log (28.32 KB, text/plain)
2007-11-07 05:03 EST, Joe Orton
no flags Details

  None (edit)
Description Tomasz Torcz 2007-11-05 06:26:09 EST
Description of problem:
I tried to upgrade my Fedora 7 (x86_64) installation to Fedora 8rc3.
Installer hangs at about 1/5 progress bar of ,,Checking selected packages
dependecies'' (sorry for reverse-translation). One of anaconda
processes uses 100% CPU, reading from some rpm files (Packages?),
but modification date of files opened by this process do not change.
Last lines from anaconda.log:

INFO: no groups missing
INFO: initscripts is arch: x86_64
INFO: po.arch is arch: x86_64
INFO: moving (1) to step post selection
INFO: selected kernel package for kernel
WARNING: No package matched to remove
WARNING: No package matched to remove
WARNING: No package matched to remove

last line repeates itself about 20 times.

I removed all F7 kernels except latest (2.6.23-something). I also
removed nVidia driver for livna -- there is only Xorg "xv" driver installed.
I do not have any 3rd party kernel modules.

How reproducible:
Comment 1 Tomasz Torcz 2007-11-05 07:01:25 EST
Created attachment 247901 [details]
install log from another run
Comment 2 Tomasz Torcz 2007-11-06 03:39:13 EST
Tried both GUI and text installer, with English and Polish locale. I even left
installer overnight. No success. Still goes to 25% and stays here.
Comment 3 Joe Orton 2007-11-07 04:59:50 EST
I see the same on my x86_64 workstation.

Comment 4 Joe Orton 2007-11-07 05:01:28 EST
Created attachment 249931 [details]
strace output

anaconda was stuck resolving dependencies, consuming about 50% CPU, progress
bar at about 25%, eating about 1M of RAM every couple of minutes.  strace
capture attached.
Comment 5 Joe Orton 2007-11-07 05:03:02 EST
Created attachment 249941 [details]
Comment 7 Paul Lemmons 2007-11-08 16:21:41 EST
This bug is also evident in the final F8 release and is seen in the 32bit
install as well. 
Comment 8 Carl-Johan Kjellander 2007-11-09 04:37:59 EST
I and several other on #fedora we're hit by this as well. Both on i386 and
x86_64 trying to upgrade F7 -> F8 final.

It probably has something to do with third party repos and inconsitencies in our
rpm databases. In the end I upgraded fedora-release to the F8 version and then
did a 'yum --obsoletes update' and resolved any issues that came up. On my two
machines I had to do the following to get the install running.

yum remove yelp gstreamer-plugins-ugly-devel
yum remove beryl-kde beryl-gnome
yum remove dbus-1.x.x-x.fc7.i386 compiz-x.x.x-x.fc7.i386 (on x86_64)

I think the version should be changed to Fedora 8, cause it is most definetely
will hit thousands of users trying to upgrade to it now.
Comment 9 Jeremy Katz 2007-11-09 09:27:26 EST
Can you try with the update image at
http://katzj.fedorapeople.org/updates-f8-yumloop.img and see if it resolves the
problem for you?

Information on using an updates.img can be found at
Comment 10 Paul Lemmons 2007-11-09 11:33:14 EST
I don't have time to really test this right now but it might be worth noting
that if you do want to try it you are going to have to be quick fingered during
the boot-up. As soon as you see the ISOLinux appear on your screen press the
ESCape key so that you can enter the "linux updeates=..." command.

I gave it a real quick go and it still stalled at 26%. I gave it 5 minutes and
aborted. It may be that I was not patient enough.
Comment 11 Joe Orton 2007-11-09 11:42:05 EST
Hangs in the same way for me with updates-f8-yumloop.img.
Comment 12 Frank Cox 2007-11-09 13:42:57 EST
I have the same problem trying to update from F7 to F8 (32-bit install).  I am
booting from a CDR then pointing the installer to the DVD image on my fileserver.

It gets to about 25% of "resolving dependencies" and never moves on from there.
 I left it overnight and it was still at 25% nine hours later.

I just tried it again with the
http://katzj.fedorapeople.org/updates-f8-yumloop.img  mentioned above.  Nothing
changed, other than that the installer mentioned that it had loaded the
"yumloop.img".  I left it for an hour and it was still at about 25% of
"resolving dependencies".
Comment 13 Jack Tanner 2007-11-09 15:15:51 EST
Same here. Booting from DVD on x86-64. Haven't tried updates-f8-yumloop yet.
Comment 14 Michael Fleming 2007-11-10 01:34:50 EST
Tried with updates-f8-yumloop, got to 26% initially, removing
NetworkManager(-gnome) got me to 28% but still encountered the same problem as
others have reported.

x86_64, from DVD - machine is a AMD Sempron 3300+
Comment 15 Mariusz Wodzicki 2007-11-10 07:26:27 EST
I am experiencing EXACTLY the same problem: while upgrading F7->F8 the installer
hangs doing "Checking dependencies" at the 26% mark. It doesn't move a bit even
after several hours.

Never had problems on this computer with upgrades before, and I went through all
the consecutive upgrades starting from Red Hat 7.3 until Fedora 7. I haven't
added any fancy packages since upgrading to Fedora 7.

IBM Thinkpad A31p, 1.7GHz Pentium 4
Comment 16 Tobias Vogel 2007-11-10 08:44:48 EST
same here.
AMD Turion 64 X2 3200
Dell Inspiron 1501
Comment 17 Matthew Opoka 2007-11-10 09:22:05 EST
Originally, I was hanging at ~25% as well while upgrading from FC7 to FC8.  I 
removed all third party repos, livna and reshrpms.  Next, I removed all rpm 
ending in lvnX.  Then I removed third party rpms such as Java, adobe reader, 
and webmin. After removing the above, I am now hanging at ~99%.

x86 Pentium 4 HT EE 3.2Ghz
Comment 18 jar 2007-11-10 09:48:17 EST
Same here. I am hanging at ~27% when trying to upgrade from Fedora Core 6 to
Fedora 8.

x86 Pentium 2 300Mhz 256RAM
Comment 19 cjlarsson 2007-11-10 09:56:23 EST
I too experienced the 26% update problem.  Removing third party repos (livna, 
etc) did not change anything for me.  What did work was removing all of the 
compiz packages.  Earlier I had installed compiz-fusion on F7.  Pulling all of 
the compiz-fusion stuff off the machine before doing the upgrade got me past 
the 26% mark.  However the dependency check is still very slow, and at this 
rate may complete in about 25-30 minutes (assuming it does complete).
Comment 20 Jeremy Fitzhardinge 2007-11-10 10:54:44 EST
I saw exactly the same thing when updating my i386 from F7->F8.  I'll try again
after removing all the compiz/beryl packages.
Comment 21 Nick Lamb 2007-11-10 11:40:26 EST
Same here, 27% according to the text mode upgrade progress meter

In my case updating from FC6 to Fedora 8 final i386

My guess is that Anaconda doesn't cope with any packages it doesn't know to
upgrade. Previous Fedora, Fedora Core and Red Hat releases would ignore such a
package, even if necessary leaving it inoperable (e.g. by replacing a library it
needed with an incompatible newer version). It's much easier to fix one or two
broken packages after an otherwise successful update than to be left with this hang.

Can someone sufficiently empowered please update the summary to reflect that
this urgent bug affects the product that was just released, rather than only a
release candidate?

I see that this is yet another product which has a completely anonymous and
unresponsive (didn't even ACCEPT the bug) "owner". If anaconda is in fact
orphaned, Fedora 9 should be held until Anaconda can be removed and replaced
with something that's actually maintained.
Comment 22 Jim 2007-11-10 13:14:39 EST
Toshiba Satellite M45 S296

Same deal: hangs at about 25%-28% and does not recover ... ever (and I have
waited a long time).

I have tried all the tricks posted on various websites (most related acpi stuff)
but nothing helps.  I have used/upgraded each release of Fedora from Fedora Core 3. 

I am disappointed that this release is such a disaster.

Jim Cicon
Comment 23 Tobias Vogel 2007-11-10 14:58:21 EST
doing 'yum list extras'

and removing these packages as well as all the livna packages
worked for me. it seems as it hangs as soon as there is a package
it cannot update...
Comment 24 cjlarsson 2007-11-10 21:06:10 EST
Seconding Tobias' solution.  I too got a smooth update after removing the
packages listed by 'yum list extras'.

Comment 25 Jim 2007-11-11 01:03:57 EST
Toshiba Satellite M45 S296

Ran 'yum list extras'.  Lists stuff like 
 etc, etc, etc

I don't think I should remove packages like 'kernel.i686'.  And if I remove
packages like koffice-suite, it doesn't matter if I can upgrade or not because I
won't be able to get any work done.

Jim Cicon 
Comment 26 jar 2007-11-11 08:58:18 EST
(In reply to comment #24)
> Seconding Tobias' solution.  I too got a smooth update after removing the
> packages listed by 'yum list extras'.

Unfortunately this doesn't help me (FC6-->F8). I have following packages (3)
under extras:

diskcheck.noarch    2:1.6-1           installed
kernel.i686   installed
kernel-devel.i686   installed

I removed them all (3), and still it hangs in 27%. I wonder if it is possible to
see somewhere the package name the anaconda hangs.
Comment 27 David Juran 2007-11-11 09:18:36 EST
*** Bug 374951 has been marked as a duplicate of this bug. ***
Comment 28 David Juran 2007-11-11 09:19:29 EST
*** Bug 373891 has been marked as a duplicate of this bug. ***
Comment 29 Nick Lamb 2007-11-12 13:32:20 EST
David, (or someone else empowered) can you merge this with bug 371111 and bug
372011 which are the same problem, reported against Fedora 8 final.

And also please update the summary to remove the mention of release candidate 3,
which is now historical and mention the word "hang" in there since that's a
likely search term (Anaconda doesn't really hang, it's actually spinning, but it
appears to hang so far as the user is concerned).
Comment 30 Jeremy Fitzhardinge 2007-11-12 13:39:22 EST
I removed all packages listed by "yum list extras", and it nearly worked - it
got past the ~25% mark, but spun in the same way at around 99%.  Thinking I'll
just do a yum-based update...
Comment 31 Jeremy Katz 2007-11-12 14:53:12 EST

*** This bug has been marked as a duplicate of 372011 ***
Comment 32 Masoud Pajoh 2007-11-13 16:12:08 EST
It happens to me too.
It goes through checking dependencies up to , guessing, 99.9% then itstalls.
This on a 64bt installation.
Comment 33 josip 2007-11-18 00:02:28 EST
Same here: x86_64 platforms, upgrade stalls at "checking dependencies" but clean
install works.  Unfortunately, in most cases clean install isn't feasible.

Note You need to log in before you can comment on or make changes to this bug.