Bug 371521 - crash when opening torrent file
crash when opening torrent file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 12:21 EST by Dan Horák
Modified: 2008-01-15 18:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 12:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output (3.35 KB, text/plain)
2007-11-08 12:21 EST, Dan Horák
no flags Details
hs_err log from crashed vm (44.51 KB, text/plain)
2007-11-14 18:24 EST, Christian Nolte
no flags Details

  None (edit)
Description Dan Horák 2007-11-08 12:21:34 EST
Description of problem:
Azureus crashes when I try to open a torrent file (directly from web or stored
on filesystem). Also it is not possible to start Azureus with a $HOME/.azureus
directory containing some configuration with distributed files. I had to rm
$HOME/.azureus and then go through the first start wizard.


Version-Release number of selected component (if applicable):
azureus-2.5.0.4-3.fc8

How reproducible:
always


Steps to Reproduce:
1. start Azureus
2. Ctrl+O (Open/.torrent file)
3. press Add files button
  
Actual results:
in this state it shows the file selection dialog for a second and then crashes

Expected results:
show the dialog and let me select the file

Additional info:
my locale is cs_CZ.UTF-8, when starting with "LANG=C azureus" it works
Comment 1 Dan Horák 2007-11-08 12:21:34 EST
Created attachment 251851 [details]
console output
Comment 2 Christian Nolte 2007-11-14 18:23:26 EST
I can confirm this. Starting azureus with existing configuration and torrents
(~/.azureus) with LANG other than 'C' azureus crashes. The console output then
is the following:

[nolte@ravine ~]$ export LANG=C
[nolte@ravine ~]$ azureus
changeLocale: *Default Language* != English (United States). Searching without
country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)'
(en_US), using 'English (default)'
DEBUG::Thu Nov 15 00:19:27 CET
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::512:
  java.lang.NullPointerException
        at
org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(SWTUpdateChecker.java:67)
        at
org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Initializer.java:258)
        at
com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(AzureusCoreImpl.java:508)
        at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)

I am using the Iced Tea VM. When starting azureus without setting LANG=C the VM
crashes and the output is:

[nolte@ravine ~]$ azureus
DEBUG::Thu Nov 15 00:21:25 CET
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::512:
  java.lang.NullPointerException
        at
org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(SWTUpdateChecker.java:67)
        at
org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Initializer.java:258)
        at
com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(AzureusCoreImpl.java:508)
        at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0377be62, pid=7762, tid=14547856
#
# Java VM: IcedTea Server VM (1.7.0-b21 mixed mode linux-x86)
# Problematic frame:
# C  [libgtkjni-2.8.so+0x7ae62]
#
# An error report file with more information is saved as:
# /home/nolte/hs_err_pid7762.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
/usr/bin/azureus: line 18:  7762 Abgebrochen            
LD_LIBRARY_PATH=/usr/lib/eclipse:/usr/lib
CLASSPATH=/usr/lib/eclipse/swt-gtk-3.3.jar:`build-classpath bcprov
jakarta-commons-cli log4j gtk2.8 glib0.2`:/usr/share/azureus/Azureus2.jar java
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dazureus.install.path=$APPDIR org.gudy.azureus2.ui.swt.Main "$@"

This bug seems to be related to bug #376111.
Comment 3 Christian Nolte 2007-11-14 18:24:10 EST
Created attachment 259091 [details]
hs_err log from crashed vm
Comment 4 Lillian Angel 2007-11-30 10:14:10 EST
I can't reproduce this. Try updating (from rawhide) to:
java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9
azureus-2.5.0.4-4.fc9
Comment 5 Lillian Angel 2007-12-03 12:07:35 EST
Updated to azureus-3.0.3.4-1.fc9. 
Should be available tomorrow in rawhide.
Comment 6 Fedora Update System 2008-01-15 18:04:35 EST
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.