Bug 371741 - multilib breakage involving gmcs
multilib breakage involving gmcs
Status: CLOSED DUPLICATE of bug 371781
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-08 14:44 EST by David Nielsen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 21:51:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2007-11-08 14:44:56 EST
Description of problem:
Whenever I try to compile something mono based gmcs fails with:

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.

Now the fun bit is that it's not even supposed to look there, I removed all the
i386 packages to have a clean x86_64 system. So really it's supposed to pick up
 /usr/lib64/mono/2.0/mscorlib.dll which is present.

Version-Release number of selected component (if applicable):
mono-core-1.2.5.1-2.fc8

How reproducible:
100%

Steps to Reproduce:
1. run gmcs
  
Actual results:
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.

Expected results:
Please stop hurting me and my innocent ndesk-dbus build.

Additional info:
x86_64 X2, da_DK.UTF-8, added Paul Johnson to CC.
Comment 1 Paul F. Johnson 2007-11-08 16:08:39 EST
I can confirm this. It looks like something is being misdirected. I'll see if I
can trace it.
Comment 2 David Nielsen 2007-11-09 02:10:01 EST
Turns out this blows away Banshee as well as Tomboy (which I believe we ship by
default) which means directly breaking default apps shortly after release, so
I'm setting this F8Target.
Comment 3 Peter Gordon 2007-11-09 17:12:16 EST
I can't rebuild Blam for the recent Firefox update, either. :(
Comment 4 Ray Strode [halfline] 2007-11-09 21:51:57 EST

*** This bug has been marked as a duplicate of 371781 ***

Note You need to log in before you can comment on or make changes to this bug.