Bug 371781 - x86_64 tomboy won't run without i386 mono-core
x86_64 tomboy won't run without i386 mono-core
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
: 371741 373731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 15:26 EST by Thomas J. Baker
Modified: 2007-11-30 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.2.5.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 01:01:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch. Applies to both F-8 and devel (515 bytes, patch)
2007-11-09 14:31 EST, Eskil Bylund
no flags Details | Diff

  None (edit)
Description Thomas J. Baker 2007-11-08 15:26:51 EST
Fresh x86_64 install of F8, tomboy won't run:

continuity> tomboy
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.
continuity> sudo yum whatprovides /usr/lib/mono/2.0/mscorlib.dll
Loading "basearchonly" plugin
Importing additional filelist information
mono-core.i386 : The Mono CIL runtime, suitable for running .NET code
mono-core.i386 : The Mono CIL runtime, suitable for running .NET code
continuity> rpm -q mono-core
mono-core-1.2.5.1-2.fc8.x86_64
continuity> rpm -q tomboy
tomboy-0.8.1-1.fc8.x86_64
continuity> 

So x86_64 tomboy needs i386 mono-core to run even though x86_64 mono-core is
installed. I didn't see this in rawhide.
Comment 1 Arkady L. Shane 2007-11-09 03:28:15 EST
This problem has appeared after updating mono to 1.2.5.1 from f8-updates!

All mono application does not work. For hotfix we can make a link:
ln -s /usr/lib64/mono/ /usr/lib/mono
Comment 2 Eskil Bylund 2007-11-09 14:31:09 EST
Created attachment 253291 [details]
Proposed patch. Applies to both F-8 and devel

It seems to me that patch #6 (mono-1251-metadata.patch) was forgotten on the
update to 1.2.5.1.
Comment 3 Thomas J. Baker 2007-11-09 19:56:57 EST
koji build with patch added back fixes it for me.
Comment 4 Ray Strode [halfline] 2007-11-09 21:51:58 EST
*** Bug 371741 has been marked as a duplicate of this bug. ***
Comment 5 Sindre Pedersen Bjørdal 2007-11-09 21:59:43 EST
*** Bug 373731 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2007-11-10 01:01:23 EST
mono-1.2.5.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.