Bug 37194 - Kernel crash when playing sound with i810_audio module
Kernel crash when playing sound with i810_audio module
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Depends On:
  Show dependency treegraph
Reported: 2001-04-23 09:34 EDT by Tim Lundstrvm
Modified: 2007-04-18 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-30 00:07:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Lundstrvm 2001-04-23 09:34:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

I got an Intel 810 sound card in my PIII 1 GHz dual processor machine (Dell
Precision 220). When I play a sound with (for example) XMMS I get a kernel
crash (using kernel 2.4.2-2) when I STOP playing the 2nd time. No Panic
message, just a system freeze. It worked just fine with the 2.2.17 kernel.

Reproducible: Always
Steps to Reproduce:
1. Play a file in XMMS (or mpg123 or...)
2. Stop playing and exit program
3. Start playing a new file
4. Stop playing

Actual Results:  Sysem freeze and do not respond to mouse, keyboard,
network etc.

Expected Results:  The system to continue running
Comment 1 Need Real Name 2001-05-28 17:38:20 EDT
If you open XMMS and goto properties, and change the Output plugin (under Audio
I/O plugins) to the OSS driver (libesdout.so) it works fine. Also, this problem
only occurs for dual cpu users. if you change to a single cpu kernel it will
work fine. the problem stems from using irq numbers over 16, due to there only
being 4 bits for the irq number. with the dual cpu going, the soundcards get
irqs greater then 16 and cause a lockup.

perhaps there is some way to ensure the soundcard gets a irq lower then 16?
Comment 2 Need Real Name 2001-05-28 17:49:18 EDT
I should say, with the OSS driver XMMS and _only_ XMMS works fine, but if all
you do is play mp3s thats all you need. No idea why.

With the single CPU kernel however, all sound works fine. Most likely because of
the lower irq settings.
Comment 3 Tim Lundstrvm 2001-05-29 04:20:54 EDT
You are right! The soundcard is using irq 17. The problem is that this computer
is used for simulations (and on occasion playing music while I work) and need
the SMP-kernel, so using the single CPU kernel is not an option. I can't find
any (obvious) way to change the IRQ setting (enlight me if I'm wrong, please).

The problem is I use the computer for playing movies too and the movieplayer
makes the kernel to hang too.
Comment 4 Need Real Name 2001-06-30 00:07:16 EDT
My computer hangs whenever I try to run any sound based applications.  But I 
could play audio CD's (only).  When I run sndconfig, a test is played, after 
which the system completely freezes.  No action of keyboard. When I move mouse, 
the test is played again.  Don't know what to do.  I have Intel 810E Mercury 
chipset motherboard with inbuilt PCI sound card.  Please help me out of this 
Comment 5 Doug Ledford 2001-08-02 13:29:49 EDT
This problem has beed fixed in the latest Red Hat Rawhide kernels.
Comment 6 Need Real Name 2001-08-03 08:36:05 EDT
the system often crashes if tried to play sound with i810 AC'97 sound card. I 
observe that it is better to use terminal to shut down the system. Can you 
please help me??The system has started crashing after that if tried to shut 
with the panel.
Comment 7 Need Real Name 2001-08-03 10:51:17 EDT
I possess a AC'97 sound card in my PIII 735 Mhz computer which is used as a pc.
It possess i810e motherboard . The first time i tried to play sound with it , 
it crashed.
When i tried to solve it by entering setup in terminal mode it detected my 
sound card but 
failed to produce any sound while testing. The condition is that it often 
crashes after that
 incident, mostly when trying to logoff by clicking the task bar. It works fine 
when I log 
off in terminal mode.  I have heard that Linux is very much stable but it has 
crashed more than my other O.S.,  Windows 2000. Please help.
Comment 8 Need Real Name 2002-03-19 03:53:18 EST

     Dear Sir
                 I am a student of INFORMATION TECHNOLOGY studying at IIIT-
CALCUTTA (INDIA). I had installed LINUX 7.2 (coming with Linux bible book 
namely REDHAT LINUX 7.2 BIBLE) on my machine which has configuration as follows:
   After installation, I found that Linux was unable to load sound drivers 
namely INTEL i810 AC 97 audio. While trying to configure sound 
through sndconfig, it finds the following:
          Model: Intel corporation 182801BA/BAM (ICH2)
           Ac 97 Audio controller
Then it shows:
            sox : cant open output file /dev/dsp: Device or resource busy
Then manual configuration starts. I have also Windows-Xp in dual boot. I have 
installed Linux not in first 10 Gb of hard disk and installed Grub loader.
 Also while running any video, it hangs and physical memory reduces to 2.4Mb to 
5Mb. While configuring sound server through control center ,it gives message 
           Sound server fatal error :CPU Overload aborting
 I am unable to listen music and play video. Every time I boot my machine in 
Linux 7.2, it boots quit O.K. but physical memory reduces to 7  13 Mb.
I shall be highly obliged if I get reply from your side.
        Thanking you
Yours sincerely

Comment 9 Need Real Name 2002-11-16 06:12:35 EST
I am Varun Sharma studying in final year BE in comp. sc.i am a linux buff.i use 
it quite often.but when i insert a video cd to play it in KDE player/GTV the 
sytem hangs despite all my efforts.please suggest me a solution.i have got 
PIII,866 MHz,intel 810e,ASUS mboard,AC 97 Audio.
Comment 10 zameer ahmed syed 2004-12-21 06:10:47 EST
Hi, Everybody..... 
I am zameer ahmed ... new bie to linux...

I am Hanging here for sound since from last two days...this is third
day.... Is anybody there to help me.......Again I am repeating my
problem with sound card.......

The OS loaded in my system was LAS 3.0

I am having Compaq branded system.... with "INBUILT SOUND CARD" named
"Intel Corp.|82801DB (ICH4) AC'97 Audio Controller" and it is having
default driver "i810_audio"...Infact my sound card details are as
follows from etc/sysconfig/hwconf.............

class: AUDIO
bus: PCI
detached: 0
driver: i810_audio
desc: "Intel Corp.|82801DB (ICH4) AC'97 Audio Controller"
vendorId: 8086
deviceId: 24c5
subVendorId: 13f6
subDeviceId: 0300
pciType: 1
pcibus: 0
pcidev: 1f
pcifn: 5

My Trails: I select "soundcard Detection" option from system
settings....here i found an option "play test sound"... then i click
on play test sound.....after sometime i got a message like did u heard
any sound .... then i clicked on No option....thereafter i found this
error message " Automatic detection of the sound card did not work "
audio will not be available on the system"...

then I downloaded ALSA (alsa-drivers,alsa-lib,alsa-utilities) named
i) alsa-drivers.1.0.7rc2.tar.bz2
ii) alsa-lib.1.0.7rc2.tar.bz2
iii) alsa-utils.1.0.7rc2.tar.bz2

and i compile them with tar xvjf option
then i installed all of them

no change in the system.... still i didn't found any sound... what to

My Question : Is my driver /inbuilt soundcard didn't support LAS 3.0 ?
( or)
Is any other porcess.......

any help would be appreciate.......

Thanx in advance...

Zameer ahmed syed
email: zameer_india@yahoo.com (most preferable)

---------awaiting for reply----------------------

Note You need to log in before you can comment on or make changes to this bug.